Thx for the revision,
> +/* Removes 'rule' from 'cls', also destructing the 'rule'. */
> +static void
> +dpcls_remove(struct dpcls *cls, struct dpcls_rule *rule)
> +{
> +struct dpcls_subtable *subtable;
> +
> +ovs_assert(rule->mask);
> +
> +INIT_CONTAINER(subtable, rule->mask, mask);
Signed-off-by: Nithin Raju
---
datapath-windows/ovsext/Flow.c | 43 ---
1 files changed, 22 insertions(+), 21 deletions(-)
diff --git a/datapath-windows/ovsext/Flow.c b/datapath-windows/ovsext/Flow.c
index f3ee726..fa61262 100644
--- a/datapath-windows/ovsex
A couple of miscellaneous fixes in code that creates a packet for
userspace as well as when we copy the packet to memory specified by
userspace.
Signed-off-by: Nithin Raju
---
datapath-windows/ovsext/User.c | 12 +---
1 files changed, 9 insertions(+), 3 deletions(-)
diff --git a/datap
In nl_sock_recv__() on Windows, we realloc a new ofpbuf to copy received
data if the caller specified buffer is small. While we do so, we need
reset some of the other stack variables to point to the new ofpbuf.
Other fixes are around using 'error' rather than 'errno'.
Acked-by: Nithin Raju
---
The semantics are read operation are generally to return 0 bytes and
STATUS_SUCCESS when there are no events.
Also, added a fix to assign the PID to the synthetic OVS_MESSAGE formed
for the command validation.
Signed-off-by: Nithin Raju
---
datapath-windows/ovsext/Datapath.c |4
1 file
In this patch, we fix a few buglets found during while testing packet
receive functionality.
Nithin Raju (4):
datapath-windows: event read should not fail when no events
datapath-windows: fixes in Flow.c in key parsing
datapath-windows: Fixes in packet created for userspace
lib/netlink-soc
Fixes a rpmbuild failure.
Signed-off-by: Gurucharan Shetty
---
xenserver/openvswitch-xen.spec.in |1 +
1 file changed, 1 insertion(+)
diff --git a/xenserver/openvswitch-xen.spec.in
b/xenserver/openvswitch-xen.spec.in
index bd82681..88cab56 100644
--- a/xenserver/openvswitch-xen.spec.in
+++
We work together, and talk about how to resolve this problem. Written by
dongdong, reviewed by me.
I generate the patch and send to you. The Author is Dongdong, you could remove
my signed off.
Thanks.
>-Original Message-
>From: Ben Pfaff [mailto:b...@nicira.com]
>Sent: Friday, October
Simon, The change makes a lot of sense.
I am just wondering if we should upstream the netlink.h change first?
To me, it seems to add a new compat API that does not exist upstream.
On Wed, Sep 24, 2014 at 9:28 PM, Simon Horman
wrote:
> The original motivation for this change was to allow the
> h
Datapath flows are created on demand, as packets with different relevant header
fields arrive, and are also deleted if idle or if there are too many of them,
so the "explosion" is controlled and typically minimal.
Jarno
> On Oct 16, 2014, at 4:17 PM, Learner Study wrote:
>
> Hi Jarno,
>
>
This patch changes the classifier internal mutex to a recursive type.
This allows simplification of locking during iteration.
Accurate iteration requires classifier_inserts to be exluded during
iteration. To this end we take the internal mutex at the start of the
iteration. To allow rule removal
Hi Jarno,
But won't it cause flow-explosion issue when a single table replaces
multiple tables...
I agree the userspace would merge all the rules from multiple tables
and provide a single entry which is good. But won't it lead to
explosion of flows that we see with OF 1.0...having multiple table
This change includes the following:
[1] Handler for subscribe/unsubscribe to a packet queue associated with a
socket pid.
[2] Allocation of per socket packet queue on a packet subscription.
[3] Removal of static allocated queues.
[4] Freeing the packet queue (on user mode process termination).
On Thu, Oct 16, 2014 at 10:14:21PM +, Nithin Raju wrote:
> > -Original Message-
> > From: Ben Pfaff [mailto:b...@nicira.com]
> > Sent: Thursday, October 16, 2014 3:09 PM
> > To: Nithin Raju
> > Cc: Eitan Eliahu; dev@openvswitch.org
> > Subject: Re: [ovs-dev] [PATCH v2] datapath-windows:
On Thu, Oct 16, 2014 at 03:30:15PM -0700, Alex Wang wrote:
> On Thu, Oct 16, 2014 at 3:20 PM, Ben Pfaff wrote:
>
> > I understand now.
> >
> > I agree that it makes sense to have a way to print the usage in an
> > easily parsed way. But I don't think that making --help and "help" do
> > differen
On Tue, Oct 14, 2014 at 10:01 AM, David Verbeiren
wrote:
> DPDK rings don't need one queue per PMD thread and don't support multiple
> queues (set_multiq function is undefined). To fix operation with DPDK rings,
> this patch ignores EOPNOTSUPP error on netdev_set_multiq() and provides, for
> DPDK
On Thu, Oct 16, 2014 at 3:20 PM, Ben Pfaff wrote:
> I understand now.
>
> I agree that it makes sense to have a way to print the usage in an
> easily parsed way. But I don't think that making --help and "help" do
> different things is a good distinction, because both forms are common
> ways to g
On Thu, Oct 16, 2014 at 03:19:03PM -0700, Alex Wang wrote:
> On Thu, Oct 16, 2014 at 3:00 PM, Ben Pfaff wrote:
>
> > This is simpler and shorter than handling each of these by itself.
> >
> > CC: Niels van Adrichem
> > Suggested-by: Alex Wang
> > Signed-off-by: Ben Pfaff
> > ---
> > ofproto/o
Thanks for the review Ankur.
Will use ARRAY_SIZE for the attribute.
We cannot send a transactional message as this message is not a transaction
based message.
Eitan
-Original Message-
From: Ankur Sharma
Sent: Thursday, October 16, 2014 3:17 PM
To: Eitan Eliahu; dev@openvswitch.org
Subje
I understand now.
I agree that it makes sense to have a way to print the usage in an
easily parsed way. But I don't think that making --help and "help" do
different things is a good distinction, because both forms are common
ways to get a program to give human-readable help. How about using a
di
On Thu, Oct 16, 2014 at 3:00 PM, Ben Pfaff wrote:
> This is simpler and shorter than handling each of these by itself.
>
> CC: Niels van Adrichem
> Suggested-by: Alex Wang
> Signed-off-by: Ben Pfaff
> ---
> ofproto/ofproto-dpif-xlate.c | 17 ++---
> 1 file changed, 2 insertions(
Hi Eitan,
Minor comments:
1. OvsSubscribePacketCmdHandler
PNL_ATTR attrs[2]; <-- as per my understanding the size of array should be
equal to max attr type.
Add code for transactional error, as OvsSubscribeDpIoctl may return
STATUS_NO_MEMORY
2. OvsGetQueue
Fix the typo in comment:
/* XXX To
> -Original Message-
> From: Ben Pfaff [mailto:b...@nicira.com]
> Sent: Thursday, October 16, 2014 3:09 PM
> To: Nithin Raju
> Cc: Eitan Eliahu; dev@openvswitch.org
> Subject: Re: [ovs-dev] [PATCH v2] datapath-windows: packet miss read NL
> command
>
> OK. Nithin, if you will send an offi
OK. Nithin, if you will send an official Signed-off-by (on-list),
then I'll make it happen.
Thanks,
Ben.
On Thu, Oct 16, 2014 at 09:51:28PM +, Eitan Eliahu wrote:
> Ben,
> It is a final version of this change. Can you please add Nithin as a
> co-author Nithin? I can add him to the commit m
On Thu, Oct 16, 2014 at 02:14:11PM -0700, Alex Wang wrote:
> On Thu, Oct 16, 2014 at 1:47 PM, Ben Pfaff wrote:
>
> > On Thu, Oct 16, 2014 at 12:53:50PM -0700, Alex Wang wrote:
> > > >
> > > > >
> > > > > Signed-off-by: Niels van Adrichem
> > > >
> > > > Thanks. I applied this. It is definitely
This is simpler and shorter than handling each of these by itself.
CC: Niels van Adrichem
Suggested-by: Alex Wang
Signed-off-by: Ben Pfaff
---
ofproto/ofproto-dpif-xlate.c | 17 ++---
1 file changed, 2 insertions(+), 15 deletions(-)
diff --git a/ofproto/ofproto-dpif-xlate.c b/of
Ben,
It is a final version of this change. Can you please add Nithin as a co-author
Nithin? I can add him to the commit message and resubmit if you wish?
Thanks,
Eitan
-Original Message-
From: Ben Pfaff [mailto:b...@nicira.com]
Sent: Thursday, October 16, 2014 2:49 PM
To: Nithin Raju
Cc:
Sorry for the confusion, I mean:
`command --help (or -h)` still prints out the usage page,
`command help` prints the function format (usage).
What do you think?
Thanks,
Alex Wang,
On Thu, Oct 16, 2014 at 2:41 PM, Ben Pfaff wrote:
> On Wed, Oct 15, 2014 at 09:51:54AM -0700, Alex Wang wrote:
On Thu, Oct 16, 2014 at 07:16:58PM +, Nithin Raju wrote:
> > -Original Message-
> > From: dev [mailto:dev-boun...@openvswitch.org] On Behalf Of Eitan Eliahu
> > Sent: Thursday, October 16, 2014 5:53 PM
> > To: dev@openvswitch.org
> > Subject: [ovs-dev] [PATCH v2] datapath-windows: packe
On Wed, Oct 15, 2014 at 09:51:54AM -0700, Alex Wang wrote:
> I'm changing the 'struct command' like this:
>
> diff --git a/lib/command-line.h b/lib/command-line.h
> index 157cb58..57fdff5 100644
> --- a/lib/command-line.h
> +++ b/lib/command-line.h
> @@ -27,7 +27,7 @@ struct command {
> const
flow inserts and removals are simplified:
- No need for classifier internal mutex, as dpif-netdev already has a
'flow_mutex'.
- Number of memory allocations/frees can be halved.
Lookup code path is a bit more effcient as well, as we can rely on
netdev_flow_key always having inline data.
This w
On Oct 16, 2014, at 2:09 PM, Jarno Rajahalme wrote:
> Thanks for the reviews, Alex!
>
> On Oct 14, 2014, at 3:31 PM, Alex Wang wrote:
>>
>> +/* Insert 'rule' into 'cls'. */
>> +static void
>> +dpcls_insert(struct dpcls *cls, struct dpcls_rule *rule,
>> + const struct netdev_flow_k
This change includes the following:
[1] Handler for subscribe/unsubscribe to a packet queue associated with a
socket pid.
[2] Allocation of per socket packet queue on a packet subscription.
[3] Removal of static allocated queues.
[4] Freeing the packet queue (on user mode process termination).
On Thu, Oct 16, 2014 at 1:47 PM, Ben Pfaff wrote:
> On Thu, Oct 16, 2014 at 12:53:50PM -0700, Alex Wang wrote:
> > >
> > > >
> > > > Signed-off-by: Niels van Adrichem
> > >
> > > Thanks. I applied this. It is definitely an improvement.
> > >
> > > There are two ways that we should continue to
Thanks for the reviews, Alex!
On Oct 14, 2014, at 3:31 PM, Alex Wang wrote:
> static inline struct netdev_flow_key *
> -miniflow_to_netdev_flow_key(const struct miniflow *mf)
> +miniflow_to_netdev_flow_key(const struct miniflow *miniflow)
> {
> -return (struct netdev_flow_key *) CONST_CAST(
On Oct 14, 2014, at 4:22 PM, Alex Wang wrote:
> the output of function 'netdev_flow_key_hash()' seems not got used,
> for dpcls_lookup(), we calculate the hash inside the function,
> for emc_lookup(), we use 'dpif_netdev_packet_get_dp_hash()'
> for flow_table(), we use the 'flow_hash(&flow->flow
On Thu, Oct 16, 2014 at 12:53:50PM -0700, Alex Wang wrote:
> >
> > >
> > > Signed-off-by: Niels van Adrichem
> >
> > Thanks. I applied this. It is definitely an improvement.
> >
> > There are two ways that we should continue to improve it, though. One
> > is incremental: CFM, as well as BFD, sh
Following patch adds support for userspace tunneling. Tunneling
needs three more component first is routing table which is configured by
caching kernel routes and second is ARP cache which build automatically
by snooping arp. And third is tunnel protocol table which list all
listening protocols whi
Routing table will be used by ovs userspace tunneling, it need to
know gw address, following commit extract gw information from
netlink message so that ovs can populate it in ovs route table.
Signed-off-by: Pravin B Shelar
---
lib/route-table.c |9 -
1 files changed, 8 insertions(+),
Rather than using hmap for storing routing entries we can directly use
classifier which has support for priority and wildcard entries.
This makes route lookup lockless. This help when we use route lookup
for native tunneling.
Signed-off-by: Pravin B Shelar
---
lib/automake.mk
name table maintains device ifindex to name mapping. On any name
table changes it invalidate name table and routing table. So
rather than building two tables this patch moves dev name to routing
entry and build routing table on any name table changes.
Signed-off-by: Pravin B Shelar
---
lib/rout
Following series adds support for tunneling entirely in userspace.
Even though this is targeted for DPDK based device, this should
work on any platform that support netdev datapath.
To make tunneling work it need special configuration, There is
README-native-tunneling file which has details.
I sti
>
> >
> > Signed-off-by: Niels van Adrichem
>
> Thanks. I applied this. It is definitely an improvement.
>
> There are two ways that we should continue to improve it, though. One
> is incremental: CFM, as well as BFD, should control forwarding.
Hey Ben, could you explain more on this 'increm
> -Original Message-
> From: dev [mailto:dev-boun...@openvswitch.org] On Behalf Of Eitan Eliahu
> Sent: Thursday, October 16, 2014 5:53 PM
> To: dev@openvswitch.org
> Subject: [ovs-dev] [PATCH v2] datapath-windows: packet miss read NL command
>
> The change include the Packet Read handler.
On Thu, Oct 16, 2014 at 11:23 AM, Ben Pfaff wrote:
> On Thu, Oct 16, 2014 at 01:26:37AM -0700, Gurucharan Shetty wrote:
>> Open vSwitch does not have native integration with Docker.
>> INSTALL.Docker explains how Open vSwitch can be integrated
>> with docker non-natively.
>>
>> ovs-docker is a hel
That would make sense, if the patch added an implementation of these
actions, but I do not see one.
The new actions must be added at the end of the list, not in the
middle, so that existing actions are not renumbered.
On Wed, Oct 15, 2014 at 11:00:38AM +0800, Liuyongqiang (A) wrote:
> I could not
On Wed, Oct 15, 2014 at 10:00:29AM +0800, lichu...@huawei.com wrote:
> From: Chunhe Li
>
> In rethat OS, the service name is "openvswitch", providers also should
> be change to "openvswitch"
>
> Signed-off-by: Chunhe Li
> Signed-off-by: Dongdong
The sign-off chain leaves me confused. The fir
On Thu, Oct 16, 2014 at 05:53:27PM -0700, Eitan Eliahu wrote:
> signed-off-by: Eitan Eliahu
Thanks for the patch. I'll wait for a review, but I have one note:
please do capitalize the "S" in "Signed-off-by". (It's not necessary
to re-send the patch for this reason; I routinely edit commit messa
On Thu, Oct 16, 2014 at 06:03:37PM -0700, Eitan Eliahu wrote:
> portNameLen to be used only in debug build
>
> signed-off-by: Eitan Eliahu
Applied, thanks!
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Thu, Oct 16, 2014 at 01:26:37AM -0700, Gurucharan Shetty wrote:
> Open vSwitch does not have native integration with Docker.
> INSTALL.Docker explains how Open vSwitch can be integrated
> with docker non-natively.
>
> ovs-docker is a helper script to add network interfaces to
> docker container
Acked-by: Ankur Sharma
From: Eitan Eliahu
Sent: Thursday, October 16, 2014 10:59 AM
To: Ankur Sharma
Subject: FW: [PATCH] datapath-windows: fix compilation error in release build
-Original Message-
From: Eitan Eliahu [mailto:elia...@vmware.com]
Sen
On Thu, Oct 16, 2014 at 10:28:00AM -0700, Gurucharan Shetty wrote:
> Thanks for the review.
You are welcome. All of your responses sound good to me. I'll take a
quick look at v2 but expect to ack it.
___
dev mailing list
dev@openvswitch.org
http://open
Open vSwitch does not have native integration with Docker.
INSTALL.Docker explains how Open vSwitch can be integrated
with docker non-natively.
ovs-docker is a helper script to add network interfaces to
docker containers and to attach them as ports to OVS bridge.
This script can be further enhance
>
> I see that this script in several places can print error messages. It
> should probably print these to stderr (by adding >&2). Maybe it
> should prefix them by "$0:", also (or calculate "basename $0" as a
> variable early on and use that).
I agree. I will add them in v2.
>
> As I started loo
portNameLen to be used only in debug build
signed-off-by: Eitan Eliahu
---
datapath-windows/ovsext/Datapath.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/datapath-windows/ovsext/Datapath.c
b/datapath-windows/ovsext/Datapath.c
index 93ff8b8..4e8be02 100644
--- a/datapat
The change include the Packet Read handler.
The current implementation reads once packet at a time. This should be updated
once user mode code is in place.
signed-off-by: Eitan Eliahu
---
datapath-windows/include/OvsDpInterfaceExt.h | 3 +-
datapath-windows/ovsext/Datapath.c | 53
On Wed, Oct 15, 2014 at 01:54:52PM +, Niels van Adrichem wrote:
> Integration of each interface' status as confirmed by BFD into the
> FastFailover Group table. When BFD is configured and function
> bfd_forwarding() reports false, odp_port_is_alive also reports false in
> order to have a watche
On Wed, Oct 15, 2014 at 05:27:14PM -0700, Nithin Raju wrote:
> In this patch, we make a few simple fixes based on reviewing the code.
> The code as such is not tested. We'll be hitting the code path soon
> and might make more fixes at that time.
>
> Signed-off-by: Nithin Raju
> Acked-by: Ankur Sh
Hi Nithin,
" devOp should be set to OVS_READ_EVENT_DEV_OP or OVS_READ_PACKET_DEV_OP"
Do you see any purpose to set the devOp for Event Read and Packet Read to a
value other than other than OVS_READ_DEV_OP ?
Thanks,
Eitan
-Original Message-
From: dev [mailto:dev-boun...@openvswitch.org]
Yesterday, we held a very productive OVS meeting as part of the Linux
Plumber's Conference. Below are the notes that were taken to record
the meeting. Thanks to all that participated!
OVS Micro Summit 2014, Oct 15, 2014, Düsseldorf
Att
On Thu, Oct 16, 2014 at 08:56:32AM -0400, Thomas F Herbert wrote:
> >Why is OVS_KEY_ATTR_CVLAN needed? The expectation when we designed
> >the Netlink flow structures was that nested VLANs would be implemented
> >as multiple nested attributes.
> Ben, OK. I will redo to use nested attributes. Why
Ben,
Thanks for your effort to review this patch. I will fix and resubmit.
On 10/15/14, 6:30 PM, Ben Pfaff wrote:
On Sat, Oct 11, 2014 at 08:56:06PM -0400, Thomas F Herbert wrote:
This is the linux kernel portion of the patch.
Signed-off-by: Thomas F Herbert
The ovs_key_attr values
Ben, thanks for your comments on my comments.
On 10/15/14, 5:08 PM, Ben Pfaff wrote:
On Wed, Oct 15, 2014 at 06:14:16AM -0400, Thomas F Herbert wrote:
I am late in commenting on Ben's comments on Dave's patch but I
thought I would add my two cents.
I need to review your patches, too, obviously
ú¼Ì~eL%Ê6ëõ7ðHj?³öuè/àÜá&Ô¬K«¯ú§ã&¬ë|-¤avvîE¢Çr*ÎHÞ~S÷Èß*9
G°QÎÆ oé6·þÉüTµ$«ùæ%#sý vŲ/èy/B¬³¨ý}j&¼^¨óýï<¿ôUYk$ë§yµûr?
0RH±ö(sR¢pñÛç²rÊôtüI?ºÚâã¼DÉ»w
Z4jÚ!?>.üâ¢üÔ¢ígeÖØ^íóì):víºÆü¢®¹b]qÏ«îw{½ºù#Z\a_ÊN3¶bÒõv×NrÊ$ÆC*D¶å¦×ÑRÑZdA¤FßÝÔIáô×\PCÈÕÀyÑ
7ZéiÔQÅÞèRÖ\aÑê
I refactored the OvsInjectPacketThroughActions function to make it
easier to follow. Also I removed from the datapath lock the creation
of the queue packet (OvsCreateQueuePacket) in case the flow lookup
fails.
In the OvsGetNetdevCmdHandler function I have removed the dispatchLock
acquisition that
65 matches
Mail list logo