On Fri, Oct 11, 2013 at 4:56 PM, Justin Pettit wrote:
> ovs-vtep is a VTEP emulator that uses Open vSwitch for forwarding.
>
> Co-authored-by: Gurucharan Shetty
> Signed-off-by: Justin Pettit
Signed-off-by: Gurucharan Shetty
Thank you.
> ---
> vtep/README.ovs-vtep | 82
> vtep/aut
The combination of two commits:
commit 8e4e1713e4
("openvswitch: Simplify datapath locking.")
commit 2537b4dd0a
("openvswitch:: link upper device for port devices")
introduced a bug where upper_dev wasn't unlinked upon
netdev_unregister notification
The following steps:
modprobe openvswitch
On Fri, Oct 11, 2013 at 05:20:22PM -0700, Justin Pettit wrote:
> On Oct 11, 2013, at 5:00 PM, Ben Pfaff wrote:
>
> > On Fri, Oct 11, 2013 at 04:56:22PM -0700, Justin Pettit wrote:
> >> From: Ben Pfaff
> >>
> >> When ovsdb-dot generates diagrams for use in the manpages, the dot2pic
> >> postproc
On Oct 11, 2013, at 5:00 PM, Ben Pfaff wrote:
> On Fri, Oct 11, 2013 at 04:56:22PM -0700, Justin Pettit wrote:
>> From: Ben Pfaff
>>
>> When ovsdb-dot generates diagrams for use in the manpages, the dot2pic
>> postprocessor makes nicer output if the arrowheads are omitted (dot2pic
>> adds the a
Before this commit, each time ofproto-dpif-monitor thread wakes up,
all monitored ports will be iterated. This adds a hugh overhead to
the monitor thread. This commit uses heap to order the wakeup
time of monitored port. So each time the monitor thread is waken up,
it will only iterate those mon
This commit adds a new function "cfm_wake_time()" that returns the
next wakeup time associated with the "struct cfm".
Signed-off-by: Alex Wang
---
v3 -> v4:
- rebase to master.
v2 -> v3:
- fix the code duplication.
v1 -> v2:
- rebase to master.
---
lib/cfm.c | 19 +--
lib/
This commit adds a new function "bfd_wake_time()" that returns the
next wakeup time associated with the "struct bfd".
Signed-off-by: Alex Wang
---
v3 -> v4:
- rebase to master.
v2 -> v3:
- fix the code duplication.
v1 -> v2:
- rebase to master.
---
lib/bfd.c | 26 --
This commit changes the variable type of priority in "struct heap"
from uint32_t to uint64_t.
Signed-off-by: Alex Wang
---
v3 -> v4:
- rebase to master.
v2 -> v3:
- no change for this patch
v1 -> v2:
- rebase to master.
---
lib/heap.c |6 +++---
lib/heap.h | 12 ++--
2 files ch
This commit moves the ofproto-dpif-monitor module into a
dedicated thread. This helps eliminate the burden of main
thread having to wake up very frequently for periodic
interface monitoring (bfd, cfm). Also, this commit greatly
increases the number of bfd/cfm sessions that can be supported
by ovs
On Fri, Oct 11, 2013 at 04:56:22PM -0700, Justin Pettit wrote:
> From: Ben Pfaff
>
> When ovsdb-dot generates diagrams for use in the manpages, the dot2pic
> postprocessor makes nicer output if the arrowheads are omitted (dot2pic
> adds the arrowheads itself). But for other uses that don't go th
Co-authored-by: David Yang
Signed-off-by: Justin Pettit
---
debian/automake.mk |5 ++
debian/control | 18 +
debian/openvswitch-vtep.default |4 ++
debian/openvswitch-vtep.dirs |1 +
debian/openvswitch-vtep.init | 78 ++
From: Bruce Davie
The hardware VTEP OVSDB schema specifies relations that a VTEP can use
to integrate physical ports into logical switches maintained by a
network virtualization controller such as NVP.
Co-authored-by: Ben Pfaff
Co-authored-by: Kenneth Duda
Co-authored-by: Justin Pettit
Signed
From: Ben Pfaff
When ovsdb-dot generates diagrams for use in the manpages, the dot2pic
postprocessor makes nicer output if the arrowheads are omitted (dot2pic
adds the arrowheads itself). But for other uses that don't go through
the postprocessor, we generally want the arrowheads. So this commi
ovs-vtep is a VTEP emulator that uses Open vSwitch for forwarding.
Co-authored-by: Gurucharan Shetty
Signed-off-by: Justin Pettit
---
vtep/README.ovs-vtep | 82
vtep/automake.mk |8 +
vtep/ovs-vtep| 511 ++
3 files chan
Signed-off-by: Ben Pfaff
---
lib/daemon.c |2 ++
lib/daemon.man |7 ---
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/lib/daemon.c b/lib/daemon.c
index 1c9ebe2..54641d0 100644
--- a/lib/daemon.c
+++ b/lib/daemon.c
@@ -376,6 +376,8 @@ should_restart(int status)
{
On Fri, Oct 11, 2013 at 04:40:38PM -0700, Jarno Rajahalme wrote:
> > On Oct 11, 2013, at 1:36 PM, Ben Pfaff wrote:
> >
> >> On Fri, Oct 11, 2013 at 12:51:35PM -0700, Jarno Rajahalme wrote:
> >>
> >>> On Oct 11, 2013, at 9:02 AM, Ben Pfaff wrote:
> >>>
> On Wed, Oct 09, 2013 at 01:47:50PM
> On Oct 11, 2013, at 1:36 PM, Ben Pfaff wrote:
>
>> On Fri, Oct 11, 2013 at 12:51:35PM -0700, Jarno Rajahalme wrote:
>>
>>> On Oct 11, 2013, at 9:02 AM, Ben Pfaff wrote:
>>>
On Wed, Oct 09, 2013 at 01:47:50PM -0700, Jarno Rajahalme wrote:
Use the offset of the last member in struct
On Fri, Oct 11, 2013 at 4:09 PM, Ben Pfaff wrote:
> On Fri, Oct 11, 2013 at 03:55:07PM -0700, Andy Zhou wrote:
> >
> > Signed-off-by: Andy Zhou
>
> It would be nice to add something to ovs-dpctl(8) to explain these new
> stats (as well as the old ones, for that matter).
>
> I would usually wrap
Too many users have incorrectly assumed that ovs-controller is a necessary
or desirable part of an Open vSwitch deployment. This commit should fix
the problem by renaming it test-controller and removing it from the
default install and from packaging.
Signed-off-by: Ben Pfaff
---
FAQ
On Fri, Oct 11, 2013 at 03:55:07PM -0700, Andy Zhou wrote:
>
> Signed-off-by: Andy Zhou
It would be nice to add something to ovs-dpctl(8) to explain these new
stats (as well as the old ones, for that matter).
I would usually wrap this:
struct ovs_dp_megaflow_stats
megaflow_stats
Collect mega flow mask stats. ovs-dpctl show command can be used to
display them.
Signed-off-by: Andy Zhou
---
datapath/datapath.c | 49 +++
datapath/datapath.h |5 +
datapath/flow_table.c | 22 ---
datapat
Signed-off-by: Andy Zhou
---
NEWS |2 ++
lib/dpif-linux.c | 12
lib/dpif.h|3 +++
utilities/ovs-dpctl.c |8
4 files changed, 25 insertions(+)
diff --git a/NEWS b/NEWS
index 94e0da9..de473f0 100644
--- a/NEWS
+++ b/NEWS
@@ -4,
On Fri, Oct 11, 2013 at 03:34:36PM -0700, Ben Pfaff wrote:
> On Fri, Oct 11, 2013 at 02:58:36PM -0700, Alex Wang wrote:
> > This commit simplifies the xlate_send_packet() function by calling
> > ofproto_dpif_execute_actions() function.
> >
> > Signed-off-by: Alex Wang
>
> Acked-by: Ben Pfaff
A
On Fri, Oct 11, 2013 at 3:02 PM, Jesse Gross wrote:
> On Fri, Oct 11, 2013 at 1:03 PM, Alexei Starovoitov wrote:
>> On Fri, Oct 11, 2013 at 11:11 AM, Jesse Gross wrote:
>>> On Thu, Oct 10, 2013 at 9:48 PM, Alexei Starovoitov
>>> wrote:
On Thu, Oct 10, 2013 at 8:56 PM, Jesse Gross wrote:
On Fri, Oct 11, 2013 at 03:31:32PM -0700, Alex Wang wrote:
> > Thanks. I agree that the existing comment is wrong. I don't really
> > understand the description of 'flow' in the new version. It implies
> > that execute_actions() does something to 'flow' and especially to the
> > tunnel and in_po
On Fri, Oct 11, 2013 at 02:58:36PM -0700, Alex Wang wrote:
> This commit simplifies the xlate_send_packet() function by calling
> ofproto_dpif_execute_actions() function.
>
> Signed-off-by: Alex Wang
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvs
Thanks Ben, for the review,
Thanks. I agree that the existing comment is wrong. I don't really
> understand the description of 'flow' in the new version. It implies
> that execute_actions() does something to 'flow' and especially to the
> tunnel and in_port members, but 'flow' is const so that
On Fri, Oct 11, 2013 at 02:58:35PM -0700, Alex Wang wrote:
> This commit changes the execute_actions() function to non-static
> function.
>
> Signed-off-by: Alex Wang
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/
On Fri, Oct 11, 2013 at 02:58:34PM -0700, Alex Wang wrote:
> This commit changes the comment for execute_actions() function,
> since the old comment does not apply.
>
> Signed-off-by: Alex Wang
...
> -/* Executes, within 'ofproto', the 'n_actions' actions in 'actions' on
> - * 'packet', which a
Hey Ben,
Could you review this series when you are available?
Thanks,
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Fri, Oct 11, 2013 at 1:03 PM, Alexei Starovoitov wrote:
> On Fri, Oct 11, 2013 at 11:11 AM, Jesse Gross wrote:
>> On Thu, Oct 10, 2013 at 9:48 PM, Alexei Starovoitov
>> wrote:
>>> On Thu, Oct 10, 2013 at 8:56 PM, Jesse Gross wrote:
However, the check dev->reg_state in netdev_destroy()
This commit changes the execute_actions() function to non-static
function.
Signed-off-by: Alex Wang
---
ofproto/ofproto-dpif.c | 23 ++-
ofproto/ofproto-dpif.h |3 +++
2 files changed, 17 insertions(+), 9 deletions(-)
diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofpro
This commit simplifies the xlate_send_packet() function by calling
ofproto_dpif_execute_actions() function.
Signed-off-by: Alex Wang
---
ofproto/ofproto-dpif-xlate.c | 25 +++--
1 file changed, 3 insertions(+), 22 deletions(-)
diff --git a/ofproto/ofproto-dpif-xlate.c b/of
This commit changes the comment for execute_actions() function,
since the old comment does not apply.
Signed-off-by: Alex Wang
---
ofproto/ofproto-dpif.c |7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c
index 61324e7..b
On Fri, Oct 11, 2013 at 12:40 PM, Pravin B Shelar wrote:
> vxlan-udp-recv function lookup vxlan_sock struct on every packet
> recv by using udp-port number. we can use sk->sk_user_data to
> store vxlan_sock and avoid lookup.
>
> This commit also allows us to get rid of socket hash table.
>
> Signe
Commit 91d6cd12 (ofproto-dpif: Move send_packet() to ofproto-dpif-xlate
module.) introduced the bug that frees the "struct ofpbuf" in 'xout' when
the struct is not initialized. This commit fixes the bug.
Reported-by: Simon Horman
Signed-off-by: Alex Wang
---
ofproto/ofproto-dpif-xlate.c |5
On Thu, Oct 10, 2013 at 03:00:09PM -0700, Romain Lenglet wrote:
> On Oct 10, 2013, at 2:56 PM, Romain Lenglet wrote:
>
> > On Oct 7, 2013, at 2:33 PM, Ben Pfaff wrote:
> >
> >> This prevents using an older datapath from breaking forwarding.
> >>
> >> CC: Romain Lenglet
> >> Signed-off-by: Ben
On Fri, Oct 11, 2013 at 12:51:35PM -0700, Jarno Rajahalme wrote:
>
> On Oct 11, 2013, at 9:02 AM, Ben Pfaff wrote:
>
> > On Wed, Oct 09, 2013 at 01:47:50PM -0700, Jarno Rajahalme wrote:
> >> Use the offset of the last member in struct flow instead of the
> >> struct size to help catch changes in
On Fri, Oct 11, 2013 at 11:11 AM, Jesse Gross wrote:
> On Thu, Oct 10, 2013 at 9:48 PM, Alexei Starovoitov wrote:
>> On Thu, Oct 10, 2013 at 8:56 PM, Jesse Gross wrote:
>>> However, the check dev->reg_state in netdev_destroy() looks racy to
>>> me, as it could already be in NETREG_UNREGISTERED e
On Oct 11, 2013, at 9:02 AM, Ben Pfaff wrote:
> On Wed, Oct 09, 2013 at 01:47:50PM -0700, Jarno Rajahalme wrote:
>> Use the offset of the last member in struct flow instead of the
>> struct size to help catch changes in the declaration.
>>
>> Add flow_random_hash_fields() used for testing in pl
vxlan-udp-recv function lookup vxlan_sock struct on every packet
recv by using udp-port number. we can use sk->sk_user_data to
store vxlan_sock and avoid lookup.
This commit also allows us to get rid of socket hash table.
Signed-off-by: Pravin B Shelar
---
datapath/linux/Modules.mk
On Thu, Oct 10, 2013 at 9:48 PM, Alexei Starovoitov wrote:
> On Thu, Oct 10, 2013 at 8:56 PM, Jesse Gross wrote:
>> However, the check dev->reg_state in netdev_destroy() looks racy to
>> me, as it could already be in NETREG_UNREGISTERED even if we already
>> processed this device.
>
> you mean th
On Fri, Oct 11, 2013 at 09:06:41AM -0700, Ethan Jackson wrote:
> > +/* The following prototypes duplicate those in rconn.h, but there we
> > weren't
> > + * able to add the OVS_EXCLUDED annotations because the definition of
> > struct
> > + * rconn was not visible. */
>
> Extra space here.
Th
OK, I added
/* Required to add and remove ofconns. This could probably be narrowed to
* cover a smaller amount of code, if that yielded some benefit. */
just before taking the lock in connmgr_set_controllers().
Thanks!
On Fri, Oct 11, 2013 at 09:33:46AM -0700, Ethan Jackson wrote:
> I
I wouldn't bother narrowing it. I was just confused about whether
it's required or not. Perhaps a brief comment explaining that logic
would be helpful.
Ethan
On Fri, Oct 11, 2013 at 9:09 AM, Ben Pfaff wrote:
> On Fri, Oct 11, 2013 at 08:58:20AM -0700, Ethan Jackson wrote:
>> I guess the only t
On Fri, Oct 11, 2013 at 08:58:20AM -0700, Ethan Jackson wrote:
> I guess the only thing I'm wondering about is how you know when
> ofproto_mutex is required and when it isn't. In particular, why do we
> need to hold it for the entire connmgr_set_controllers()? That's not
> totally clear from the
> +/* The following prototypes duplicate those in rconn.h, but there we weren't
> + * able to add the OVS_EXCLUDED annotations because the definition of struct
> + * rconn was not visible. */
Extra space here.
Pretty straight forward, I'm happy with this. Thanks for pulling it
together so quic
Acked-by: Ethan Jackson
On Fri, Oct 11, 2013 at 12:23 AM, Ben Pfaff wrote:
> 'ofproto_mutex' has effectively protected the monitor-related members of
> struct ofconn since its introduction, but this was not written down or
> systematically annotated. This commit makes it more systematic and fi
On Wed, Oct 09, 2013 at 01:47:50PM -0700, Jarno Rajahalme wrote:
> Use the offset of the last member in struct flow instead of the
> struct size to help catch changes in the declaration.
>
> Add flow_random_hash_fields() used for testing in places where
> struct flow was used without zero initiali
I guess the only thing I'm wondering about is how you know when
ofproto_mutex is required and when it isn't. In particular, why do we
need to hold it for the entire connmgr_set_controllers()? That's not
totally clear from the comment at the top of the file.
Acked-by: Ethan Jackson
On Fri, Oct
Acked-by: Ethan Jackson
On Fri, Oct 11, 2013 at 12:23 AM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> lib/rconn.c | 61
> -
> lib/rconn.h | 14
> ofproto/connmgr.c | 14 +++-
> 3 files changed,
On Wed, Oct 09, 2013 at 04:49:06PM +0900, YAMAMOTO Takashi wrote:
> Signed-off-by: YAMAMOTO Takashi
...
> + This requires the following.
> + - Change the default table-miss action (in the absense of table-miss
> +entry) from packet_in to drop for OF1.3+. Decide what to do if
>
On Fri, Oct 11, 2013 at 02:16:15PM +0200, Johannes Grassler wrote:
> There is a small typo in the /etc/default/openvswitch-switch configuration
> file shipped with the package. The comment in line 11 reads
>
> # * "pctp:[PORT]": Listen for TCP connections on the specified PORT
> ^^
>
Package: openvswitch-controller
Version: 1.4.2+git20120612-9
Severity: minor
Dear Maintainer,
There is a small typo in the /etc/default/openvswitch-switch configuration
file shipped with the package. The comment in line 11 reads
# * "pctp:[PORT]": Listen for TCP connections on the specified PO
Code in the ofproto-dpif miss handler threads can currently access
ofconns, sending flow_removed and flow monitor messages due to NXAST_LEARN
actions. Nothing currently protects those threads from accessing ofconns
that are in the process of being destroyed. This commit adds protection
'ofproto_m
This should make sending OFPT_FLOW_REMOVED and NXST_FLOW_MONITOR safe from
miss handler threads.
Bug #20271.
Signed-off-by: Ben Pfaff
---
lib/rconn.c | 286 +--
lib/rconn.h |6 ++
2 files changed, 247 insertions(+), 45 deletions(-)
di
'ofproto_mutex' has effectively protected the monitor-related members of
struct ofconn since its introduction, but this was not written down or
systematically annotated. This commit makes it more systematic and fixes
a few issues found using the annotations.
Signed-off-by: Ben Pfaff
---
ofproto
Signed-off-by: Ben Pfaff
---
lib/rconn.c | 61 -
lib/rconn.h | 14
ofproto/connmgr.c | 14 +++-
3 files changed, 70 insertions(+), 19 deletions(-)
diff --git a/lib/rconn.c b/lib/rconn.c
index 64cc6d0..9273
58 matches
Mail list logo