#24335: DateRange and friends require psycopg2 >= 2.5
-------------------------------------+-------------------------------------
     Reporter:  claudep              |                    Owner:  ovangle
         Type:                       |                   Status:  assigned
  Cleanup/optimization               |
    Component:  contrib.postgres     |                  Version:  1.8alpha1
     Severity:  Normal               |               Resolution:
     Keywords:  1.8-beta             |             Triage Stage:  Accepted
    Has patch:  0                    |      Needs documentation:  0
  Needs tests:  0                    |  Patch needs improvement:  0
Easy pickings:  0                    |                    UI/UX:  0
-------------------------------------+-------------------------------------

Comment (by ovangle):

 While testing this, it seems that
 
https://github.com/django/django/commit/39d95fb6ada99c59d47fa0eae6d3128abafe2d58
 dropped support for psycopg2 <= 2.4.3 globally (new_array_type was added
 in 2.4.3). I'm just going to add a check for the version >= 2.5 into
 `django.db.backends.postgres_pyscopg2` and update
 `docs/ref/databases.txt`.

--
Ticket URL: <https://code.djangoproject.com/ticket/24335#comment:9>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/065.8a30bee7ae011a0ccc4e951ac29c6de6%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to