#24335: DateRange and friends require psycopg2 >= 2.5
-------------------------------------+-------------------------------------
               Reporter:  claudep    |          Owner:
                   Type:             |         Status:  new
  Cleanup/optimization               |
              Component:             |        Version:  1.8alpha1
  contrib.postgres                   |
               Severity:  Normal     |       Keywords:
           Triage Stage:             |      Has patch:  0
  Unreviewed                         |
    Needs documentation:  0          |    Needs tests:  0
Patch needs improvement:  0          |  Easy pickings:  0
                  UI/UX:  0          |
-------------------------------------+-------------------------------------
 Currently, if your psycopg2 version is lower than 2.5, you cannot import
 any of contrib.postgres fields or forms, as ranges.py is unconditionally
 imported in their `__init__`.

 On one side, this should be documented, and on the other side we should
 still allow other fields/forms (array/hstore) to be imported (maybe raise
 a RuntimeWarning for the ranges import failure?).

--
Ticket URL: <https://code.djangoproject.com/ticket/24335>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/050.2aef488f010d634e56bf5681878f2ed8%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to