On Thu, 3 Sep 2026 13:21:15 GMT, Dan Heidinga <[email protected]> wrote:

>> Stefan Karlsson has updated the pull request incrementally with two 
>> additional commits since the last revision:
>> 
>>  - inline_alloc -> value_type_alloc
>>  - Rename PrintInlineLayout
>
> src/hotspot/share/classfile/fieldLayoutBuilder.hpp line 307:
> 
>> 305:   bool _has_nonstatic_fields;
>> 306:   bool _has_inlineable_fields;
>> 307:   bool _has_inlined_fields;
> 
> We need to check these two to see what the proper inline->value mapping is.  
> Or maybe they are still correctly referring to inlined values.... needs some 
> eyes to confirm

FWIW, I've refrained from changing names containing the words "inlineable" and 
"inlined". Mainly because I think they do convey the correct intention: "has 
the class fields that can be inlineable?" and "did the class inline these 
fields?".

I would prefer if we changed all these to talk about flattening instead of 
inlining, so that we get a consistent nomenclature. So, maybe I should change 
these to `_has_flattenable_fields` and `_has_flattened_fields`?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3926523281

Reply via email to