On Thu, 3 Sep 2026 14:47:11 GMT, Stefan Karlsson <[email protected]> wrote:

>> src/hotspot/share/classfile/classFileParser.cpp line 6592:
>> 
>>> 6590: 
>>> 6591:   // Set the Klass for the field's index
>>> 6592:   _inline_layout_info_array->adr_at(field_index)->set_klass(vk);
>> 
>> Should `_inline_layout_info_array` be renamed to `_value_layout_info_array` 
>> for consistency with the new naming convention?
>
> I was unsure if InlineLayoutInfo only referred to flattened fields and 
> therefore were sort-of better named as InlineLayoutInfo, FlattenedLayoutInfo, 
> or ValueLayoutInfo. WDYT?

I've renamed InlineLayoutInfo and associated variables and functions. See 
motivation in main thread.

>> src/hotspot/share/classfile/classFileParser.hpp line 257:
>> 
>>> 255:   void set_klass(InstanceKlass* instance);
>>> 256: 
>>> 257:   void set_inline_layout_info_klass(int field_index, ValueKlass* vk, 
>>> TRAPS);
>> 
>> Suggestion:
>> 
>>   void set_value_layout_info_klass(int field_index, ValueKlass* vk, TRAPS);
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/classfile/fieldLayoutBuilder.cpp line 73:
>> 
>>> 71:   }
>>> 72: 
>>> 73:   InlineLayoutInfo* inline_field_info = 
>>> inline_layout_info_array->adr_at(field_info.index());
>> 
>> Suggestion:
>> 
>>   ValueLayoutInfo* value_field_info = 
>> value_layout_info_array->adr_at(field_info.index());
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/classfile/fieldLayoutBuilder.cpp line 74:
>> 
>>> 72: 
>>> 73:   InlineLayoutInfo* inline_field_info = 
>>> inline_layout_info_array->adr_at(field_info.index());
>>> 74:   ValueKlass* vk = inline_field_info->klass();
>> 
>> Suggestion:
>> 
>>   ValueKlass* vk = value_field_info->klass();
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/classfile/fieldLayoutBuilder.cpp line 111:
>> 
>>> 109:   if (lk == LayoutKind::REFERENCE) return lk;
>>> 110:   assert(LayoutKindHelper::is_flat((lk)), "Must be");
>>> 111:   InlineLayoutInfo* inline_field_info = 
>>> inline_layout_info_array->adr_at(field_info.index());
>> 
>> Suggestion:
>> 
>>   ValueLayoutInfo* inline_field_info = 
>> value_layout_info_array->adr_at(field_info.index());
>> 
>> 
>> There's some renaming that was missed in this file.
>> 
>> To be consistent, we should use inline->value in all these places or, if  
>> we're talking about fields that have been flattened and want a distinction, 
>> we should use flat rather than inline
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/classfile/fieldLayoutBuilder.hpp line 281:
>> 
>>> 279:   GrowableArray<FieldInfo>* _field_info;
>>> 280:   FieldLayoutInfo* _info;
>>> 281:   Array<InlineLayoutInfo>* _inline_layout_info_array;
>> 
>> Suggestion:
>> 
>>   Array<ValueLayoutInfo>* _value_layout_info_array;
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/oops/instanceKlass.hpp line 329:
>> 
>>> 327:   Array<FieldStatus>* _fields_status;
>>> 328: 
>>> 329:   Array<InlineLayoutInfo>* _inline_layout_info_array;
>> 
>> Suggestion:
>> 
>>   Array<ValueLayoutInfo>* _value_layout_info_array;
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/oops/instanceKlass.hpp line 995:
>> 
>>> 993:   static ByteSize init_thread_offset() { return 
>>> byte_offset_of(InstanceKlass, _init_thread); }
>>> 994: 
>>> 995:   static ByteSize inline_layout_info_array_offset() { return 
>>> byte_offset_of(InstanceKlass, _inline_layout_info_array); }
>> 
>> Suggestion:
>> 
>>   static ByteSize value_layout_info_array_offset() { return 
>> byte_offset_of(InstanceKlass, _value_layout_info_array); }
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/oops/instanceKlass.hpp line 1094:
>> 
>>> 1092:     assert(_inline_layout_info_array != nullptr, "Array not created");
>>> 1093:     return _inline_layout_info_array->at(index);
>>> 1094:   }
>> 
>> inline -> value needs to be applied here as well
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/oops/instanceKlass.hpp line 1096:
>> 
>>> 1094:   }
>>> 1095: 
>>> 1096:   InlineLayoutInfo* inline_layout_info_adr(int index) {
>> 
>> Suggestion:
>> 
>>   ValueLayoutInfo* value_layout_info_adr(int index) {
>> 
>> 
>> _inline_layout_info_array -> _value_layout_info_array
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

>> src/hotspot/share/oops/instanceKlass.inline.hpp line 82:
>> 
>>> 80:   assert(has_inlined_fields() || has_null_restricted_static_fields(), 
>>> "Sanity checking");
>>> 81:   assert(idx < java_fields_count(), "IOOB");
>>> 82:   ValueKlass* k = inline_layout_info(idx).klass();
>> 
>> Suggestion:
>> 
>>   ValueKlass* k = value_layout_info(idx).klass();
>
> Waiting for decision on the name for InlineLayoutInfo

I've renamed InlineLayoutInfo and associated variables and functions.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927471793
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927454354
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927474023
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927475406
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927477032
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927442365
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927481766
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927484739
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927486539
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927488103
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927489972

Reply via email to