Sorry! I didn't remember this patch (regvalues.h) is where a poorly
named macro (comment on patch 7/11, SDRAM parameters) was defined. I
will fix it.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
Adding macros for more configurable lowlevel_init code.
Also cleanup of some typos.
---
Changes for v2:
- Add spaces for legibility
- Correct multiple #include protection to specify device
---
arch/arm/include/asm/arch-ks8695/platform.h | 55 -
arch/arm/include/asm/arch-ks8695
On Fri, 26 Oct 2012 23:37:28 +0200
Albert ARIBAUD wrote:
> Hi Yann,
>
> On Fri, 19 Oct 2012 10:02:09 +0200, Yann Vernier
> wrote:
>
> > On Thu, 18 Oct 2012 15:55:31 -0500
> > Joe Hershberger wrote:
> >
> > > Hi Yann,
> > >
> > &g
On Sat, 10 Nov 2012 09:03:32 +0100
Albert ARIBAUD wrote:
> Hi Yann,
>
> On Fri, 5 Oct 2012 14:09:47 +0200, Yann Vernier
> wrote:
>
> > On Thu, 4 Oct 2012 11:15:06 +0200
> > Albert ARIBAUD wrote:
> > > Sorry it took me so long to crawl my backlog... Th
On Thu, 18 Oct 2012 21:09:07 +0200
Albert ARIBAUD wrote:
> Hi Yann,
>
> On Fri, 5 Oct 2012 14:09:53 +0200, Yann Vernier
> wrote:
>
> > Changed CONFIG_SYS_TEXT_BASE to actual address (required for
> > board_init_f) and moved it into cm4{008,1xx}.h, along with a war
On Thu, 18 Oct 2012 15:55:31 -0500
Joe Hershberger wrote:
> Hi Yann,
>
> On Fri, Oct 5, 2012 at 7:09 AM, Yann Vernier
> wrote:
> > Removed board specific MAC reading code from driver.
> > Should move the reading to the cm4008/cm41xx board code.
> > ---
>
Just use the existing #define instead of magic number.
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
index 31b028b..ba37c28 100644
Allows configuration macros to set SDRAM parameters.
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S | 20 +++-
1 file changed, 11 insertions(+), 9 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
index 74579ed.
Previously code to do this was in the Ethernet driver itself.
Since it is board specific, moved it here, and altered it to
support preset MAC from environment.
---
board/cm4008/cm4008.c | 12
board/cm41xx/cm41xx.c | 12
2 files changed, 24 insertions(+)
diff --git a/
A small bug caused code to set up LEDs to instead disable lots
of functionality in the Ethernet switch, including bounds checks.
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arc
Removed needless values for configuration macros.
---
include/configs/cm4008.h | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/include/configs/cm4008.h b/include/configs/cm4008.h
index 18f7900..43a2591 100644
--- a/include/configs/cm4008.h
+++ b/include/configs/cm4
Adding macros for more configurable lowlevel_init code.
Also cleanup of some typos.
---
arch/arm/include/asm/arch-ks8695/platform.h | 55 -
arch/arm/include/asm/arch-ks8695/regvalues.h | 112 ++
2 files changed, 149 insertions(+), 18 deletions(-)
diff --git
Changed CONFIG_SYS_TEXT_BASE to actual address (required for
board_init_f) and moved it into cm4{008,1xx}.h, along with a warning
that it must match CONFIG_SYS_FLASH_BASE (since lowlevel_init
relocates there).
lowlevel_init now uses CONFIG_SYS_RCS0_BASE to map ROM.
---
Changes for v2:
- Update t
This change allows use of other flash chips than the two supported by
the cm4008 flash.c. Tested with Micrel KSZ8695X demo board.
---
Changes for v2:
- Update cm41xx also
- Remove unused board specific flash code
Changes for v3:
- Do not define to 1 where it is not required, just define
Ch
Removed board specific MAC reading code from driver.
Should move the reading to the cm4008/cm41xx board code.
---
drivers/net/ks8695eth.c | 38 +-
1 file changed, 9 insertions(+), 29 deletions(-)
diff --git a/drivers/net/ks8695eth.c b/drivers/net/ks8695eth.c
Leave dram_init_banksize to set up the bank info data.
ram_size was previously uninitialized.
Also put data on SDRAM configuration in header file.
Signed-off-by: Yann Vernier
---
Changes for v2:
- Update to use CONFIG_SYS_SDRAM_ constants
- Update cm41xx also
- Map SDRAM to match
CONFIG_BAUDRATE and KS8695_UART_LINEC_WLEN8 used for UART registers
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
index e9f1227.
t, this time using 'git send-email'?
Terribly sorry. This should fix that problem.
In the meantime, work on our board progresses nicely, and we plan to
submit it after registering a machine ID. We have u-boot support for
PCI, FPGA configuration, and I2C for power control working, the
latt
Changes for v4:
- Define flash bank characteristics (for big constant cleanup)
- Poll status for AMD flash (as on KS8695X demo board)
Signed-off-by: Yann Vernier
---
board/cm4008/Makefile|2 +-
board/cm4008/flash.c | 410
-- board
CONFIG_BAUDRATE and KS8695_UART_LINEC_WLEN8 used for UART registers
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695
KS8695X demo board
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S | 63
+++ board/cm4008/config.mk
|1 - board/cm41xx/config.mk |1 -
3 files changed, 45 insertions(+), 20 deletions(-)
delete mode 100644 board
Allows configuration macros to set SDRAM parameters.
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S | 20 +++-
1 file changed, 11 insertions(+), 9 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695
ied mail, nor a commit in the git, so I figure
this is still not merged. I've since made an attempt at cleaning up the
magic constants. Since this is fairly intrusive I have a much larger
patch affecting the same sections. I've attempted to split it up, though
some combinations of these
Adding macros for more configurable lowlevel_init code.
Also cleanup of some typos.
Signed-off-by: Yann Vernier
---
arch/arm/include/asm/arch-ks8695/platform.h | 55 -
arch/arm/include/asm/arch-ks8695/regvalues.h | 112
++ 2 files changed, 149 insertions
Removed board specific MAC reading code from driver.
Should move the reading to the cm4008/cm41xx board code.
Signed-off-by: Yann Vernier
---
drivers/net/ks8695eth.c | 38 +-
1 file changed, 9 insertions(+), 29 deletions(-)
diff --git a/drivers/net
Leave dram_init_banksize to set up the bank info data.
ram_size was previously uninitialized.
Also put data on SDRAM configuration in header file.
Signed-off-by: Yann Vernier
---
Changes for v2:
- Update to use CONFIG_SYS_SDRAM_ constants
- Update cm41xx also
- Map SDRAM to match
A small bug caused code to set up LEDs to instead disable lots
of functionality in the Ethernet switch, including bounds checks.
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/cpu
Removed needless values for configuration macros.
Signed-off-by: Yann Vernier
---
include/configs/cm4008.h | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/include/configs/cm4008.h b/include/configs/cm4008.h
index 18f7900..43a2591 100644
--- a/include/configs
Just use the existing #define instead of magic number.
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
b/arch/arm/cpu/arm920t/ks8695/lowlevel_init.S
Previously code to do this was in the Ethernet driver itself.
Since it is board specific, moved it here, and altered it to
support preset MAC from environment.
Signed-off-by: Yann Vernier
---
board/cm4008/cm4008.c | 12
board/cm41xx/cm41xx.c | 12
2 files changed
On Thursday 12 July 2012 21:37:10 you wrote:
> Did not hear any answer to this. Do we get a V3 for this patch?
>
> Or should I assume that the pversions to pick are V2 for 1/3 and 2/3,
> and V3 for 3/3?
Sorry for the late reply. Let me just sort this out. We're talking about three
patches:
1/3
On Friday 06 July 2012 10:43:40 you wrote:
> >>> =((CONFIG_SYS_SDRAM_BASE+CONFIG_SYS_SDRAM_SIZE-0x1)<<(22-16) | \ +
> >>> (CONFIG_SYS_SDRAM_BASE>>(16-12) | 0x00e))
> >>
> >> ugh ... magic. Will it work for every possible setting?
> >> How about one setting CONFIG_SYS_SDRAM_BASE != 0x0? I
Signed-off-by: Yann Vernier
---
board/cm4008/Makefile|2 +-
board/cm4008/flash.c | 410 --
board/cm41xx/Makefile|2 +-
board/cm41xx/flash.c | 410 --
include/configs/cm4008.h |4
On Thursday 05 July 2012 16:48:22 you wrote:
> On 05.07.2012 14:11, Yann Vernier wrote:
> > Leave dram_init_banksize to set up the bank info data.
> > ram_size was previously uninitialized. Also, generalize
> > lowlevel assembly to support more RAM options.
> >
>
This change allows use of other flash chips than the two supported by
the cm4008 flash.c. Tested with Micrel KSZ8695X demo board.
---
Changes for v2:
- Update cm41xx also
- Remove unused board specific flash code
Signed-off-by: Yann Vernier
---
board/cm4008/Makefile|2 +-
board
I do apologise. I mistakenly entered the wrong message ID for this mail; it is
In-Reply-To: <4ff56547.6070...@gmail.com>
Subject: Re: [U-Boot] [PATCH 2/3] cm4008: Fix ROM relocation.
I shall soon submit the updated patch that does belong in this thread. Sorry!
___
mapped at 0x0240-0x027f.
---
Changes for v2:
- Update to use CONFIG_SYS_FLASH_ constants only (no PHYS_FLASH)
- Use tabs where appropriate
- Update cm41xx also
- Explain the lowlevel_init change
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |9
Leave dram_init_banksize to set up the bank info data.
ram_size was previously uninitialized. Also, generalize
lowlevel assembly to support more RAM options.
Signed-off-by: Yann Vernier
---
Changes for v2:
- Update to use CONFIG_SYS_SDRAM_ constants
- Update cm41xx also
- Map SDRAM to
Leave dram_init_banksize to set up the bank info data.
ram_size was previously uninitialized.
Signed-off-by: Yann Vernier
---
board/cm4008/cm4008.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/board/cm4008/cm4008.c b/board/cm4008/cm4008.c
index ed493a8..557cd8e
Changed CONFIG_SYS_TEXT_BASE to actual address (required for
board_init_f) and moved it into cm4008.h, along with a warning that it
must match PHYS_FLASH_1 (since lowlevel_init relocates there).
Signed-off-by: Yann Vernier
---
arch/arm/cpu/arm920t/ks8695/lowlevel_init.S |9 +++--
board
This change allows use of other flash chips than the two supported by
the cm4008 flash.c. Tested with Micrel KSZ8695X demo board.
Signed-off-by: Yann Vernier
---
board/cm4008/Makefile|2 +-
include/configs/cm4008.h |4
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git
intended to remedy that. With all three
combined, I have been able to get Micrel's KSZ8695X demo board to run U-Boot.
As this is my first attempt at a contribution upstream to U-Boot, any comments
are quite welcome.
Yann Vernier (3):
cm4008: set gd->ram_size in dram_init
cm4008:
42 matches
Mail list logo