Added support for a ``-v'' option for fw_setenv to explicitly enable
what was formerly default verbose diagnostic output when updating the
environment.
Signed-off-by: Grant Erickson <[EMAIL PROTECTED]>
---
tools/env/fw_env.c | 43 +--
tools/env/fw_en
Dear Grant,
On Fri, Aug 29, 2008 at 08:32:39PM -0700, Grant Erickson wrote:
> The u-boot companion command line tool 'fw_setenv' emits verbose output
> during a set operation of the form:
>
> Unlocking flash...
> Done
> Erasing old environment...
> Done
> Writing environment
This patch adds GPCS, SGMII and M88E1112 PHY support
for the AMCC PPC460GT/EX processors.
Signed-off-by: Victor Gallardo <[EMAIL PROTECTED]>
---
cpu/ppc4xx/4xx_enet.c | 116 -
cpu/ppc4xx/miiphy.c | 40 -
include/ppc4xx_enet.h |
The u-boot companion command line tool 'fw_setenv' emits verbose output
during a set operation of the form:
Unlocking flash...
Done
Erasing old environment...
Done
Writing environment to /dev/mtd4...
Done
Locking ...
Done
While this is nice for debugging and troubl
Hi, I have problems in writing an application for U-boot. I do not need
U-boot functions (for now), I just have to write some registers and then
fill some memory with a value. The HW will read that memory region for
its usage.
I work on a ARM9 board whose RAM is mapped from 0x00 to 0x0400
Dear Wolfgang,
The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4:
Wolfgang Denk (1):
Merge branch 'master' of /home/wd/git/u-boot/custodians
are available in the git repository at:
git://git.denx.de/u-boot-sh.git master
Nobuhiro Iwamatsu (8):
sh: Add
Adds returning an error from the ramdisk detection code if
its not a real ramdisk (invalid). There is no reason we can't
just return back to the console if we detect an invalid
ramdisk or CRC error.
Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
---
This is based on Anatolij's patch:
'Prevent cr
On Aug 29, 2008, at 5:16 PM, Peter Tyser wrote:
> Hello,
>
> [snip]
>
>> +
>> +/* DDR SDRAM control configuration 2 (DDR_SDRAM_CFG_2) */
>> +static void set_ddr_sdram_cfg_2(fsl_memctl_config_regs_t *ddr,
>> + const memctl_options_t *popts)
>> +{
>> +unsigned int frc_
Dear Leon,
In message <[EMAIL PROTECTED]> you wrote:
>
> > * Intermediate releases, that might become necessary because of
> > serious bugs or other major problems, shall be indicated by
> > incrementing the "SUBLEVEL" field.
> > ...
> From experience with other open-source projects:
>
> I wou
Hello Again
>>
>> All the boards I am using use the same link script, shall I copy
>> it to its specific directory? Do you really want this? It is not
>> better to do it like the MODE B (cp common_script to board dir)?
>
> If they use the same linker script you can handle this for example
> l
Dear Jerry Van Baren,
In message <[EMAIL PROTECTED]> you wrote:
>
> Of course, we need silly alphabetical animal names for "code names."
Do we?
> No, wait, that's been done before. I know! We can use u-boat names for
> the code names. We can start with the code name "Unterseeboot 1."
><
Dear "Ricardo Ribalda Delgado",
In message <[EMAIL PROTECTED]> you wrote:
>
> All the boards I am using use the same link script, shall I copy
> it to its specific directory? Do you really want this? It is not
> better to do it like the MODE B (cp common_script to board dir)?
If they use the
Hello,
On Fri, Aug 29, 2008 at 11:19 PM, Wolfgang Denk <[EMAIL PROTECTED]> wrote:
> after some discussions in the past I propose to use the following
> numbering scheme for future releases of U-Boot (starting with the
> ...
> That means the upcoming release, which is scheduled for October
> 2008
Wolfgang Denk wrote:
> Hi,
>
> after some discussions in the past I propose to use the following
> numbering scheme for future releases of U-Boot (starting with the
> upcoming one):
>
> * Regular releases (about once every two months or so) shall be named
> ".MM" with = year as 4 digit
Dear "Wolfgang Denk"
OK, just two questions.
All the boards I am using use the same link script, shall I copy
it to its specific directory? Do you really want this? It is not
better to do it like the MODE B (cp common_script to board dir)?
I want to create two different targets: ml50
Dear "Ricardo Ribalda Delgado",
In message <[EMAIL PROTECTED]> you wrote:
>
> Before this "unification" patch I send another path that did treat
> the avnet board as a new board (a lot of code replication). This is
> what I call the old way.
>
> Let me be more clear. What do we want:
>
> MODE
Hello,
[snip]
> +
> +/* DDR SDRAM control configuration 2 (DDR_SDRAM_CFG_2) */
> +static void set_ddr_sdram_cfg_2(fsl_memctl_config_regs_t *ddr,
> +const memctl_options_t *popts)
> +{
> + unsigned int frc_sr = 0;/* Force self refresh */
> + unsigned int
> "Kim" == Kim Phillips <[EMAIL PROTECTED]> writes:
Kim> this is a duplicate of:
Ahh sorry, I must have missed that one.
Kim> so I'll merge your better description and s-o-b to that one if you
Kim> don't mind.
Yeah, that's fine.
--
Bye, Peter Korsgaard
_
Hi,
after some discussions in the past I propose to use the following
numbering scheme for future releases of U-Boot (starting with the
upcoming one):
* Regular releases (about once every two months or so) shall be named
".MM" with = year as 4 digits, MM = month (01..12)
In other wo
Hello Wolfgang
Before this "unification" patch I send another path that did treat
the avnet board as a new board (a lot of code replication). This is
what I call the old way.
Let me be more clear. What do we want:
MODE A
=
ml507_config: unconfig
BOARD_DIR=$(obj)board/xilinx/
Dear "Ricardo Ribalda Delgado",
In message <[EMAIL PROTECTED]> you wrote:
>
> I have no problem in setting the Makefile in the classic way, I just
> wanted to create a new way with the less code replication possible.
>
>Shall I continue with this idea or I move back to the old way?
I'm no
Jean-Christophe PLAGNIOL-VILLARD wrote:
> Hi Ben,
>
>
>>> + * along with this program; if not, write to the Free Software
>>> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
>>> + * MA 02111-1307 USA
>>> + */
>>> +#include
>>> +
>>> +#include
>>> +
>>> +extern int macb_eth_initialize
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
fs/Makefile | 10 +-
fs/cramfs/Makefile |7 ---
fs/cramfs/cramfs.c |5 -
fs/cramfs/uncompress.c |4
fs/ext2/Makefile|6 +++---
fs/ext2/d
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile|1 -
common/cmd_console.c |9 +-
common/cmd_terminal.c | 10 +-
common/console.c | 62 ++---
common/devices.c | 79 +++---
common/lists.c | 734
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
include/linux/list.h | 506 +++-
include/linux/poison.h | 13 ++
2 files changed, 474 insertions(+), 45 deletions(-)
diff --git a/include/linux/list.h b/include/linux/list.h
in
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile |2 +-
common/miiphyutil.c |2 --
drivers/net/phy/Makefile |2 +-
3 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/common/Makefile b/common/Makefile
index 918b908..6ba20c
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/cmd_terminal.c |4
1 files changed, 0 insertions(+), 4 deletions(-)
diff --git a/common/cmd_terminal.c b/common/cmd_terminal.c
index 8871607..57943c1 100644
--- a/common/cmd_terminal.c
+++ b/common/cmd_termina
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile | 70 +--
1 files changed, 37 insertions(+), 33 deletions(-)
diff --git a/common/Makefile b/common/Makefile
index 6ba20c0..6365fae 100644
--- a/common/Make
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile |1 -
lib_generic/Makefile|1 +
{common => lib_generic}/crc16.c |0
3 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/common/Makefile b/common/Makefile
inde
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile|1 -
drivers/i2c/Makefile |1 +
{common => drivers/i2c}/soft_i2c.c |0
3 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/common/Makefile b/common/Make
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile |1 -
lib_generic/Makefile |1 +
{common => lib_generic}/gunzip.c |0
3 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/common/Makefile b/common/Makefile
i
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
Makefile |1 +
common/Makefile|1 -
drivers/net/phy/Makefile | 46
{common => drivers/net/phy}/miiphybb.c |0
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile|1 -
drivers/spi/Makefile |3 ++-
{common => drivers/spi}/soft_spi.c |0
3 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/common/Makefile b/common/Ma
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile |3 ++-
common/cmd_autoscript.c |4
2 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/common/Makefile b/common/Makefile
index 0c8ef5b..918b908 100644
--- a/common/Makefile
+++
Hi Ben,
>> + * along with this program; if not, write to the Free Software
>> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
>> + * MA 02111-1307 USA
>> + */
>> +#include
>> +
>> +#include
>> +
>> +extern int macb_eth_initialize(int id, void *regs, unsigned int phy_addr);
>> +
>> +#if
On 15:22 Fri 29 Aug , Wolfgang Denk wrote:
> Dear Jean-Christophe PLAGNIOL-VILLARD,
>
> In message <[EMAIL PROTECTED]> you wrote:
> > Hi Wolfgang
> > Please pull
> > The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4:
> > Wolfgang Denk (1):
> > Merge branch '
Wolfgang,
The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4:
Wolfgang Denk (1):
Merge branch 'master' of /home/wd/git/u-boot/custodians
are available in the git repository at:
git://git.denx.de/u-boot-mpc5xxx.git master
Ben Warren (2):
Move MPC5xx
On Fri, 29 Aug 2008 20:37:25 +0200
Peter Korsgaard <[EMAIL PROTECTED]> wrote:
> Set gpio level register before direction register to inhibit
> glitches on high level output pins.
>
> Dir and data gets cleared at powerup, so high level output lines see
> a short low pulse between setting the direc
This patch adds bootm_start() return value check. If
error status is returned, we do not proceed further to
prevent board reset or crash as we still can recover
at this point.
Signed-off-by: Anatolij Gustschin <[EMAIL PROTECTED]>
---
common/cmd_bootm.c |3 ++-
common/image.c |2 +-
2
Set gpio level register before direction register to inhibit
glitches on high level output pins.
Dir and data gets cleared at powerup, so high level output lines see
a short low pulse between setting the direction and level registers.
Issue was seen on a new board with the nReset line of the NOR
Hi Sergey,
Sergey Lapin wrote:
> This patch provides support for AFEB9260 board, a product of
> OpenSource hardware and software. Some commertial projects
> are made with this design. A board is basically AT91SAM9260-EK
> with some modifications and different peripherals and different
> parts used
rearrange some #if !defined() / #else / #endif statements to remove
the negative logic.
Signed-off-by: Andrew Dyer <[EMAIL PROTECTED]>
---
drivers/video/cfb_console.c | 24
1 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/video/cfb_console.c b/d
Hi Bryan,
The USB/RS232 cable is a USB device, it shall has firmware in it,
which works as a USB slave. What I need to do is have some code talk
to this device via the Host controller - ISP1561. So, I need some code
as usb-storage.c, maybe called usb-serial.c.
I am not sure how "usbtty" being us
Hi Stefan,
Thanks.
> Somehow your patch was malformatted though. Please see the ">From bdc..."
> above. This should not be included in the patch mail. Did you create this
> patch with git format-patch and send it with git send-email?
I created the patch using git format-patch. I had applied th
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <[EMAIL PROTECTED]> you wrote:
> Hi Wolfgang
> Please pull
> The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4:
> Wolfgang Denk (1):
> Merge branch 'master' of /home/wd/git/u-boot/custodians
>
> are available in
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <[EMAIL PROTECTED]> you wrote:
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
> ---
> include/linux/list.h | 506
> +++-
> include/linux/poison.h | 13 ++
Do we really need t
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message <[EMAIL PROTECTED]> you wrote:
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
> ---
> common/Makefile |4 +-
> common/{cmd_autoscript.c => autoscript.c} | 44
> common/cmd_autoscript.
Hi Wolfgang
Please pull
The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4:
Wolfgang Denk (1):
Merge branch 'master' of /home/wd/git/u-boot/custodians
are available in the git repository at:
git://git.denx.de/u-boot-arm.git Makefile
Jean-Christophe PLAGNIOL-V
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile | 70 +--
1 files changed, 37 insertions(+), 33 deletions(-)
diff --git a/common/Makefile b/common/Makefile
index 68aded6..99781fe 100644
--- a/common/Make
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <[EMAIL PROTECTED]>
---
common/Makefile |4 +-
common/{cmd_autoscript.c => autoscript.c} | 44
common/cmd_autoscript.c | 158 -
3 files changed, 3 insertions(+),
Which CPU (ARCH) should i define for ARM7EJS ?
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
Dear Wolfgang:
I believe that it is not setting any configuration information. In
many boards the TEXT_BASE address is set up in the makefile depending
if the user wants to compile u-boot for ram o for flash. Like the
acadia (and many others)
@echo "TEXT_BASE = 0x0100" > $(obj)board/amc
Dear Ricardo,
in message <[EMAIL PROTECTED]> you wrote:
> ml507_flash_config: unconfig
>BOARD_DIR=$(obj)board/xilinx/ml507 \
>TEXT_BASE=0xFE36 \
>LINK_SCRIPT=$(obj)board/xilinx/ppc440-generic/u-boot-rom.lds \
>CONFIG_SCRIPT="ml507 ppc ppc4xx ml5
Hi Wolfgang,
My apologies. As I mentioned I'm pretty new to online forums and mailing
lists. I was trying different ways to get help!
Regards,
Muzammal
-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]
Sent: Thursday, August 28, 2008 7:35 PM
To: Ahmed, Muzammal
Cc: u-
Hello Stefan
I did want to reduce the code replication in the Makefile. So I
created a common target called xilinx_ppc440 that uses three
variables: BOARD_DIR,TEXT_BASE (u-boot location), LINK_SCRIPT and
CONFIG_SCRIPT (to setup board dir and config .h), every board just
setup this variables and
This is needed since now with HUSH enabled (amcc-common.h) the image
read from NAND exceeds the previous limit.
Signed-off-by: Stefan Roese <[EMAIL PROTECTED]>
---
include/configs/sequoia.h |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/include/configs/sequoia.h b/inclu
This function is needed for the new NAND infrastructure. We only need
a dummy implementation though for the NDFC.
Signed-off-by: Stefan Roese <[EMAIL PROTECTED]>
---
cpu/ppc4xx/ndfc.c |8
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/cpu/ppc4xx/ndfc.c b/cpu/ppc4xx/nd
Add support for environment in NAND with automatic recognition, including
unaligned environment, bad-block skipping, redundant environment copy.
A new parameter is introduced to limit the number of sectors that may be
used on NAND, when skipping bad blocks, it is unused on NOR.
Take care to preser
Hi Jeff,
On Monday 25 August 2008, [EMAIL PROTECTED] wrote:
> I found the issue... it is with the NAND image (NUB). The NUB destination
> address is the TEXT_BASE address defined in the top level Makefile
>
> The SPL loads the NUB, and then the NUB relocates itself to the top of
> RAM (at 0xFF230
This patch provides support for AFEB9260 board, a product of
OpenSource hardware and software. Some commertial projects
are made with this design. A board is basically AT91SAM9260-EK
with some modifications and different peripherals and different
parts used. Main purpose of this project is to gain
Imported from Freescale's Linux NFC driver from the i.MX31 BSP
release 5 (Linux 2.6.22.5) and the i.MX31 PDK BSP (Linux 2.6.24).
The code has been changed to conform (better) with the coding style
in Linux/U-boot. Sections not used by U-boot have been removed.
The driver has been tested on i.MX31
Signed-off-by: Magnus Lilja <[EMAIL PROTECTED]>
The U-Boot environment is placed in NAND.
---
include/configs/mx31pdk.h | 26 --
1 files changed, 24 insertions(+), 2 deletions(-)
diff --git a/include/configs/mx31pdk.h b/include/configs/mx31pdk.h
index 6df1a00..b511e36 10
Add support for the Freescale i.MX31 PDK (a.k.a 3DS) board. Ethernet and
MC13873 RTC support is enabled by this patch.
Booting from NAND is not supported yet so U-boot relies on some other
initial boot loader to set up SDRAM and clocks and copying U-boot to SDRAM.
Signed-off-by: Magnus Lilja <[EM
Signed-off-by: Magnus Lilja <[EMAIL PROTECTED]>
---
include/configs/imx31_litekit.h | 12
1 files changed, 12 insertions(+), 0 deletions(-)
diff --git a/include/configs/imx31_litekit.h b/include/configs/imx31_litekit.h
index 62a03fa..da155cf 100644
--- a/include/configs/imx31_litek
This patch adds the reset_timer() function (needed by nand_base.c) and
modifies the get_timer_masked() to work in the same way as the omap24xx
function.
Signed-off-by: Magnus Lilja <[EMAIL PROTECTED]>
---
cpu/arm1136/mx31/interrupts.c | 24
1 files changed, 20 insertion
The i.MX31 has three SPI buses and each bus has several chip selects
and the MC13783 chip can be connected to any of these. The current
RTC driver for MC13783 is hardcoded for CSPI2/SS2.
This patch makes make MC13783 SPI bus and chip select configurable
via CONFIG_MC13783_SPI_BUS and CONFIG_MC1378
Hi again
This series of patches adds support for the NAND flash controller in the
i.MX31 device and also introduces the Freescale i.MX31 PDK board.
Changes since v2:
- Added doc/README.mx31 (contains MC13783 SPI config documentation)
- Split the PDK patch into two patches, the first introduces t
This patch provides support for AFEB9260 board, a product of
OpenSource hardware and software. Some commertial projects
are made with this design. A board is basically AT91SAM9260-EK
with some modifications and different peripherals and different
parts used. Main purpose of this project is to gain
On Tuesday 26 August 2008, Wolfgang Ocker wrote:
> Made NAND bank configuration setting a config variable.
Applied to u-boot-ppc4xx. Thanks.
Best regards,
Stefan
=
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Z
It's preparation for UBI codes.
UBI uses partition and get & put mtd devices
Signed-off-by: Kyungmin Park <[EMAIL PROTECTED]>
---
diff --git a/drivers/mtd/Makefile b/drivers/mtd/Makefile
index 6538f7a..d225a68 100644
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -25,6 +25,7 @@ include $
On Friday 29 August 2008, Victor Gallardo wrote:
> This patch fixes a UIC external_interrupt hang if critical or non-critical
> interrupt is set at the same time as a normal interrupt is set on UIC0.
Applied to u-boot-ppc4xx. Thanks.
Best regards,
Stefan
=
On Thursday 28 August 2008, Prodyut Hazarika wrote:
> >From bdc99201a532b040b3d346fca5acff8332d670e4 Mon Sep 17 00:00:00 2001
>
> From: Prodyut Hazarika <[EMAIL PROTECTED]>
> Date: Wed, 27 Aug 2008 16:26:36 -0700
> Subject: [PATCH] Optimizations/Cleanups for IBM DDR2 memory controller
> Removed Ma
Ricardo,
sorry that the review took so long. Here we go:
On Wednesday 27 August 2008, Ricardo Ribalda Delgado wrote:
> This patch provides an unificated way of handling xilinx v5 ppc440 boards.
One thing I noticed after applying your patch is the output while running
MAKEALL:
[EMAIL PROTECTED]
73 matches
Mail list logo