Forgot to export this one. Needed when pasemi_mac is compiled as a module.
Signed-off-by: Olof Johansson <[EMAIL PROTECTED]>
---
Jeff, since the dma_lib stuff went up through netdev-2.6, please apply and
feed this one up with the rest.
Thanks,
Olof
Index: 2.6.24/arch/powerpc/platforms/pasemi
On Thu, Nov 29, 2007 at 04:13:14PM +0100, Geert Uytterhoeven wrote:
> On Wed, 28 Nov 2007, Geert Uytterhoeven wrote:
> > +static inline void warn_emulated_sysctl_register(void)
> > +{
> > + int res = register_sysctl_table(warn_emulated_sysctl_root);
> ^^
> > + printk("@@@ regist
On Dec 14, 2007, at 2:12 AM, Olof Johansson wrote:
> On Thu, Nov 29, 2007 at 04:13:14PM +0100, Geert Uytterhoeven wrote:
>> On Wed, 28 Nov 2007, Geert Uytterhoeven wrote:
>>> +static inline void warn_emulated_sysctl_register(void)
>>> +{
>>> + int res = register_sysctl_table(warn_emulated_sysct
On Fri, Dec 14, 2007 at 02:08:14AM -0600, Kumar Gala wrote:
> I'd say wait for Paul to pickup my 2.6.25 request. Than the base will
> have the isel emulation as well.
It was spotting the isel patch in your queue that made me go back and
look at the thread. :)
-Olof
__
On Dec 6, 2007, at 8:01 PM, David Gibson wrote:
> On Wed, Dec 05, 2007 at 06:37:53PM +0800, Li Yang wrote:
>> Signed-off-by: Li Yang <[EMAIL PROTECTED]>
>> ---
>> Update SATA nodes; remove serdes nodes; add aliases and labels.
>>
>> arch/powerpc/boot/dts/mpc8377_mds.dts | 270 +++
On Wed, Dec 05, 2007 at 12:39:12PM -0600, Scott Wood wrote:
> On Wed, Dec 05, 2007 at 09:48:41AM +0900, Paul Mundt wrote:
> > On Tue, Dec 04, 2007 at 02:01:21PM -0600, Olof Johansson wrote:
> > > On Tue, Dec 04, 2007 at 10:49:21PM +0300, Anton Vorontsov wrote:
> > > > tristate "Generic plat
On Fri, Dec 14, 2007 at 02:12:10AM -0600, Olof Johansson wrote:
> Care to resubmit a clean patch under a fresh subject? Paul didn't chime
> in but hopefully he can pick it up for 2.6.25.
Next time I will take the time to re-read the whole thread. :)
Seems like the open question was how to warn on
Hi,
Minor nitpicks:
On Fri, Dec 14, 2007 at 03:56:05PM +1100, Benjamin Herrenschmidt wrote:
> --- linux-merge.orig/arch/powerpc/kernel/pci_32.c 2007-12-14
> 15:49:28.0 +1100
> +++ linux-merge/arch/powerpc/kernel/pci_32.c 2007-12-14 15:49:29.0
> +1100
> @@ -48,7 +51,7 @@ st
On Fri Dec 14 10:43:27 EST 2007, Stephen Neuendorffer wrote:
> From: Grant Likely
>
> This target produces a flat binary rather than an ELF file,
> fixes the entry point at the beginning of the image, and takes
> a complete device tree with no fixups needed.
>
> The device tree must have labels
Hi,
I think it is possible to make common code to support both IPIC and MPIC.
Currently, the MPIC has already implemented MSI which is different from IPIC
and embedded into the mpic code body.
If want to unifiy MSI code, we need to remove the current MPIC MSI
implementation.
Micheal, what is
On Dec 14, 2007, at 2:47 AM, Li Tony wrote:
>
> Hi,
>
> I think it is possible to make common code to support both IPIC and
> MPIC.
> Currently, the MPIC has already implemented MSI which is different
> from IPIC and embedded into the mpic code body.
> If want to unifiy MSI code, we need to r
> On Fri, Dec 14, 2007 at 03:56:05PM +1100, Benjamin Herrenschmidt wrote:
>
> > --- linux-merge.orig/arch/powerpc/kernel/pci_32.c 2007-12-14
> > 15:49:28.0 +1100
> > +++ linux-merge/arch/powerpc/kernel/pci_32.c2007-12-14
> > 15:49:29.0 +1100
> > @@ -48,7 +51,7 @@ stati
> >> + device_type = "serial";
> >> + compatible = "ns16550";
> >> + reg = <4600 100>;
> >> + clock-frequency = <0>;
> >> + interrupts = ;
> >> + interrupt-parent = < &ipic >;
> >> + };
>
On Fri, 2007-12-14 at 16:52 +0800, Kumar Gala wrote:
>
> On Dec 14, 2007, at 2:47 AM, Li Tony wrote:
>
> >
> > Hi,
> >
> > I think it is possible to make common code to support both IPIC
> and
> > MPIC.
> > Currently, the MPIC has already implemented MSI which is different
> > from IPIC a
Fix build break of powerpc holly_defconfig:
In file included from arch/powerpc/platforms/embedded6xx/holly.c:24:
include/linux/ide.h:1206: error: 'CONFIG_IDE_MAX_HWIFS' undeclared here (not in
a function)
There's no need to have a sized array in the prototype, might as well
turn it into a pointe
> -Original Message-
> From: Kumar Gala [mailto:[EMAIL PROTECTED]
> Sent: Friday, December 14, 2007 4:52 PM
> To: Li Tony
> Cc: Phillips Kim; [EMAIL PROTECTED]; linuxppc-dev list;
> Jin Zhengxiong; Olof Johansson
> Subject: Re: [PATCH 2/2] powerpc: Add IPIC MSI support
>
>
> On Dec 1
On Fri, 2007-12-14 at 02:52 -0600, Kumar Gala wrote:
> On Dec 14, 2007, at 2:47 AM, Li Tony wrote:
>
> >
> > Hi,
> >
> > I think it is possible to make common code to support both IPIC and
> > MPIC.
> > Currently, the MPIC has already implemented MSI which is different
> > from IPIC and embedd
Hi,
I posted a patch adding windfarm-pm121 driver, i wish it were included
in 2.6.24 . Can you review it ?
http://ozlabs.org/pipermail/linuxppc-dev/2007-December/047641.html
Regards,
Étienne.
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https
From: Bob Nelson <[EMAIL PROTECTED]>
This is a patch removes an OProfile dependency on the spufs module.
This was causing a problem for multiplatform systems that are
built with support for Oprofile on Cell but try to load the
oprofile module on another system.
Signed-off-by: Bob Nelson <[EMAIL P
> > It can use the new notifier that happens before freezing yes. Johannes,
> > I think that's pretty much what my old powermac implementation did
> > (using my private notifier scheme I had there), might be worth reviving
> > that bit and sticking it into the generic apm_emu ...
>
> Note that yo
On Fri, Dec 14, 2007 at 02:23:13AM -0600, Olof Johansson wrote:
> On Wed, Dec 05, 2007 at 12:39:12PM -0600, Scott Wood wrote:
> > Why is it dependent on anything other than platform bus support and ATA?
>
> There's no way to specify dependency on platform bus as a config option,
> that's likely wh
On Dec 14, 2007, at 9:53 AM, Scott Wood wrote:
> On Thu, Dec 13, 2007 at 11:19:33PM -0600, Kumar Gala wrote:
>> Can we make this a /dts-v1/; since its new.
>
> It's not really new; it's just been collecting dust for a while. :-P
Its new to us on the list :P
> Are there any tools to autoconvert
On 12/14/07, Milton Miller <[EMAIL PROTECTED]> wrote:
> On Fri Dec 14 10:43:27 EST 2007, Stephen Neuendorffer wrote:
>
> > From: Grant Likely
> >
> > This target produces a flat binary rather than an ELF file,
> > fixes the entry point at the beginning of the image, and takes
> > a complete devic
On Thu, Dec 13, 2007 at 11:19:33PM -0600, Kumar Gala wrote:
> Can we make this a /dts-v1/; since its new.
It's not really new; it's just been collecting dust for a while. :-P
Are there any tools to autoconvert (preferably without losing comments)?
> >+/ {
> >+model = "EP8248E";
> >+compa
On Nov 22, 2007, at 9:46 AM, Dale Farnsworth wrote:
> Add the ability to build a ppc_85xx kernel to run at a physical
> address of 32MB.
>
> Signed-off-by: Dale Farnsworth <[EMAIL PROTECTED]>
> ---
> arch/powerpc/Kconfig |2 +-
> arch/powerpc/kernel/head_fsl_booke.S | 23
On Fri, Dec 14, 2007 at 10:09:28AM -0600, Scott Wood wrote:
> On Fri, Dec 14, 2007 at 02:23:13AM -0600, Olof Johansson wrote:
> > On Wed, Dec 05, 2007 at 12:39:12PM -0600, Scott Wood wrote:
> > > Why is it dependent on anything other than platform bus support and ATA?
> >
> > There's no way to spe
On Fri, Dec 14, 2007 at 10:48:58AM -0600, Kumar Gala wrote:
> On Nov 22, 2007, at 9:46 AM, Dale Farnsworth wrote:
>
> > Add the ability to build a ppc_85xx kernel to run at a physical
> > address of 32MB.
> >
> > Signed-off-by: Dale Farnsworth <[EMAIL PROTECTED]>
> > ---
> > arch/powerpc/Kconfig
> -Original Message-
> From: Milton Miller [mailto:[EMAIL PROTECTED]
> Sent: Friday, December 14, 2007 12:06 AM
> To: Stephen Neuendorffer
> Cc: ppcdev; Grant Likely
> Subject: Re: [PATCH 1/7] bootwrapper: Add a
> firmware-independent "raw" target.
>
> On Fri Dec 14 10:43:27 EST 2007,
Fix documentation once and for ever, because I'm pretty tired of
repeating that I am merely following it. ;-)
http://ozlabs.org/pipermail/linuxppc-dev/2007-December/048096.html
http://ozlabs.org/pipermail/linuxppc-dev/2007-November/046977.html
http://ozlabs.org/pipermail/linuxppc-dev/2007-Novembe
Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
---
As requested, compatible is used rather than name for probing.
The simple-bus name comes from ePAPR drafts.
arch/powerpc/boot/dts/mpc8313erdb.dts | 38 +
arch/powerpc/platforms/83xx/mpc8313_rdb.c | 16 ++
This patch adds localbus and pata nodes to use CF IDE interface
on MPC8349E-mITX boards.
Patch also adds code to probe localbus.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
Acked-by: Olof Johansson <[EMAIL PROTECTED]>
---
arch/powerpc/boot/dts/mpc8349emitx.dts| 17 -
On Fri, Dec 14, 2007 at 12:56:24PM -0600, Scott Wood wrote:
> Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> Respun according to feedback; also, fixed a couple direct accesses
> of iomem.
>
> drivers/mtd/nand/Kconfig |9 +
> driv
Hi all,
Here is the third version of the OF-platform PATA driver and
related patches.
Changes since v2:
- "PPC" added to PATA_PLATFORM "depends on" Kconfig entry;
I didn't remove EMBEDDED "depends on" -- this wasn't discussed
much and these patches should not depend on the decision.
- cosmet
Split pata_platform_{probe,remove} into two pieces:
1. pata_platform_{probe,remove} -- platform_device-dependant bits;
2. __ptata_platform_{probe,remove} -- device type neutral bits.
This is done to not duplicate code for the OF-platform driver.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
This driver nicely wraps around pata_platform library functions,
and provides OF platform bus bindings to the PATA devices.
Also add || PPC to the PATA_PLATFORM's "depends on" Kconfig entry,
needed for PA Semi Electra.
Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>
Reviewed-by: Olof Johansson
Kumar Gala wrote:
>
> On Dec 14, 2007, at 9:53 AM, Scott Wood wrote:
>
>> On Thu, Dec 13, 2007 at 11:19:33PM -0600, Kumar Gala wrote:
>>> Can we make this a /dts-v1/; since its new.
>>
>> It's not really new; it's just been collecting dust for a while. :-P
>
> Its new to us on the list :P
I tho
Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
---
Respun according to feedback; also, fixed a couple direct accesses
of iomem.
drivers/mtd/nand/Kconfig |9 +
drivers/mtd/nand/Makefile|1 +
drivers/mtd/nand/fsl_elbc_nand.c | 12
Anton Vorontsov wrote:
> On Fri, Dec 14, 2007 at 12:56:24PM -0600, Scott Wood wrote:
>> +#if 0
>> +#define ELBC_NAND_DEBUG_LVL 6
>> +#endif
>> +
>> +#ifdef ELBC_NAND_DEBUG_LVL
>> +static int fcm_debug_level = ELBC_NAND_DEBUG_LVL;
>> +#define FCM_DEBUG(n, args...) \
>> +do {
On Fri, Dec 14, 2007 at 01:33:41PM -0600, Scott Wood wrote:
> Anton Vorontsov wrote:
> >On Fri, Dec 14, 2007 at 12:56:24PM -0600, Scott Wood wrote:
> >>+#if 0
> >>+#define ELBC_NAND_DEBUG_LVL 6
> >>+#endif
> >>+
> >>+#ifdef ELBC_NAND_DEBUG_LVL
> >>+static int fcm_debug_level = ELBC_NAND_DEBUG_LVL;
Scott Wood wrote:
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> Jeff, can you ack this to go through Paul's tree
> (assuming nothing wrong with it)?
>
> drivers/net/gianfar.c | 137
> -
> drivers/net/gianfar.h | 13 +++-
> driv
On Friday 14 December 2007, Anton Vorontsov wrote:
> > >Maybe this desires its own header?
> >
> > It can be factored out if anything else ever uses it.
>
> It's just confusing to parse lbc-specific and nand-specific code
> placed in the same file.
In that case, you could argue for splitting the
Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
---
Fixed some formatting issues, removed some leftover debugging cruft,
and added a comment about potential conflicts in the interrupt handling.
drivers/mtd/nand/Kconfig |9 +
drivers/mtd/nan
On Tue, Dec 04, 2007 at 07:28:00PM -0600, Timur Tabi wrote:
> Scott Wood wrote:
>
>> The physical address certainly is useful when you have more than one
>> device of the same name.
>
> What I meant was that the physical address isn't helpful by itself.
>
>> So then you'd get "firmware-ucc.e01024"
Greg KH wrote:
> In the near future (2.6.26) there will not be a limit on the size of the
> file name, so we should not have this problem anymore.
In that case, I won't worry about it. I would have preferred 2.6.25, since I
have code going into 2.6.25 that is affected by the current limit.
--
On Fri, Dec 14, 2007 at 09:53:41AM -0600, Scott Wood wrote:
> On Thu, Dec 13, 2007 at 11:19:33PM -0600, Kumar Gala wrote:
> > Can we make this a /dts-v1/; since its new.
>
> It's not really new; it's just been collecting dust for a while. :-P
>
> Are there any tools to autoconvert (preferably wit
On Mon, Dec 10, 2007 at 05:37:38PM -0700, Mark A. Greer wrote:
> From: Mark A. Greer <[EMAIL PROTECTED]>
>
> Convert the prpmc2800.dts file to dts-v1. Basically, this means
> converting the numeric constants to be 'C'-like (e.g., hexadecimal
> numbers start with '0x').
[snip]
>
On Friday, 14 of December 2007, Johannes Berg wrote:
>
> > > It can use the new notifier that happens before freezing yes. Johannes,
> > > I think that's pretty much what my old powermac implementation did
> > > (using my private notifier scheme I had there), might be worth reviving
> > > that bit
On Fri, 14 Dec 2007 16:17:36 -0600
Scott Wood <[EMAIL PROTECTED]> wrote:
> Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> Fixed some formatting issues, removed some leftover debugging cruft,
> and added a comment about potential conflicts in
Josh Boyer wrote:
> On Fri, 14 Dec 2007 16:17:36 -0600
> Scott Wood <[EMAIL PROTECTED]> wrote:
>
> > + child = NULL;
> > + while ((child = of_get_next_child(ofdev->node, child)))
> > + if (of_device_is_compatible(child, "fsl,elbc-fcm-nand"))
> > + fsl_elbc_chip_probe
In message <[EMAIL PROTECTED]> you wrote:
> We have multiple calls to has_feature being inlined, but gcc can't
> be sure that the store via get_paca() doesn't alias the path to
> cur_cpu_spec->feature.
>
> Reorder to put the calls to read_purr and read_spurr adjacent to each
> other. To add a sen
On Thu, Dec 13, 2007 at 11:17:14AM -0600, Scott Wood wrote:
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> arch/powerpc/boot/dts/mpc8313erdb.dts | 37
> +
> arch/powerpc/platforms/83xx/mpc8313_rdb.c | 17 +
> 2 files changed, 54 insertions(
On Fri, Dec 14, 2007 at 12:58:26PM -0600, Scott Wood wrote:
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> As requested, compatible is used rather than name for probing.
> The simple-bus name comes from ePAPR drafts.
>
> arch/powerpc/boot/dts/mpc8313erdb.dts | 38
> +++
On Fri, Dec 14, 2007 at 04:17:36PM -0600, Scott Wood wrote:
> Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
> Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> ---
> Fixed some formatting issues, removed some leftover debugging cruft,
> and added a comment about potential conflicts in the interrupt
On Sat, Dec 15, 2007 at 12:55:43PM +1100, David Gibson wrote:
> > + // CS0 and CS1 are swapped when
> > + // booting from nand, but the
> > + // addresses are the same.
>
> Should the bootwrapper have some kind of fixup to poke in the correct
> chipselect values based
On Sat, Dec 15, 2007 at 01:58:51PM +1100, David Gibson wrote:
> On Fri, Dec 14, 2007 at 04:17:36PM -0600, Scott Wood wrote:
> > Signed-off-by: Nick Spence <[EMAIL PROTECTED]>
> > Signed-off-by: Scott Wood <[EMAIL PROTECTED]>
> > ---
> > Fixed some formatting issues, removed some leftover debugging
On Fri, 2007-12-14 at 14:40 -0800, Greg KH wrote:
> On Tue, Dec 04, 2007 at 07:28:00PM -0600, Timur Tabi wrote:
> > Scott Wood wrote:
> >
> >> The physical address certainly is useful when you have more than one
> >> device of the same name.
> >
> > What I meant was that the physical address isn'
> index 8b642ab..db0e749 100644
> --- a/arch/powerpc/kernel/misc_32.S
> +++ b/arch/powerpc/kernel/misc_32.S
> @@ -816,6 +816,75 @@ relocate_new_kernel:
> /* r4 = reboot_code_buffer */
> /* r5 = start_address */
>
> +#ifdef CONFIG_E500
> + /*
> + * Since we can't turn of
On Thu, 2007-11-22 at 08:46 -0700, Dale Farnsworth wrote:
> This is needed for the ppc32 /dev/oldmem driver of crash dump.
Kumar's working (well, last I heard he was) on a fixmap mechanism
so we can do that sort of thing without CONFIG_HIGHMEM, you may
want to sync with him here, that would allow
On Sat, Dec 15, 2007 at 05:14:29PM +1100, Benjamin Herrenschmidt wrote:
>
> On Fri, 2007-12-14 at 14:40 -0800, Greg KH wrote:
> > On Tue, Dec 04, 2007 at 07:28:00PM -0600, Timur Tabi wrote:
> > > Scott Wood wrote:
> > >
> > >> The physical address certainly is useful when you have more than one
>
Signed-off-by: Stefan Roese <[EMAIL PROTECTED]>
---
arch/powerpc/boot/dts/bamboo.dts |9 +
arch/powerpc/boot/dts/ebony.dts |7 +++
arch/powerpc/boot/dts/ep405.dts |6 ++
arch/powerpc/boot/dts/katmai.dts |7 +++
arch/powerpc/boot/dts/kilauea.dts |7
60 matches
Mail list logo