On Mon, 13 May 2024 03:46:50 GMT, Kevin Driver <kdri...@openjdk.org> wrote:
>> Introduce an API for Key Derivation Functions (KDFs), which are >> cryptographic algorithms for deriving additional keys from a secret key and >> other data. See [JEP 478](https://openjdk.org/jeps/478). > > Kevin Driver has updated the pull request incrementally with one additional > commit since the last revision: > > re-enable preview annotations src/java.base/share/classes/javax/crypto/spec/HKDFParameterSpec.java line 206: > 204: * @return a {@code Builder} to mutate > 205: */ > 206: static Builder extract() { The expand method return an Expand object, the extractExpand returns a ExtractExpand. It looks a bit strange to have the extract method return a Builder rather than extract something or return an Extract object. Try renaming it to builder and see if it looks any better. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/18924#discussion_r1598137045