On Fri, Feb 10, 2006 at 02:58:20AM +0100, Lars Gullik Bjønnes wrote:
>
> The LyX source repository has now moved to subversion.
>
> Anonaccess with svn://svn.lyx.org/lyx/lyx-devel/trunk (for head branch)
>
> Developer access with svn+ssh://svn.lyx.org/lyx/lyx-devel/trunk
>
> Super short quicks
Am Freitag, den 10.02.2006, 02:58 +0100 schrieb Lars Gullik Bjønnes:
> The repo is not opened up for commit yet, but checkouts should work
> ok.
It is working for me - I can check out a tree and get correct diffs.
Ready to commit stuff whenever you have time to finish setting it up.
By the way,
The LyX source repository has now moved to subversion.
Anonaccess with svn://svn.lyx.org/lyx/lyx-devel/trunk (for head branch)
Developer access with svn+ssh://svn.lyx.org/lyx/lyx-devel/trunk
The repo is not opened up for commit yet, but checkouts should work
ok.
Super short quickstart for de
Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
> I'll go into non-grumpy-mode after 1.4.0 is released (and when I have
> this subversion thing up and going)
> At least I will do my best to.
That'd be a shame. I quite enjoyed grumpy.
Angus
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
> >> +{
> >> + bool result=true;
> >> + for (size_t i=start; i >
> > bool result = true;
> > for (size_t i = start; i < end; ++i)
> >
> > People are picky here ;-}
>
> That picky?
Even pickier.
A good idiom to follow in for loops is to u
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
> > One thing I like about your code is that it makes the code of clients of
> > ParagraphList a lot more readable. One place where this isn't the case is in
> > undo.C where code like this suggests that you haven't yet hit on the perfect
> > interface.
Angus Leeming a écrit :
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
I would be very happy if you could review my code.
One thing I like about your code is that it makes the code of clients of
ParagraphList a lot more readable. One place where this isn't the case is in
undo.C where code like
Andre Poenitz a écrit :
-class ParagraphList : public std::vector
+using namespace std;
Please no 'using' in headers.
Sure, this was just a quickly made proof of concept.
- ParagraphList::const_iterator p = par + 1;
+ ParagraphList::const_iterator p = par; p++;
Or 'p = boost::
Lars Gullik Bjønnes a écrit :
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| OK Lars,
|
| Why not going the other way? I can first provide a patch that will fix
| interface problems like for example the '++it' instead of 'it+1' but
| without touching ParagraphList.
| Then a second patch will
Am Donnerstag, den 09.02.2006, 21:08 +0100 schrieb Lars Gullik Bjønnes:
> I know that this is an really awkward time to do this, but I am going
> to take the oppurtunity to change to subversion regardless.
Good man!
John
Angus Leeming <[EMAIL PROTECTED]> writes:
| Incidentally, there are two main differences between the way Lars and
| I review code:
| 1. I'm less grumpy and more encouraging
| 2. My opinion counts less than Lars'
I'll go into non-grumpy-mode after 1.4.0 is released (and when I have
this subversion
> "Lars" == Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
Lars> Yes, but I have had no time to act on it.
That's OK, I wanted to be sure.
JMarc
Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
| > "Lars" == Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
|
| Lars> And I belive it will stay like that.
|
| Lars> I know that this is an really awkward time to do this, but I am
| Lars> going to take the oppurtunity to change to subversio
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
> I would be very happy if you could review my code.
One thing I like about your code is that it makes the code of clients of
ParagraphList a lot more readable. One place where this isn't the case is in
undo.C where code like this suggests that you hav
Andre Poenitz <[EMAIL PROTECTED]> writes:
| Use 100 or so for VECTOR_RESERVE _at max_. In fact, I do think
| we should not reserve anything.
agree.
| I'd guess most of these functions should be inline in the header.
Not in the beginning IMHO, it is easy to play with implementation when
it is in
> "Lars" == Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
Lars> And I belive it will stay like that.
Lars> I know that this is an really awkward time to do this, but I am
Lars> going to take the oppurtunity to change to subversion
Lars> regardless.
I guess we have no choice. Go for it.
JM
"Kayvan A. Sylvan" <[EMAIL PROTECTED]> writes:
| On Thu, Feb 09, 2006 at 09:08:25PM +0100, Lars Gullik Bjønnes wrote:
| >
| > And I belive it will stay like that.
| >
| > I know that this is an really awkward time to do this, but I am going
| > to take the oppurtunity to change to subversion reg
On Thu, Feb 09, 2006 at 11:58:26AM +0100, Abdelrazak Younes wrote:
> Anyway, please find attached the patch. Everything but CutAndPaste
> (which crashes lyx) seems to work OK. But I didn't do extensive
> testing... sorry about that. If this is interesting to you, I'll try to
> find some time thi
On Thu, Feb 09, 2006 at 02:41:20PM +0100, Abdelrazak Younes wrote:
> I think this is because the member fontlist is a std::vector
> and eraseIntern seems to be doing a lot of deletion. Would it make sense
> to apply the same strategy as ParagraphList? It should be as easy as
> "templatify" my ver
On Thu, Feb 09, 2006 at 09:08:25PM +0100, Lars Gullik Bjønnes wrote:
>
> And I belive it will stay like that.
>
> I know that this is an really awkward time to do this, but I am going
> to take the oppurtunity to change to subversion regardless.
>
> The conversion is farily easy, I will do this
On Thu, Feb 09, 2006 at 09:08:25PM +0100, Lars Gullik Bjønnes wrote:
>
> And I belive it will stay like that.
>
> I know that this is an really awkward time to do this, but I am going
> to take the oppurtunity to change to subversion regardless.
>
> The conversion is farily easy, I will do this
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| OK Lars,
|
| Why not going the other way? I can first provide a patch that will fix
| interface problems like for example the '++it' instead of 'it+1' but
| without touching ParagraphList.
| Then a second patch will introduce the new ParagraphList (
And I belive it will stay like that.
I know that this is an really awkward time to do this, but I am going
to take the oppurtunity to change to subversion regardless.
The conversion is farily easy, I will do this from the CVS backup on
aussie.
If you have opinions on this you have to be quick t
Angus Leeming <[EMAIL PROTECTED]> writes:
| Abdelrazak Younes wrote:
|
| > This is why I had to write "it++" instead of "it+1" in some cases.
|
| Just browing an interesting thread. You're doing great things here Abdel!
|
| I highlighted the line above because language issues require less thoug
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> As a side note, I don't really like this ParIterator class
Abdelrazak> and I think most of its use could be replaced by a simple
Abdelrazak> use of ParagraphList::iterator. But maybe it's just that I
Abdelrazak> don't
Abdelrazak Younes a écrit :
Martin Vermeer a écrit :
On Thu, Feb 09, 2006 at 05:16:10PM +0100, Abdelrazak Younes wrote:
Jean-Marc Lasgouttes a écrit :
Abdelrazak> Again when pasting multiple paragraphs, my debug info
Abdelrazak> tells me that the multiple insertion are instantaneous but
Abdelr
Am Sonntag, 5. Februar 2006 11:11 schrieb Georg Baum:
> Am Samstag, 4. Februar 2006 18:39 schrieb Georg Baum:
> > Am Samstag, 4. Februar 2006 18:18 schrieb Jean-Marc Lasgouttes:
> > >
> > > I propose to use
> > > \begin_layout
> > > without any name. "" is not good
> > > because it is read explici
Martin Vermeer a écrit :
On Thu, Feb 09, 2006 at 05:16:10PM +0100, Abdelrazak Younes wrote:
Jean-Marc Lasgouttes a écrit :
Abdelrazak> Again when pasting multiple paragraphs, my debug info
Abdelrazak> tells me that the multiple insertion are instantaneous but
Abdelrazak> I have to wait maybe 0.
On Thu, Feb 09, 2006 at 05:16:10PM +0100, Abdelrazak Younes wrote:
> Jean-Marc Lasgouttes a écrit :
> >Abdelrazak> Again when pasting multiple paragraphs, my debug info
> >Abdelrazak> tells me that the multiple insertion are instantaneous but
> >Abdelrazak> I have to wait maybe 0.5 second to see th
OK Lars,
Why not going the other way? I can first provide a patch that will fix
interface problems like for example the '++it' instead of 'it+1' but
without touching ParagraphList.
Then a second patch will introduce the new ParagraphList (the full dual
vector/list one) that will provide the no
Angus Leeming a écrit :
Abdelrazak Younes wrote:
This is why I had to write "it++" instead of "it+1" in some cases.
Just browing an interesting thread. You're doing great things here Abdel!
Thanks. But I have to convince Lars...
I highlighted the line above because language issues require
Abdelrazak Younes wrote:
> This is why I had to write "it++" instead of "it+1" in some cases.
Just browing an interesting thread. You're doing great things here Abdel!
I highlighted the line above because language issues require less thought
than a real code review ;-)
"++it" is generally prefe
Jean-Marc Lasgouttes a écrit :
Abdelrazak> Again when pasting multiple paragraphs, my debug info
Abdelrazak> tells me that the multiple insertion are instantaneous but
Abdelrazak> I have to wait maybe 0.5 second to see them on the
Abdelrazak> screen...
Could it be updateCounters()? This scans th
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| Lars Gullik Bjønnes a écrit :
| > Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| > | I have put convenience function so as to minimize the changes
| > needed
| > | in the code that uses ParagraphList. But there are some minimal (IMHO)
| > | change.
Jean-Marc Lasgouttes a écrit :
"Jean-Marc" == Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
Jean-Marc> Wouldn't it be simpler to use a vector and change its
Jean-Marc> interface to look like a vector? I am not sure why we want
Jean-Marc> a list, actually. Inserting/erasing in a vector of poi
Jean-Marc Lasgouttes a écrit :
"Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
IMHO first step is to make ParagraphList a proper class that
_contains_ a (private) vector. Methods should be added to this
ParagraphList so that what we use from the vector is covered.
Nothing more. N
> "Jean-Marc" == Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
Jean-Marc> Wouldn't it be simpler to use a vector and change its
Jean-Marc> interface to look like a vector? I am not sure why we want
Jean-Marc> a list, actually. Inserting/erasing in a vector of pointers
Jean-Marc> should be f
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> The effect is the same for any paragraph inside
Abdelrazak> "Extended.lyx", but it seems that I was mis leaded by my
Abdelrazak> debug info, sorry for the noise. Actually I think that it
Abdelrazak> is the instructions
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> I don't remember! I cannot configure since the automake
Abdelrazak> changes plus I don't want to mess up my the Makefile that
Abdelrazak> I have modified for the qt4 frontend. A typical gcc call
Abdelrazak> is:
Abdelr
Jean-Marc Lasgouttes a écrit :
"Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
But eraseIntern is only called when removing characters from a
paragraph, right?
Abdelrazak> You are right of course. My use case is to type "Enter" in
Abdelrazak> the middle of the paragraph of a bi
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
>> IMHO first step is to make ParagraphList a proper class that
>> _contains_ a (private) vector. Methods should be added to this
>> ParagraphList so that what we use from the vector is covered.
>> Nothing more. No tricks with usi
Lars Gullik Bjønnes a écrit :
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| I have put convenience function so as to minimize the changes needed
| in the code that uses ParagraphList. But there are some minimal (IMHO)
| change. The interface is simpler so a lot of code could be simplified
| wi
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
>> But eraseIntern is only called when removing characters from a
>> paragraph, right?
Abdelrazak> You are right of course. My use case is to type "Enter" in
Abdelrazak> the middle of the paragraph of a big document (Extended or
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| I have put convenience function so as to minimize the changes needed
| in the code that uses ParagraphList. But there are some minimal (IMHO)
| change. The interface is simpler so a lot of code could be simplified
| with this new class.
By using a s
Abdelrazak Younes a écrit :
Jean-Marc Lasgouttes a écrit :
"Abdelrazak" == Abdelrazak Younes
<[EMAIL PROTECTED]>
writes:
Abdelrazak> Hello Jean-Marc, maybe this is the bottleneck I am looking
Abdelrazak> for. With my patch, undo/redo paragraph insertion is
Abdelrazak> instantaneous and I can
Jean-Marc Lasgouttes a écrit :
"Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> Abdelrazak Younes a écrit :
On Mon, Feb 06, 2006 at 09:59:42AM +0100, Jean-Marc Lasgouttes
wrote:
This is what I was about to suggest: currently, every time a
paragraph is created/killed,
Abdelrazak Younes a écrit :
Martin Vermeer a écrit :
On Thu, Feb 09, 2006 at 12:25:41PM +0100, Abdelrazak Younes wrote:
Abdelrazak Younes a écrit :
...
Again when pasting multiple paragraphs, my debug info tells me that
the multiple insertion are instantaneous but I have to wait maybe 0.5
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> Abdelrazak Younes a écrit :
On Mon, Feb 06, 2006 at 09:59:42AM +0100, Jean-Marc Lasgouttes
wrote:
> This is what I was about to suggest: currently, every time a
> paragraph is created/killed, the whol
On Feb 8, 2006, at 10:03 AM, Martin Vermeer wrote:
-dbg painting gives the output below. To get it, I started LyX,
opened a document containing 3 open notes insets that filled the
screen. The initial set of #[110][110]...#[100][100]... occurred when
I moved the cursor inside the middle inset. I
Martin Vermeer a écrit :
On Thu, Feb 09, 2006 at 12:25:41PM +0100, Abdelrazak Younes wrote:
Abdelrazak Younes a écrit :
...
Again when pasting multiple paragraphs, my debug info tells me that the
multiple insertion are instantaneous but I have to wait maybe 0.5 second
to see them on the scr
Jean-Marc Lasgouttes a écrit :
"Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> Hello Jean-Marc, maybe this is the bottleneck I am looking
Abdelrazak> for. With my patch, undo/redo paragraph insertion is
Abdelrazak> instantaneous and I can see that ParagraphList::insert
Abdelrazak Younes a écrit :
On Mon, Feb 06, 2006 at 09:59:42AM +0100, Jean-Marc Lasgouttes wrote:
This is what I was about to suggest: currently, every time a paragraph
is created/killed, the whole document after it is duplicated. For
images, this means a lot of work. In particular, I think a pi
On Thu, Feb 09, 2006 at 12:25:41PM +0100, Abdelrazak Younes wrote:
> Abdelrazak Younes a écrit :
...
> Again when pasting multiple paragraphs, my debug info tells me that the
> multiple insertion are instantaneous but I have to wait maybe 0.5 second
> to see them on the screen...
>
> Abdel.
R
> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:
Abdelrazak> Hello Jean-Marc, maybe this is the bottleneck I am looking
Abdelrazak> for. With my patch, undo/redo paragraph insertion is
Abdelrazak> instantaneous and I can see that ParagraphList::insert
Abdelrazak> and/or erase ar
Abdelrazak Younes a écrit :
Andre Poenitz a écrit :
On Mon, Feb 06, 2006 at 09:59:42AM +0100, Jean-Marc Lasgouttes wrote:
"Helge" == Helge Hafting
<[EMAIL PROTECTED]> writes:
Helge> I tested the userguide, no problems there. Further testing
Helge> shows that it is related to images. I have som
> "Felix-Antoine" == Felix-Antoine Bourbonnais <[EMAIL PROTECTED]> writes:
Felix-Antoine> In the LyXText class, there is some methods like
Felix-Antoine> cursorLeft, cursorRight, cursorUp, ... that are
Felix-Antoine> returning a boolean which indicates if the text needs
Felix-Antoine> to be up
| I suspect the machine has been hacked (again), but we will not know
| for sure until Lars tells us.
Lars> To my kmowledge, this is not the case.
Good news :)
JMarc
Andre Poenitz a écrit :
On Mon, Feb 06, 2006 at 09:59:42AM +0100, Jean-Marc Lasgouttes wrote:
"Helge" == Helge Hafting <[EMAIL PROTECTED]> writes:
Helge> I tested the userguide, no problems there. Further testing
Helge> shows that it is related to images. I have some high resolution
Helge> imag
Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
| > "christian" == christian ridderstrom <[EMAIL PROTECTED]> writes:
|
| >> I can't even ping it.
|
|
| christian> Is the IP number correct?
|
| I suspect the machine has been hacked (again), but we will not know
| for sure until Lars tell
[EMAIL PROTECTED] writes:
| On Wed, 8 Feb 2006, Jean-Marc Lasgouttes wrote:
|
| > > "Martin" == Martin Vermeer <[EMAIL PROTECTED]> writes:
| >
| > Martin> Anybody else notice that its sshd seems dead? As a result I
| > Martin> cannot use CVS.
| >
| > I can't even ping it.
|
| Me neither:
|
> "christian" == christian ridderstrom <[EMAIL PROTECTED]> writes:
>> I can't even ping it.
christian> Is the IP number correct?
I suspect the machine has been hacked (again), but we will not know
for sure until Lars tells us.
JMarc
Charles de Miramon wrote:
Martin Vermeer wrote:
as be can just embed verbatim macros here. No dirty tricks and lots of
slow, extra files needed. And all this trouble just because
environments can't have arguments in lyx... Oh my dear...
That would be easy to fix...
Would nes
62 matches
Mail list logo