Lars Gullik Bjønnes wrote:
> That would be me... but no. I don't think so. I vaguely remember that
> I had a perfectly good reason for doing this. But not that I can
> remember this now...
If you think you had a good reason I'll leave it as is.
Georg
Andreas Vox wrote:
> If you care about overwriting files you could test for
> existence of $2.
This is not necessary here. Either $2 is in a temp dir, was previously
created by the very same script and needs to be updated. Or it is not in
the temp dir, and the caller of the script checked for its
To add my spicing to this soup, shouldn't we first take inventory of
what bugs we actually have, and how critical they are? There is all
kinds of stuff on bugzilla, and I suspect some of them must be
absolutely fixed while others can be plastered over safely like Andre
suggests... but could "someb
On Mon, 2004-10-25 at 21:55, Josà AbÃlio Oliveira Matos wrote:
> On Mon, Oct 25, 2004 at 05:15:39PM +0300, Martin Vermeer wrote:
> > >
> > > Then probably the first line inside the if should be instead:
> > >
> > > id += " " + bstyle->latexparam();
> >
> > No no... rather, keep it as it is
On Tue, 2004-10-26 at 01:00, Josà AbÃlio Oliveira Matos wrote:
> On Mon, Oct 25, 2004 at 05:15:39PM +0300, Martin Vermeer wrote:
> >
> > I still feel you're making this too complicated :-)
>
> Mais au contraire, mon cher ami. ;-)
>
> [This started as an simple answer and ended as a rant. Y
Angus Leeming <[EMAIL PROTECTED]> writes:
> >> ... I thought it was
> >> about not accidently overwriting some files.
> >
> > Ach! Should I test for that? Hmmm. As it stands the script will overwrite
> > an existing "$2" if 'sed' is used and will not if 'cp' is used. I guess
> > I'll change that
On Mon, Oct 25, 2004 at 09:39:52PM +, Andreas Vox wrote:
>
> You could ask someone with a 64bit box for help! ;-P
That would be nice. :-)
> Sorry, I have my nasty day again, José. At our institute we ordered
> a couple of Athlon64s which should arrive in a few weeks if not
> next year (
On Mon, Oct 25, 2004 at 05:15:39PM +0300, Martin Vermeer wrote:
>
> I still feel you're making this too complicated :-)
Mais au contraire, mon cher ami. ;-)
[This started as an simple answer and ended as a rant. You have been
warned... ;-)]
ids are attributes that are allowed in every ele
Josà AbÃlio Oliveira Matos <[EMAIL PROTECTED]> writes:
>
> On Mon, Oct 25, 2004 at 03:05:38PM +0100, John Levon wrote:
> >
> > It shouldn't ;)
>
> Any idea how to debug this?
You could ask someone with a 64bit box for help! ;-P
Sorry, I have my nasty day again, JosÃ. At our institute we ord
John Levon <[EMAIL PROTECTED]> writes:
> > So this is 'more usable' than a plain crash.
What's wrong with a plain crash ? ;-)
I never lost more than a line of text when LyX
recovered after a crash and that's pretty _impressive_
when compared to Word and its likes!
(Well, ok, Word doesn't crash as
Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> On Mon, Oct 25, 2004 at 12:23:17AM +0200, Andreas Vox wrote:
> > During my tests I found strange <+> ... tokens in the produced
> > MathML code.
> > I tracked this down to math_extern.C, where the normal code is replaced
> > by MathExFuncInsets.
>
On Mon, Oct 25, 2004 at 05:33:17PM +0200, Andre Poenitz wrote:
> > Sure, but how's that going to encourage users to use 1.4.0cvs?
>
> If the result is still usable, it's usable.
The only people we're going to get using a program that brings up a
"everything's screwed message" every 10 minutes ar
Angus Leeming <[EMAIL PROTECTED]> writes:
| Georg Baum wrote:
>
>> While playing with the mover stuff I found out that getExtFromContents()
>> is inconsistent: It returns format names, not extensions for formats that
>> it knows, and it returns file extensions for formats that it does not
>> know.
Georg Baum wrote:
> While playing with the mover stuff I found out that getExtFromContents()
> is inconsistent: It returns format names, not extensions for formats that
> it knows, and it returns file extensions for formats that it does not
> know.
> This does not matter in many cases, because for
While playing with the mover stuff I found out that getExtFromContents()
is inconsistent: It returns format names, not extensions for formats that
it knows, and it returns file extensions for formats that it does not
know.
This does not matter in many cases, because format name == extension for
On Mon, Oct 25, 2004 at 03:05:38PM +0100, John Levon wrote:
>
> It shouldn't ;)
Any idea how to debug this?
> john
--
José Abílio Matos
LyX and docbook a perfect match. :-)
On Mon, Oct 25, 2004 at 05:15:39PM +0300, Martin Vermeer wrote:
> >
> > Then probably the first line inside the if should be instead:
> >
> > id += " " + bstyle->latexparam();
>
> No no... rather, keep it as it is, but shift it to inside the second
> if-statement, i.e., one line down.
O
On Mon, Oct 25, 2004 at 07:37:34AM +0100, John Levon wrote:
> On Sun, Oct 24, 2004 at 12:03:59PM +0200, Andre Poenitz wrote:
>
> > > > That's why I propose changing some/most/all asserts to something less
> > > > brutish, i.e. an exception carrying the same information as the assert
> > > > that w
On Mon, Oct 25, 2004 at 12:23:17AM +0200, Andreas Vox wrote:
> During my tests I found strange <+> ... tokens in the produced
> MathML code.
> I tracked this down to math_extern.C, where the normal code is replaced
> by MathExFuncInsets.
That's funny, this part of math_extern.C should not be in
Bennett Helm <[EMAIL PROTECTED]> writes:
> I'm not sure exactly what's meant by "dead keys".
"Dead keys" are mischevious little things, which when typed just "play dead",
waiting for their time to come, until another key is typed and then
dastardly put some kind of accent on the poor th
On Mon, 2004-10-25 at 16:39, Josà AbÃlio Oliveira Matos wrote:
> On Mon, Oct 25, 2004 at 04:13:23PM +0300, Martin Vermeer wrote:
> >
> > At least this looks correct now... but can't you (referring to before
> > this proposed patch) just place the counters thingy *inside* the second
> > if-statemen
Current CVS is broken by use of QuoteName. The attached patch is a simple
fix that will work in 'many' cases. View it as a stop gap rather than as a
permanent solution.
Committing now...
--
AngusIndex: src/support/ChangeLog
===
RCS
On Mon, Oct 25, 2004 at 01:28:15PM +0100, Jos? Ab?lio Oliveira Matos wrote:
> > Is the Buffer (this) valid?
>
> You are right. The buffer changed between these two calls, even weird.
>
> It shouldn't, right?
It shouldn't ;)
john
On Mon, Oct 25, 2004 at 04:13:23PM +0300, Martin Vermeer wrote:
>
> At least this looks correct now... but can't you (referring to before
> this proposed patch) just place the counters thingy *inside* the second
> if-statement? Again, what do I miss?
>
> Like this
>
> if (!bstyle->latexp
On Oct 25, 2004, at 6:07 AM, Jean-Marc Lasgouttes wrote:
I tried that under lyx/qt and it worked well, but I had to use
\bind "C-~S-grave""buffer-next"
\bind "C-~S-asciitilde" "buffer-previous"
So at least this change is needed.
This has no effect. (Again, I think because the Mac
Current keybindings on the Mac for the new buffer-next and
buffer-previous functions to cycle between buffers don't work: it
appears the Mac is intercepting ` and ~ and using them to
switch between windows (including between dialogs and the main window).
So we'll need other keybindings.
Switch
On Mon, 2004-10-25 at 15:38, Josà AbÃlio Oliveira Matos wrote:
> On Mon, Oct 25, 2004 at 03:25:50PM +0300, Martin Vermeer wrote:
> >
> > Wrong fix I think.
> >
> > What if style->latexparam() is non-empty, but does not contain a '#'?
> >
> > :-)
>
> I think that we need to agree on a common s
Angus Leeming wrote:
>> < > Doesn't resolve symlinks on Mac
>> <
>> < and I repeat: this script is to be used to move .fig files into the
>> temp directory only. The worst case is that the directories are flagged
>> as different and so 'sed' is used rather than 'cp'. Explain to me why
>> that is a
Andreas Vox wrote:
> < > Doesn't resolve symlinks on Mac
> <
> < and I repeat: this script is to be used to move .fig files into the
> temp directory only. The worst case is that the directories are flagged
> as different and so 'sed' is used rather than 'cp'. Explain to me why
> that is a problem
On Mon, Oct 25, 2004 at 03:25:50PM +0300, Martin Vermeer wrote:
>
> Wrong fix I think.
>
> What if style->latexparam() is non-empty, but does not contain a '#'?
>
> :-)
I think that we need to agree on a common syntax for string substitution
and place that on openTag. :-)
Second try, somet
Angus Leeming <[EMAIL PROTECTED]> writes:
< Andreas Vox wrote:
< > Doesn't resolve symlinks on Mac
<
< and I repeat: this script is to be used to move .fig files into the temp
< directory only. The worst case is that the directories are flagged as
< different and so 'sed' is used rather than '
On Mon, Oct 25, 2004 at 01:20:26PM +0100, John Levon wrote:
> On Mon, Oct 25, 2004 at 12:06:33PM +0100, Jos? Ab?lio Oliveira Matos wrote:
>
> >http://bugzilla.lyx.org/attachment.cgi?id=597&action=view
> >
> >What I find strange is the frame #5:
> >
> > #5 0x00456f50 in Buffer
On Mon, 2004-10-25 at 16:20, [EMAIL PROTECTED] wrote:
> CVSROOT: /usr/local/lyx/cvsroot
> Module name: lyx-devel
> Repository: lyx-devel/src/
> Changes by: [EMAIL PROTECTED] 04/10/25 13:20:02
>
> Modified files:
> lyx-devel/src/: ChangeLog output_docbook.C
>
> Log message:
On Mon, Oct 25, 2004 at 12:06:33PM +0100, Jos? Ab?lio Oliveira Matos wrote:
>http://bugzilla.lyx.org/attachment.cgi?id=597&action=view
>
>What I find strange is the frame #5:
>
> #5 0x00456f50 in Buffer::makeDocBookFile (this=0xb38fc0, [EMAIL PROTECTED],
> nice=true, only
Andreas Vox wrote:
> < I think we're getting a little too involved with generics here, given
> that < this script is to be used to move .fig files into the temp
> directory only. < I think that the test below should do the job and
> should be portable. <
> < PRESENT_DIR=$PWD
> <
> < cd `dirname "$1
Angus Leeming <[EMAIL PROTECTED]> writes:
< I think we're getting a little too involved with generics here, given that
< this script is to be used to move .fig files into the temp directory only.
< I think that the test below should do the job and should be portable.
<
< PRESENT_DIR=$PWD
<
< cd
Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
| http://bugzilla.lyx.org/show_bug.cgi?id=1702
>
| Lars, could you review the patch enclosed in this bug? Is it needed in
| 1.4.0cvs too?
I cannot find this code in boost 1.31. at all.
this must be 1.3.x only.
--
Lgb
On Mon, Oct 25, 2004 at 01:47:09PM +0300, Martin Vermeer wrote:
> >
> > Nothing, I think. I have reordered the code and, probably, before this
> > code chuncks were in different places.
> > As you clearly show this should be merged. Do you want me to do it?
>
> Yes, please.
Done, thanks.
Hi,
I am lost. :-)
The bug is:
http://bugzilla.lyx.org/show_bug.cgi?id=1687
In short, a user running a 64 bit plataform and lyx-1.3.4 has problems
exporting any docbook document in any format.
LyX always crashes, and the bug report is here:
http://bugzilla.lyx.org/attachm
> "Uwe" == Uwe Wolfram <[EMAIL PROTECTED]> writes:
Uwe> Whereas I am able to compile and link lyx 1.3.5 on Solaris 8
Uwe> using gcc 3.3.4, the final link step fails doing a build with gcc
Uwe> 3.4.2. Since I'm able to build qt using gcc 3.4.2 it's not a
Uwe> compiler issue.
Can you try the pa
On Mon, 2004-10-25 at 13:28, Josà AbÃlio Oliveira Matos wrote:
> On Mon, Oct 25, 2004 at 01:05:22PM +0300, Martin Vermeer wrote:
> > ma, 2004-10-25 kello 03:35, Josà AbÃlio Oliveira Matos kirjoitti:
> >
> > > Martin the code now should be a lot easier to read, I tried to maintain
> > > all the p
http://bugzilla.lyx.org/show_bug.cgi?id=1702
Lars, could you review the patch enclosed in this bug? Is it needed in
1.4.0cvs too?
JMarc
On Mon, Oct 25, 2004 at 11:32:36AM +0100, Angus Leeming wrote:
>
> The statement below is grammatically correct and a little less
> mind-twisty...
>
> If you have questions about the organization of this directory,
> or would like to suggest additions to it, please contact the
> LyX developers' m
On Mon, Oct 25, 2004 at 12:22:47PM +0200, Jean-Marc Lasgouttes wrote:
> > "José" == José Abílio Oliveira Matos <[EMAIL PROTECTED]> writes:
>
> José> Hello, here is what I propose for ftp.lyx.org/pub/lyx
>
> José> devel
>
> José> remove it completly, all the files there are outdated a
Jean-Marc Lasgouttes wrote:
> José> For questions regarding the organization, or suggestions
> José> regarding additions, for this directory please contact the LyX
> José> developpers mailing list.
>
> With an e-mail address, I guess...
The statement below is grammatically correct and a little le
On Mon, Oct 25, 2004 at 01:05:22PM +0300, Martin Vermeer wrote:
> ma, 2004-10-25 kello 03:35, José Abílio Oliveira Matos kirjoitti:
>
> > Martin the code now should be a lot easier to read, I tried to maintain
> > all the previous features for AGU. I think also that we should set some kind
> > o
> "José" == José Abílio Oliveira Matos <[EMAIL PROTECTED]> writes:
José> Hello, here is what I propose for ftp.lyx.org/pub/lyx
José> devel
José> remove it completly, all the files there are outdated and
José> serve no meaningful purpose. ;-)
Since everything is in cvs, I guess only the ol
ma, 2004-10-25 kello 03:35, Josà AbÃlio Oliveira Matos kirjoitti:
> On Sun, Oct 24, 2004 at 01:14:56AM +0100, Josà AbÃlio Oliveira Matos wrote:
> >
> > I hope that Martin and Andreas find the code easier to understand now.
...
> Martin the code now should be a lot easier to read, I tried to
> "Bennett" == Bennett Helm <[EMAIL PROTECTED]> writes:
Bennett> The new functions work fine for me on Mac OS X, but the
Bennett> keybindings don't.
This is bug 1639.
Bennett> Currently, mac.bind has:
Bennett> \bind "C-grave" "buffer-next"
Bennett> \bind "C-asciitilde" "buffer-previous"
On Mon, 2004-10-25 at 11:34 +0200, Lars Gullik Bjønnes wrote:
> Can the default unit change?
>
> If not make it const.
Yes, it gets set later depending on paper size.
> Hmm...
>
> vector data(unit_name, unit_name + num_units);
>
> should work and is a bit more elegant (and faster.)
Alri
Stephan Witt wrote:
> Andreas Vox wrote:
>> Angus Leeming <[EMAIL PROTECTED]> writes:
>>
>>
what about [ `dirname "$1"` -ef `dirname "$2"` ] ?
>>>
>>>"test -e FOO" is a bash extension.
>>>Also, "dirname" does nothing more than strip everything after the final
>>>'/' character. "/foo/bar/../b
John Spray <[EMAIL PROTECTED]> writes:
| +namespace frontend {
| +
| +namespace {
| +string defaultUnit("cm");
| +} // namespace anon
Can the default unit change?
If not make it const.
| + }
| + //Fallen through, we didn't find the target length!
Space after '//'
| +vector const build
Andreas Vox wrote:
Angus Leeming <[EMAIL PROTECTED]> writes:
what about [ `dirname "$1"` -ef `dirname "$2"` ] ?
"test -e FOO" is a bash extension.
Also, "dirname" does nothing more than strip everything after the final '/'
character. "/foo/bar/../baz.cpp" and "/foo/baz.cpp" will appear to be in
di
Angus Leeming <[EMAIL PROTECTED]> writes:
> > what about [ `dirname "$1"` -ef `dirname "$2"` ] ?
>
> "test -e FOO" is a bash extension.
> Also, "dirname" does nothing more than strip everything after the final '/'
> character. "/foo/bar/../baz.cpp" and "/foo/baz.cpp" will appear to be in
> differ
Angus Leeming wrote:
> The real problem being that the regex is insufficient for the use case?
>
> Looking at the code, there are three separate tests:
> 1 "[,,,foo..." -> "[foo..."
> 2 "foo,,,bar" -> "foo,bar"
> 3 "...foo,,,]" -> ""...foo]"
> it seems that your case should be
> "Kayvan" == Kayvan A Sylvan <[EMAIL PROTECTED]> writes:
Kayvan> Inserting a non-breaking space puts the cursor *before* the
Kayvan> non-breaking space inset.
The following patch cures the problem and also a couple of other cases
(special characters, list of floats). I'll apply it shortly.
Alfredo Braunstein wrote:
>> Incidentaly, is there a more elegant (shell script) way to ascertain
>> whether two directories are the same than:
>>
>> # If the "to" and the "from" files are in the same directory,
>> # then we're done.
>> PRESENT_DIR=`pwd`
>> cd `dirname "$1"`
>> FROM_DIR=`pwd`
>>
Also sprach Jean-Marc Lasgouttes:
> I like it, except that intitle should be initialized when it is
> declared. I guess the compiler warns about it.
Yes, my fault. I have now initialized it (to "false"). Just committing.
> Feel free to apply it, as far as 1.3.x is concerned. I would say that
> it
> "Juergen" == Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
Juergen> Jean-Marc Lasgouttes wrote:
>> FWIW, I agree that Juergen's patch is the way to go. Actually, if
>> we had a scripting language in layout files, or if we used css for
>> them, we could encode this directly in the layout.
Jean-Marc Lasgouttes wrote:
> FWIW, I agree that Juergen's patch is the way to go. Actually, if we
> had a scripting language in layout files, or if we used css for them,
> we could encode this directly in the layout.
BTW, I also have a patch for 1.3.x (attached). Slightly different approach,
but
Georg Baum wrote:
> Angus,
>
> while playing with your mover stuff I got the warning
>
> Unable to sanitize LaTeX "Option": ]
>
> from the external inset. sanitizeLatexOption() was called with the input
> "[,,,]". The last regex was then called with "]", and this lead to the
> warning message.
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> On Mon, Oct 18, 2004 at 02:15:21PM +0200, Jean-Marc Lasgouttes
Andre> wrote:
>> What do kword or abiword do? I did not find anything relevant in
>> the Gnome or KDE HIG. I guess windows apps use C-Tab, but mathed
>> already uses tha
> "Bennett" == Bennett Helm <[EMAIL PROTECTED]> writes:
Bennett> LyX 1.4.0cvs does not automatically install the mac.bind
Bennett> file. I believe this is because lib/Makefile.am needs to add
Bennett> mac.bind to the dist_bind_DATA. Is this right?
Bennett> The attached patch will make this ch
Georg Baum wrote:
> Am Freitag, 22. Oktober 2004 22:59 schrieb Angus Leeming:
>> I won't apply this until I've finished the stuff above, but it now works
>> as-is. Perhaps someone else would like to test it out?
>
> I did, and I could not break it, but I found another reason to use this
> mover st
Alfredo Braunstein wrote:
> Andreas Vox wrote:
>
>> Alfredo Braunstein <[EMAIL PROTECTED]> writes:
>>
>>> what about [ `dirname "$1"` -ef `dirname "$2"` ] ?
>>>
>>> No idea about portability and such.
>>
>> Works on MacOSX (bash).
>
> forgot to mention, bash too ;-)
>
>> Apparently the defa
On Sun, Oct 24, 2004 at 09:18:58PM -0700, Kayvan A. Sylvan wrote:
> On Linux, xforms frontend:
>
> if g++ -DHAVE_CONFIG_H -I. -I. -I. -I../boost -I/usr/X11R6/include -O2 -fno-ex
> ceptions -W -Wall -MT sgml.o -MD -MP -MF ".deps/sgml.Tpo" \
> -c -o sgml.o `test -f 'sgml.C' || echo './'`sgml.C;
> "Juergen" == Juergen Spitzmueller <[EMAIL PROTECTED]> writes:
Juergen> Andre Poenitz wrote:
>> I am not sure. Having two insets (or at least a parameter 'thanks'
>> or 'footnote' to the existing footnote inset makes mark up more
>> 'high level'. In fact, I think your patch is the LaTeX centr
67 matches
Mail list logo