This revision was automatically updated to reflect the committed changes.
Closed by commit rG0107513fe79d: [lldb] Implement CrashReason using UnixSignals
(authored by DavidSpickett).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146044/new/
https://
DavidSpickett added inline comments.
Comment at: lldb/include/lldb/Target/UnixSignals.h:127
+ struct SignalCode {
+ConstString m_description;
+SignalCodePrintOption m_print_option;
DavidSpickett wrote:
> labath wrote:
> > I think we should just make stri
DavidSpickett updated this revision to Diff 506022.
DavidSpickett added a comment.
Rebase
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146044/new/
https://reviews.llvm.org/D146044
Files:
lldb/include/lldb/Target/UnixSignals.h
lldb/source/Plug
DavidSpickett marked 2 inline comments as done.
DavidSpickett added inline comments.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:14
FreeBSDSignals::FreeBSDSignals() : UnixSignals() { Reset(); }
void FreeBSDSignals::Reset() {
DavidSpicke
DavidSpickett marked an inline comment as done.
DavidSpickett added inline comments.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:14
FreeBSDSignals::FreeBSDSignals() : UnixSignals() { Reset(); }
void FreeBSDSignals::Reset() {
arichardson
arichardson added a comment.
Minor suggestions, feel free to ignore.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:14
FreeBSDSignals::FreeBSDSignals() : UnixSignals() { Reset(); }
void FreeBSDSignals::Reset() {
I wonder if it would make
DavidSpickett updated this revision to Diff 505413.
DavidSpickett added a comment.
Use ASSERT_EQ, change name of new function.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146044/new/
https://reviews.llvm.org/D146044
Files:
lldb/include/lldb/Ta
DavidSpickett marked an inline comment as done.
DavidSpickett added inline comments.
Comment at: lldb/include/lldb/Target/UnixSignals.h:127
+ struct SignalCode {
+ConstString m_description;
+SignalCodePrintOption m_print_option;
labath wrote:
> I think w
JDevlieghere accepted this revision.
JDevlieghere added a comment.
This revision is now accepted and ready to land.
LGTM with Pavel's comments.
Comment at: lldb/unittests/Signals/UnixSignalsTest.cpp:132-134
+ EXPECT_EQ(expected, signals.GetSignalAsString(16, 3));
+ EXPECT_EQ(
labath added a comment.
It's not exactly what I had in mind, but I kinda like it :)
Comment at: lldb/include/lldb/Target/UnixSignals.h:127
+ struct SignalCode {
+ConstString m_description;
+SignalCodePrintOption m_print_option;
I think we should just m
emaste added a comment.
FreeBSD LGTM
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146044/new/
https://reviews.llvm.org/D146044
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llv
DavidSpickett marked an inline comment as done.
DavidSpickett added inline comments.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:20
+ // SIGILL
+ AddSignalCode(4, 1 /*ILL_ILLOPC*/, "illegal instruction");
+ AddSignalCode(4, 2 /*ILL_ILLOPN*/, "illegal ins
DavidSpickett updated this revision to Diff 505090.
DavidSpickett added a comment.
Update the descriptions to match the platform's.
Add a couple of FreeBSD signals I missed the first time.
We're missing a bunch of Linux ones too but since that file
already existed, I don't want to make the diff
DavidSpickett updated this revision to Diff 505082.
DavidSpickett added a comment.
Corect FreeBSD SIGFPE integer overflow/divide by zero order.
FreeBSD is overflow then divide by zero.
NetBSD is divide by zero then overflow.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
htt
emaste added inline comments.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:20
+ // SIGILL
+ AddSignalCode(4, 1 /*ILL_ILLOPC*/, "illegal instruction");
+ AddSignalCode(4, 2 /*ILL_ILLOPN*/, "illegal instruction operand");
FreeBSD comment us
DavidSpickett added inline comments.
Comment at: lldb/source/Plugins/Process/Utility/FreeBSDSignals.cpp:38
+ AddSignalCode(8, 8 /*FPE_FLTSUB*/, "invalid floating point subscript range");
+ AddSignalCode(8, 9 /*FPE_FLTIDO*/, "input denormal operation");
+
This o
DavidSpickett added a subscriber: mgorny.
DavidSpickett added a comment.
@emaste , @mgorny maybe you want to glance at the numbers for the BSDs. I got
the codes from the FreeBSD/NetBSD sources, and the signal numbers are as
before, using the Darwin numbers.
Repository:
rG LLVM Github Monorep
DavidSpickett created this revision.
Herald added subscribers: krytarowski, arichardson, emaste.
Herald added a project: All.
DavidSpickett requested review of this revision.
Herald added a project: LLDB.
Herald added a subscriber: lldb-commits.
By adding signal codes to UnixSignals and adding a n
18 matches
Mail list logo