On MPC52xx the PCI target control register (PCITCR) @ MBAR + 0xD6C is
initialized with
only bit 7 (Latrule disable) set. The 8-Bit write combine timer (Bits 24..31)
should be
also set to a reasonable value _greater zero_ (0x08 = default) since setting it
to 0x00
leads to _very poor_ performance
Hi Sean,
On Tue, 8 Jul 2008 14:46:09 -0400, Sean MacLennan wrote:
> This patch completes the conversion of the IBM IIC driver to an
> of-platform driver.
>
> It removes the index from the IBM IIC driver and makes it an unnumbered
> driver. It then calls of_register_i2c_devices to properly registe
Hello,
today, I was debugging a kernel crash on a board with a MPC5200B using
2.6.26-rc9. I found the following code in drivers/net/fec_mpc52xx.c:
static irqreturn_t mpc52xx_fec_interrupt(int irq, void *dev_id)
{
[...]
/* on fifo error, soft-reset fec */
if (ievent & (FEC_IEVENT_R
On Jul 9, 2008, at 8:52 PM, David Gibson wrote:
On Tue, Jul 08, 2008 at 08:20:56AM -0500, Kumar Gala wrote:
Moved Freescale SoC related bindings out of booting-without-of.txt
and into
their own files.
Signed-off-by: Kumar Gala <[EMAIL PROTECTED]>
Acked-by: David Gibson <[EMAIL PROTECTED]>
On Jul 9, 2008, at 12:13 PM, Stephen Rothwell wrote:
Hi Kumar,
On Wed, 9 Jul 2008 08:13:03 -0500 (CDT) Kumar Gala <[EMAIL PROTECTED]
> wrote:
Please pull from 'powerpc-next' branch of
master.kernel.org:/pub/scm/linux/kernel/git/galak/dts.git powerpc-
next
$ git ls-remote ssh://master.k
Acked by: Brian King <[EMAIL PROTECTED]>
--
Brian King
Linux on Power Virtualization
IBM Linux Technology Center
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
On Thursday 10 July 2008, Chris Friesen wrote:
> Just wondering if anyone has looked at what it would take to support
> latency top on powerpc?
Just guessing something like the patch below, not more that that, but
without the bugs ;-). Haven't tested at all, so it will probably
fall apart, but gi
Implement save_stack_trace_tsk on powerpc, so that we can run with
latencytop.
Signed-off-by: Arnd Bergmann <[EMAIL PROTECTED]>
---
On Thursday 10 July 2008, Arnd Bergmann wrote:
> Just guessing something like the patch below, not more that that, but
> without the bugs ;-).
Obvious bug #1: needs
Welch, Martyn (GE EntSol, Intelligent Platforms) 写道:
Wang Jian wrote:
It may not be appropriate to post here instead of netdev, but I am
using
powerpc dev board and I think there will be someone here who has board
to test.
Wang Jian 写道:
These 2 patches fixed misuse of register for 88e.
On Wednesday 09 July 2008, Benjamin Herrenschmidt wrote:
> On Wed, 2008-07-09 at 15:15 +0200, Arnd Bergmann wrote:
> > Ugly, but doable, yes. I wonder if there is a way that we can trigger some
> > interrupt from system_reset_exception context in order to get around the
> > polling though. tasklets
Hi,
On Tue, 8 Jul 2008, Sam Ravnborg wrote:
> We use Kconfig for a mixture of user editable values and fixed
> configuration values.
> And I agree that asking the user to input a 64 bit number is not usefull.
>
> But keeping support for 64 bit values is what I would consider
> expected functiona
On Thu, Jul 10, 2008 at 11:53:16AM +0200, Andre Schwarz wrote:
> On MPC52xx the PCI target control register (PCITCR) @ MBAR + 0xD6C is
> initialized with
> only bit 7 (Latrule disable) set. The 8-Bit write combine timer (Bits 24..31)
> should be
> also set to a reasonable value _greater zero_ (0x
Hi,
On Thu, 10 Jul 2008, Michael Ellerman wrote:
> Well yes :) But I think that's because you're thinking of
> "end-users" and I'm thinking of "users" like myself - ie. _I_ use
> Kconfig and I do expect myself to be able to type a 64-bit address.
That doesn't really answer my question, why you
On Thu, Jul 10, 2008 at 02:39:09PM +0200, Wolfram Sang wrote:
> Hello,
>
> today, I was debugging a kernel crash on a board with a MPC5200B using
> 2.6.26-rc9. I found the following code in drivers/net/fec_mpc52xx.c:
> I assume the proper thing to do is to set a flag in the ISR and handle
> the s
On Jul 9, 2008, at 7:44 PM, Josh Boyer wrote:
On Thu, 10 Jul 2008 06:39:39 +1000
Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
On Wed, 2008-07-09 at 16:22 -0400, Josh Boyer wrote:
On Thu, 10 Jul 2008 06:02:38 +1000
Benjamin Herrenschmidt <[EMAIL PROTECTED]> wrote:
On Wed, 2008-07-09 at
Review comments were incorporated to improve the driver.
1. Some data was eliminated that was not needed.
2. Renaming of variables for clarity.
3. Removed unneeded type casting.
4. Changed to use dev_err rather than other I/O.
5. Merged together some functions.
6. Added kerneldoc format to functio
On Jul 9, 2008, at 1:22 PM, Grant Likely wrote:
On Mon, Jun 30, 2008 at 5:01 PM, Jon Smirl <[EMAIL PROTECTED]> wrote:
Convert i2c-mpc to an of_platform driver. Utilize the code in
drivers/of-i2c.c to make i2c modules dynamically loadable by the
device tree.
Timur, can you please test this
Hi all,
I am trying to optimize the __copy_tofrom_user function for PPC4xx,
and I would want to know why the exception handling code has been made
so complicated. All the fixup code should do is to store the number of
bytes that failed in copy in r3 and return back.
The current code tries to copy
On Tue, Jul 08, 2008 at 11:27:28AM -0400, Dave Jones wrote:
> On Tue, Jul 08, 2008 at 08:43:43AM +0200, Arnd Bergmann wrote:
> > On Monday 07 July 2008, Dave Jones wrote:
> > > One question I do have though, is how userspace scripts are supposed
> > > to know they're to echo cbe_spu_governor int
> "John" == John Linn <[EMAIL PROTECTED]> writes:
> Review comments were incorporated to improve the driver.
> 1. Some data was eliminated that was not needed.
> 2. Renaming of variables for clarity.
> 3. Removed unneeded type casting.
> 4. Changed to use dev_err rather than other I/O.
>
Hi,
On Monday 07 July 2008, Stephen Rothwell wrote:
> Hi all,
>
> Today's linux-next merge of the powerpc tree got a conflict in
> drivers/macintosh/mediabay.c between commit
> 7ad963b103d3863b1161c59f3e65a435979804ed ("ide-pmac: media-bay support
> fixes (take 4)") from the ide tree and commit
Review comments were incorporated to improve the driver.
1. Some data was eliminated that was not needed.
2. Renaming of variables for clarity.
3. Removed unneeded type casting.
4. Changed to use dev_err rather than other I/O.
5. Merged together some functions.
6. Added kerneldoc format to functio
The mpc7448hpc2 board doesn't have an alias block like
most of the other modern eval boards have. We need this
block in order to have u-boot be able to make use of the
CONFIG_OF_STDOUT_VIA_ALIAS (vs. having a hard coded node)
in the future.
Also remove the old, redundant chosen node. Of all the
Paul Gortmaker wrote:
The mpc7448hpc2 board doesn't have an alias block like
most of the other modern eval boards have. We need this
block in order to have u-boot be able to make use of the
CONFIG_OF_STDOUT_VIA_ALIAS (vs. having a hard coded node)
in the future.
Also remove the old, redundant c
Scott Wood wrote:
Paul Gortmaker wrote:
The mpc7448hpc2 board doesn't have an alias block like
most of the other modern eval boards have. We need this
block in order to have u-boot be able to make use of the
CONFIG_OF_STDOUT_VIA_ALIAS (vs. having a hard coded node)
in the future.
Also remove t
Paul Gortmaker wrote:
OK, so does that mean that the cuboot wrapper is explicitly
not supported for all the 83xx, 85xx, and 86xx boards?
No (except 86xx, which doesn't have cuboot, because it never existed in
arch/ppc and thus there's no compatibility to maintain), it just means
that chosen w
On Thursday 10 July 2008, Dominik Brodowski wrote:
> Actually, "cpufreq-set -g spu_governor" should be enough. (BTW, do we really
> want this name?)
Do you have a better suggestion for the name? I don't think there was a
particularly strong reason to choose it over something else.
Arnd <>
Scott Wood wrote:
Paul Gortmaker wrote:
OK, so does that mean that the cuboot wrapper is explicitly
not supported for all the 83xx, 85xx, and 86xx boards?
No (except 86xx, which doesn't have cuboot, because it never existed in
arch/ppc and thus there's no compatibility to maintain), it just m
Jon Loeliger wrote:
Scott Wood wrote:
Paul Gortmaker wrote:
OK, so does that mean that the cuboot wrapper is explicitly
not supported for all the 83xx, 85xx, and 86xx boards?
No (except 86xx, which doesn't have cuboot, because it never existed
in arch/ppc and thus there's no compatibility to
After the following patch to mark the isa region busy and applying a few
patches[1], I was able to kexec boot into an all-yes-config kernel from
linux-next, with the following KCONFIG_ALLCONFIG file:
# CONFIG_KALLSYMS_EXTRA_PASS is not set
# CONFIG_CRASH_DUMP is not set
CONFIG_PPC_EARLY_DEBUG_RTA
find the address in the device tree.
Signed-off-by: Milton Miller <[EMAIL PROTECTED]>
---
There is no powerpc defconfig that sets either CONFIG_DOC200{0,1*} nor
CONFIG_MTD_NAND_DISKONCHIP in next-20080710.
diff --git a/drivers/mtd/devices/docprobe.c b/drivers/mtd/devices/docprobe.c
index 6
This is the first step to moving the interrupt vectors to .text.head.
Rather than creating more repetition, factor out creating a function
descriptor, from declaring it to be global in a section.
The order of .globl and the symbol definitions is changed but is
a don't care.
Signed-off-by: Milton
On Thu, Jul 10, 2008 at 11:05:08PM +0200, Arnd Bergmann wrote:
> On Thursday 10 July 2008, Dominik Brodowski wrote:
> > Actually, "cpufreq-set -g spu_governor" should be enough. (BTW, do we really
> > want this name?)
>
> Do you have a better suggestion for the name? I don't think there was a
> pa
We rely on careful placement of the start of the kernel, and use org from
the start of our image to line up the exception handlers.
When building a large kernel, the linker will insert stubs to call from one
toc to the next, breaking our careful placement. In addition, kexec does
not (currently)
numa_enforce_memory_limit trys to be smart and only trim the memory it
finds to lmb_end_of_DRAM when a memory limit is set. However, the
early boot code may also limit memory when iommu=off is specified. When
this happens, the page allocator is told of pages not in the linear mapping
and gets a
Replace a left over % 2 to be a check for the primary thread and
update the comments.
Note: We assume the secondary threads are not spinning, but they are
actually spinning if we start via kexec. This means that we call rtas to
spin up the secondary threads. If we get a bad return code from we sk
Because we copy the image using the kernels virtual memory system, we
require kexec user space to avoid overwriting the static kernel image, tce
tables, and the hash table. Kexec userspace gets this information by
reading propertys the kernel adds, but does not filter these propertys when
starting
These functions should have been static, and inspection shows they
are no longer used. (We used to parse mem= but we now defer that
to early_param).
Signed-off-by: Milton Miller <[EMAIL PROTECTED]>
---
Should we just remove them instead?
diff --git a/arch/powerpc/kernel/prom_init.c b/arch/power
kcalloc is supposed to be called with the count as its first argument and
the element size as the second.
Signed-off-by: Milton Miller <[EMAIL PROTECTED]>
---
Both arguments are size_t so does not affect correctness. This callsite is
during module_init and therefore not performance critical. Ano
Scott Wood wrote:
Jon Loeliger wrote:
Scott Wood wrote:
Paul Gortmaker wrote:
OK, so does that mean that the cuboot wrapper is explicitly
not supported for all the 83xx, 85xx, and 86xx boards?
No (except 86xx, which doesn't have cuboot, because it never existed
in arch/ppc and thus there's
Hi Rusty, Ingo.
Rusty's patch [PATCH 3/3] stop_machine: use cpu mask rather than magic numbers
didn't find kernel/trace/ftrace.c in -next, causing an immediate almost NULL
pointer dereference in ftrace_dynamic_init.
Signed-off-by: Milton Miller <[EMAIL PROTECTED]>
diff --git a/kernel/trace/ft
Paul Gortmaker wrote:
Well, for the mpc7448hpc2, I can say for sure that there are
chosen-duplicating versions of u-boot 1.3.1 in use -- since
there wasn't a prebuilt, validated image newer than 1.1.3(?)
available anywhere back some 6 months ago, I'd built 1.3.1
and made it available with our 2.6
On Jul 10, 2008, at 4:33 PM, Hans de Goede wrote:
Milton Miller wrote:
After the following patch to mark the isa region busy and applying a
few
patches[1], I was able to kexec boot into an all-yes-config kernel
from linux-next, with the following KCONFIG_ALLCONFIG file:
...
While the first
Scott Wood wrote:
Paul Gortmaker wrote:
Well, for the mpc7448hpc2, I can say for sure that there are
chosen-duplicating versions of u-boot 1.3.1 in use -- since
there wasn't a prebuilt, validated image newer than 1.1.3(?)
available anywhere back some 6 months ago, I'd built 1.3.1
and made it ava
Hello Chandru,
static int __init early_init_dt_scan_drconf_memory(unsigned long node)
{
- cell_t *dm, *ls;
+ cell_t *dm, *ls, *endp, *usm;
unsigned long l, n, flags;
u64 base, size, lmb_size;
+ char buf[32], t[8];
ls = (cell_t *)of_get_flat_dt_prop(node, "
Milton,
> kcalloc is supposed to be called with the count as its first argument
> and the element size as the second.
Thanks, applied.
Cheers,
Jeremy
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-d
Hi all,
I am trying to optimize the __copy_tofrom_user function for PPC4xx,
and I would want to know why the exception handling code has been made
so complicated. All the fixup code should do is to store the number of
bytes that failed in copy in r3 and return back.
The current code tries to copy
On Thu, Jul 10, 2008 at 08:22:53AM -0500, Kumar Gala wrote:
>
> On Jul 9, 2008, at 8:52 PM, David Gibson wrote:
>
>> On Tue, Jul 08, 2008 at 08:20:56AM -0500, Kumar Gala wrote:
>>> Moved Freescale SoC related bindings out of booting-without-of.txt
>>> and into
>>> their own files.
>>>
>>> Signed-
On Fri, 2008-07-11 at 04:21 +0800, Paul Gortmaker wrote:
> The mpc7448hpc2 board doesn't have an alias block like
> most of the other modern eval boards have. We need this
> block in order to have u-boot be able to make use of the
> CONFIG_OF_STDOUT_VIA_ALIAS (vs. having a hard coded node)
> i
Milton Miller wrote:
After the following patch to mark the isa region busy and applying a few
patches[1], I was able to kexec boot into an all-yes-config kernel from
linux-next, with the following KCONFIG_ALLCONFIG file:
# CONFIG_KALLSYMS_EXTRA_PASS is not set
# CONFIG_CRASH_DUMP is not set
CO
Benjamin Herrenschmidt wrote:
On Tue, 2008-07-08 at 08:03 -0700, Grant Erickson wrote:
This patch adds support to the RGMII handler in the EMAC driver for
the MII PHY mode such that device tree entries of the form `phy-mode = "mii";'
are recognized and handled appropriately.
While logically, in
giveup_vsx didn't save the FPU and VMX regsiters. Change it to be
like giveup_fpr/altivec which save these registers.
Also update call sites where FPU and VMX are already saved to use the
original giveup_vsx (renamed to __giveup_vsx).
Signed-off-by: Michael Neuling <[EMAIL PROTECTED]>
---
benh:
VSX loads and stores will take an alignment exception when the address
is not on a 4 byte boundary.
This add support for these alignment exceptions and will emulate the
requested load or store.
Signed-off-by: Michael Neuling <[EMAIL PROTECTED]>
---
benh: for your 2.6.27 tree
arch/powerpc/ke
> "John" == John Linn <[EMAIL PROTECTED]> writes:
John> Review comments were incorporated to improve the driver.
John> 1. Some data was eliminated that was not needed.
John> 2. Renaming of variables for clarity.
John> 3. Removed unneeded type casting.
John> 4. Changed to use dev_err rathe
On Friday 11 July 2008 07:07:57 Milton Miller wrote:
> Hi Rusty, Ingo.
>
> Rusty's patch [PATCH 3/3] stop_machine: use cpu mask rather than magic
> numbers didn't find kernel/trace/ftrace.c in -next, causing an immediate
> almost NULL pointer dereference in ftrace_dynamic_init.
Yes, I'm switching
In message <[EMAIL PROTECTED]> you wro
te:
> Hi all,
> I am trying to optimize the __copy_tofrom_user function for PPC4xx,
> and I would want to know why the exception handling code has been made
> so complicated. All the fixup code should do is to store the number of
> bytes that failed in copy in
Hi Hans, hi Milton,
On Thu, 10 Jul 2008 16:51:33 -0500, Milton Miller wrote:
>
> On Jul 10, 2008, at 4:33 PM, Hans de Goede wrote:
>
> > Milton Miller wrote:
> >> After the following patch to mark the isa region busy and applying a
> >> few
> >> patches[1], I was able to kexec boot into an all-
57 matches
Mail list logo