[PATCH 2/2] powerpc: make 64K huge pages more reliable

2007-11-27 Thread Jon Tollefson
This patch adds reliability to the 64K huge page option by making use of the PMD for 64K huge pages when base pages are 4k. So instead of a 12 bit pte it would be 7 bit pmd and a 5 bit pte. The pgd and pud offsets would continue as 9 bits and 7 bits respectively. This will allow the pgtable t

[PATCH 1/2] powerpc: add hugepagesz boot-time parameter

2007-11-27 Thread Jon Tollefson
This patch adds the hugepagesz boot-time parameter for ppc64 that lets you pick the size for your huge pages. The choices available are 64K and 16M. It defaults to 16M (previously the only choice) if nothing or an invalid choice is specified. Tested 64K huge pages with the libhugetlbfs 1.2 r

of_compat_cmp on various platforms

2007-11-27 Thread Jon Smirl
Is this right or should it be the same everywhere? asm-powerpc/prom.h:#define of_compat_cmp(s1, s2, l) strcasecmp((s1), (s2)) asm-sparc/prom.h:#define of_compat_cmp(s1, s2, l) strncmp((s1), (s2), (l)) asm-sparc64/prom.h:#define of_compat_cmp(s1, s2, l) strncmp((s1), (s2), (l)) -- J

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-27 Thread Stephen Rothwell
On Tue, 27 Nov 2007 18:39:08 +0300 Anton Vorontsov <[EMAIL PROTECTED]> wrote: > > +static int __devinit pata_of_platform_probe(struct of_device *ofdev, > + const struct of_device_id *match) > +{ > + uint32_t *prop; Make this "const uint32_t *prop" or (mo

Re: [PATCH] powerpc: fix os-term usage on kernel panic

2007-11-27 Thread Will Schmidt
(resending with the proper "from" addr this time). I'm seeing some funky behavior on power5/power6 partitions with this patch.A "/sbin/reboot" is now behaving much more like a "/sbin/halt". Anybody else seeing this, or is it time for me to call an exorcist for my boxes? -Will On Mon, 200

[PATCH] [POWERPC] kernel_execve is identical in 32 and 64 bit

2007-11-27 Thread Stephen Rothwell
so concolidate it into misc.S. Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]> --- arch/powerpc/kernel/misc.S|8 arch/powerpc/kernel/misc_32.S |7 --- arch/powerpc/kernel/misc_64.S |7 --- 3 files changed, 8 insertions(+), 14 deletions(-) -- Cheers, Stephen

Re: [PATCH] sys_indirect kernel implementation for PowerPC

2007-11-27 Thread Arnd Bergmann
On Wednesday 21 November 2007, Stephen Rothwell wrote: > > +++ b/include/asm-powerpc/systbl.h > > @@ -313,3 +313,4 @@ COMPAT_SYS_SPU(timerfd) > >  SYSCALL_SPU(eventfd) > >  COMPAT_SYS_SPU(sync_file_range2) > >  COMPAT_SYS(fallocate) > > +COMPAT_SYS(indirect) > > Do the SPUs want this? Excellent q

Re: PPC upstream kernel ignored DABR bug

2007-11-27 Thread Arnd Bergmann
On Monday 26 November 2007, Jan Kratochvil wrote: > Hi, > > this testcase: > http://people.redhat.com/jkratoch/dabr-lost.c > > reproduces a PPC DABR kernel bug.  The variable `variable' should not get > modified as the thread modifying it should be caught by its DABR: > > $ ./dabr-lost >

Re: [PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2007-11-27 Thread Arnd Bergmann
On Tuesday 27 November 2007, Anton Vorontsov wrote: > Split pata_platform_{probe,remove} into two pieces: > 1. pata_platform_{probe,remove} -- platform_device-dependant bits; > 2. __ptata_platform_{probe,remove} -- device type neutral bits. > > This is done to not duplicate code for the OF-platfor

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-27 Thread Arnd Bergmann
On Tuesday 27 November 2007, Olof Johansson wrote: > On Tue, Nov 27, 2007 at 06:39:08PM +0300, Anton Vorontsov wrote: > > This driver nicely wraps around pata_platform library functions, > > and provides OF platform bus bindings to the PATA devices. > > > +static struct of_device_id pata_of_platfo

Re: [PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-27 Thread Olof Johansson
On Tue, Nov 27, 2007 at 06:39:08PM +0300, Anton Vorontsov wrote: > This driver nicely wraps around pata_platform library functions, > and provides OF platform bus bindings to the PATA devices. > +static struct of_device_id pata_of_platform_match[] = { > + { .compatible = "pata-platform", }, >

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Kumar Gala
On Nov 27, 2007, at 9:49 AM, Sergei Shtylyov wrote: > Hello. > > Anton Vorontsov wrote: > >> This patch adds localbus and pata nodes to use CF IDE interface >> on MPC8349E-mITX boards. > >> Patch also adds code to probe localbus. > >> Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> >> --- >> a

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 09:07:14PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >2. "ioport" because shift^Wstride ;-) applies only to the io range > >(yes, it's obvious, but worth open-wording, no?). > > Contrarywise, to memory range. > > >>>By io range I meant "I/O b

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Sergei Shtylyov
Anton Vorontsov wrote: >2. "ioport" because shift^Wstride ;-) applies only to the io range >(yes, it's obvious, but worth open-wording, no?). Contrarywise, to memory range. >>>By io range I meant "I/O base", in contrast to "CTL base". >>>There is no need to apply shifting for CTL.

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 08:34:11PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>2. "ioport" because shift^Wstride ;-) applies only to the io range > >>> (yes, it's obvious, but worth open-wording, no?). > > >> Contrarywise, to memory range. > > >By io range I meant "I/O base",

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Sergei Shtylyov
Anton Vorontsov wrote: >>>2. "ioport" because shift^Wstride ;-) applies only to the io range >>> (yes, it's obvious, but worth open-wording, no?). >> Contrarywise, to memory range. > By io range I meant "I/O base", in contrast to "CTL base". > There is no need to apply shifting for CTL. That

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
[ Had cut too much in the previous reply ] On Tue, Nov 27, 2007 at 07:46:13PM +0300, Sergei Shtylyov wrote: [...] > >2. "ioport" because shift^Wstride ;-) applies only to the io range > > (yes, it's obvious, but worth open-wording, no?). > >Contrarywise, to memory range. By io range I mean

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Sergei Shtylyov
Anton Vorontsov wrote: >> All I want is that "ioport-*" be renamed. > I give up. Don't. :-) > The final name is..? I can think out wrong one, so you'd better > convoy me on that way. ;-) reg-shift sounds okay? Yes. > Thanks, WBR, Sergei _

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 07:46:13PM +0300, Sergei Shtylyov wrote: [...] > >>>+ ioport-shift = <1>; > > >> Bleh... that shift again. And this is surely not a good name for a > >>property (where's I/O ports in your case?) -- why not call it "reg-shift" > >>(well, I'd call it "reg-

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Sergei Shtylyov
Anton Vorontsov wrote: >>>This patch adds localbus and pata nodes to use CF IDE interface >>>on MPC8349E-mITX boards. >>>Patch also adds code to probe localbus. >>>Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> >>>--- >>>arch/powerpc/boot/dts/mpc8349emitx.dts| 17 - >>>a

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 06:49:13PM +0300, Sergei Shtylyov wrote: > Hello. Hi Sergei, > Anton Vorontsov wrote: > > >This patch adds localbus and pata nodes to use CF IDE interface > >on MPC8349E-mITX boards. > > >Patch also adds code to probe localbus. > > >Signed-off-by: Anton Vorontsov <[EMAI

How to notify userspace of custom bus master/slave access mode changes ?

2007-11-27 Thread Laurent Pinchart
Hi everybody, I'm a bit unsure about how to notify userspace of changes to access mode to a custom bus. This is more an architecture issue than an implementation issue. My system has an ISA-like cold-pluggable extension bus. The bus controller sits on the CPU board which is plugged along with s

Re: [PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Sergei Shtylyov
Hello. Anton Vorontsov wrote: > This patch adds localbus and pata nodes to use CF IDE interface > on MPC8349E-mITX boards. > Patch also adds code to probe localbus. > Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> > --- > arch/powerpc/boot/dts/mpc8349emitx.dts| 17 - >

[PATCH 3/3] [POWERPC] MPC8349E-mITX: introduce localbus and pata nodes

2007-11-27 Thread Anton Vorontsov
This patch adds localbus and pata nodes to use CF IDE interface on MPC8349E-mITX boards. Patch also adds code to probe localbus. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc8349emitx.dts| 17 - arch/powerpc/platforms/83xx/mpc834x_itx.c |

[PATCH 2/3] [libata] pata_of_platform: OF-Platform PATA device driver

2007-11-27 Thread Anton Vorontsov
This driver nicely wraps around pata_platform library functions, and provides OF platform bus bindings to the PATA devices. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> --- drivers/ata/Kconfig| 10 + drivers/ata/Makefile |1 + drivers/ata/pata_of_platform.c |

[PATCH 1/3] [libata] pata_platform: make probe and remove functions device type neutral

2007-11-27 Thread Anton Vorontsov
Split pata_platform_{probe,remove} into two pieces: 1. pata_platform_{probe,remove} -- platform_device-dependant bits; 2. __ptata_platform_{probe,remove} -- device type neutral bits. This is done to not duplicate code for the OF-platform driver. Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]>

[PATCH 0/3] OF-platform PATA driver

2007-11-27 Thread Anton Vorontsov
Hi all, Here is the second spin of the OF-platform PATA driver and related patches. Changes since RFC: - nuked drivers/ata/pata_platform.h; - powerpc bits: proper localbus node added. Thanks for the previous review! This time I'm collecting acks, don't be shy to give 'em generously. ;-) Good

Re: [PATCH] [POWERPC] Emulate isel (Integer Select) instruction

2007-11-27 Thread Olof Johansson
On Tue, Nov 27, 2007 at 03:56:53PM +0100, Geert Uytterhoeven wrote: > On Wed, 21 Nov 2007, Geert Uytterhoeven wrote: > > On Tue, 20 Nov 2007, Kumar Gala wrote: > > > On Nov 20, 2007, at 11:54 AM, Scott Wood wrote: > > > > On Mon, Nov 19, 2007 at 09:36:57PM -0600, Kumar Gala wrote: > > > >> isel (In

Re: [PATCH] [POWERPC] Emulate isel (Integer Select) instruction

2007-11-27 Thread Geert Uytterhoeven
On Wed, 21 Nov 2007, Geert Uytterhoeven wrote: > On Tue, 20 Nov 2007, Kumar Gala wrote: > > On Nov 20, 2007, at 11:54 AM, Scott Wood wrote: > > > On Mon, Nov 19, 2007 at 09:36:57PM -0600, Kumar Gala wrote: > > >> isel (Integer Select) is a new user space instruction in the > > >> PowerISA 2.04 spec

RE: [PATCH v2] [POWERPC] Optimize counting distinct entries in the relocation sections

2007-11-27 Thread Medve Emilian
Hi Paul, I'm just wondering what are your latest thoughts about this patch (http://patchwork.ozlabs.org/linuxppc/patch?id=14707). Cheers, Emil. > -Original Message- > From: Medve Emilian > Sent: Tuesday, November 13, 2007 10:24 AM > To: [EMAIL PROTECTED]; [EMAIL PROTECTED]; [EMAIL PR

Re: [PATCH 2/3] [POWERPC] fsl_soc: add support for gianfar for fixed-link property

2007-11-27 Thread Joakim Tjernlund
On Tue, 2007-11-27 at 16:59 +0300, Anton Vorontsov wrote: > On Tue, Nov 27, 2007 at 02:17:11PM +0100, Joakim Tjernlund wrote: > > > > On Tue, 2007-11-27 at 14:39 +0300, Anton Vorontsov wrote: > > > On Mon, Nov 26, 2007 at 04:04:08PM +0100, Joakim Tjernlund wrote: > > > > On Mon, 2007-11-26 at 17:

Re: [PATCH 2/3] [POWERPC] fsl_soc: add support for gianfar for fixed-link property

2007-11-27 Thread Anton Vorontsov
On Tue, Nov 27, 2007 at 02:17:11PM +0100, Joakim Tjernlund wrote: > > On Tue, 2007-11-27 at 14:39 +0300, Anton Vorontsov wrote: > > On Mon, Nov 26, 2007 at 04:04:08PM +0100, Joakim Tjernlund wrote: > > > On Mon, 2007-11-26 at 17:29 +0300, Vitaly Bordug wrote: > > > > fixed-link says: register new

Re: time accounting problem (powerpc only?)

2007-11-27 Thread Johannes Berg
On Tue, 2007-11-27 at 16:00 +1100, Tony Breeds wrote: > On Mon, Nov 26, 2007 at 05:23:13PM +0100, Johannes Berg wrote: > > Contrary to what I claimed later in the thread, my 64-bit powerpc box > > (quad-core G5) doesn't suffer from this problem. > > > > Does anybody have any idea? I don't even kn

Re: [PATCH 2/3] [POWERPC] fsl_soc: add support for gianfar for fixed-link property

2007-11-27 Thread Joakim Tjernlund
On Tue, 2007-11-27 at 14:39 +0300, Anton Vorontsov wrote: > On Mon, Nov 26, 2007 at 04:04:08PM +0100, Joakim Tjernlund wrote: > > On Mon, 2007-11-26 at 17:29 +0300, Vitaly Bordug wrote: > > > fixed-link says: register new "Fixed/emulated PHY", i.e. PHY that > > > not connected to the real MDIO bus

Re: time accounting problem (powerpc only?)

2007-11-27 Thread Johannes Berg
On Tue, 2007-11-27 at 20:57 +1100, Paul Mackerras wrote: > Johannes Berg writes: > > > Contrary to what I claimed later in the thread, my 64-bit powerpc box > > (quad-core G5) doesn't suffer from this problem. > > > > Does anybody have any idea? I don't even know how to debug it further. > > I

Re: time accounting problem (powerpc only?)

2007-11-27 Thread Johannes Berg
> On my powerbook, with NO_HZ and HIGH_RES_TIMERS, I observed recently > that powernowd would not ever switch between CPU speeds. Also happens without NO_HZ (with HIGH_RES_TIMERS). johannes signature.asc Description: This is a digitally signed message part _

Re: 2.6.24-rc3: High CPU load -- hardware interrupts

2007-11-27 Thread Jörg Sommer
Hi Elimar, Elimar Riesebieter schrieb am Mon 26. Nov, 23:38 (+0100): > I can confirm this situation. But it seems, that no one takes care > of it Have a look at the thread “time accounting problem (powerpc only?)” started by Johannes Berg on 23 Nov 2007. Bye, Jörg. -- Du kannst einem Schwe

Re: [PATCH 2/3] [POWERPC] fsl_soc: add support for gianfar for fixed-link property

2007-11-27 Thread Anton Vorontsov
On Mon, Nov 26, 2007 at 04:04:08PM +0100, Joakim Tjernlund wrote: > On Mon, 2007-11-26 at 17:29 +0300, Vitaly Bordug wrote: > > fixed-link says: register new "Fixed/emulated PHY", i.e. PHY that > > not connected to the real MDIO bus. > > > > Signed-off-by: Vitaly Bordug <[EMAIL PROTECTED]> > > Sig

MPC5200 I2C and 2.6 kernel

2007-11-27 Thread Oliver Rutsch
Hi, I'm using a TQM5200S (MPC5200B CPU) module on the STK52xx starter kit. For some reasons I have to use the 2.6 kernel (the latest 2.6.23.1 from the DENX git archive) with ARCH=powerpc and most of my external hardware is running fine with this. On the starter kit there is an external I2C RTC

Re: [2.6 patch] the scheduled I2C RTC driver removal

2007-11-27 Thread Jean Delvare
On Fri, 2 Nov 2007 23:12:43 +0100, Jean Delvare wrote: > Hi Adrian, > > On Thu, 1 Nov 2007 00:03:58 +0100, Adrian Bunk wrote: > > This patch contains the scheduled removal of legacy I2C RTC drivers with > > replacement drivers. > > (...) > > Documentation/feature-removal-schedule.txt |7 > >

Re: time accounting problem (powerpc only?)

2007-11-27 Thread Paul Mackerras
Johannes Berg writes: > Contrary to what I claimed later in the thread, my 64-bit powerpc box > (quad-core G5) doesn't suffer from this problem. > > Does anybody have any idea? I don't even know how to debug it further. I see it on my G4 powerbook. However, a compute-bound task runs just as fas

Re: [patch 2/9] ps3: Use symbolic names for video modes

2007-11-27 Thread Geert Uytterhoeven
On Tue, 27 Nov 2007, Stephen Rothwell wrote: > On Mon, 26 Nov 2007 18:24:57 +0100 Geert Uytterhoeven <[EMAIL PROTECTED]> > wrote: > > @@ -594,20 +594,21 @@ static const struct { > > unsigned mask : 19; > > unsigned id : 4; > > } ps3av_preferred_modes[] = { > > - { .mask = PS3AV_RESBIT_

Re: [RFC/PATCH] powerpc: Move CPM command handling into the cpm drivers

2007-11-27 Thread Vitaly Bordug
On Mon, 26 Nov 2007 15:41:19 -0600 Scott Wood wrote: > Vitaly Bordug wrote: > > perhaps I was not clear enough. That was a rough idea how to handle > > the whole thing, not just cpm_cr_cmd. This cpm command is a corner > > case, but there can be other actions that may confuse CPM being > > trigger