On Tue, Nov 27, 2007 at 09:07:14PM +0300, Sergei Shtylyov wrote: > Anton Vorontsov wrote: > > >>>>>2. "ioport" because shift^Wstride ;-) applies only to the io range > >>>>>(yes, it's obvious, but worth open-wording, no?). > > >>>> Contrarywise, to memory range. > > >>>By io range I meant "I/O base", in contrast to "CTL base". > > >>>There is no need to apply shifting for CTL. That's why ioport-* > >>>appeared in the first place. > > >> So, a matter of wrong terminology then. The thing that you meant by > >> "I/O" is actually called "command block". > > > Yes. And IO is the second name. > > I'd say the first place in drivers/ide belongs to the historic name > "taskfile". The "command block" which is as ATA standard calls it, is hardly > used. > > > It's used widespread in the drivers/ide/. > > Don't remember seeing it.
Oops, thinko -- not drivers/ide/, but include/linux/ide.h. Grep for io_addr. > > Now you understand why I'm so reluctant to hanging up different > > labels on the single thing? ;-) > > :-) -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev