On 11/4/12 1:55 PM, jan iversen wrote:
Hi.

I have finished the control part of the new localization tool, and before I walk further down the line (writing/converting all the translations parts) I would like to have checked if the code is ok in terms of standard, readability and expectations (from other C++ programmers).

I hope one of the C++ programmers, can have a quick look at the code and tell me:
- Are the code written in accordance with the AOO standards (I think so)
- Is it in general in accordance with the AOO writing style.

- C++ files usually have file extensions of .cxx and .hxx

- There are some conventions of naming variables like mnSomthing for a numerical member variable.

I can live with you using a different naming scheme but would ask to change the file extensions.


Of course, I would very much like to hear if there are non-efficient / malicious code in there, but please remember this is only the control skeleton, so there are a lot of code missing.
I only found one thing:

genConvert.cpp  convert_gen::getConverter

- There are two if statements at the start of the method. The second looks like it should be a "else if" instead.

- The return at the bottom looks unreachable.



But the main thing that I am not sure about is whether C++ is the right language for this. I am not sure because I have not found the interesting part of the program: how the file tree is traversed, how external tools are called, or whether there are not external tools anymore.

If the main task of genLang is to traverse the file tree and call external tools, then a script language like Perl might be better suited and would speed up implementation a lot.


I try to include a zip file with this mail, should I not succeed, then please respond to the mail and I will sent it directly.

If the above sounds too harsh, then that is because I am currently sitting in the BoF seesion and am trying to concentrate on two things at the same time.

-Andre


MANY Thanks in advance for the help.
Jan.


Reply via email to