On Wed, 16 Apr 2025 00:25:59 GMT, Paul Sandoz <psan...@openjdk.org> wrote:

>> Vladimir Ivanov has updated the pull request with a new target base due to a 
>> merge or a rebase. The incremental webrev excludes the unrelated changes 
>> brought in by the merge/rebase. The pull request contains 19 additional 
>> commits since the last revision:
>> 
>>  - Merge branch 'master' into vector.math.01.java
>>  - RVV and SVE adjustments
>>  - Merge branch 'master' into vector.math.01.java
>>  - Fix windows-aarch64 build failure
>>  - features_string -> cpu_info_string
>>  - Reviews and Float64Vector-related fix
>>  - Misc fixes and cleanups
>>  - CPU features support
>>  - Cleanup
>>  - TODO list
>>  - ... and 9 more: https://git.openjdk.org/jdk/compare/b0b76fc4...0ffed12f
>
> src/hotspot/share/opto/vectorIntrinsics.cpp line 555:
> 
>> 553: 
>> 554:   const char* debug_name = "<unknown>";
>> 555:   const TypeInstPtr* debug_name_oop = 
>> gvn().type(argument(8))->isa_instptr();
> 
> Should that be:
> 
>   const TypeInstPtr* debug_name_oop = gvn().type(argument(6 + 
> arity))->isa_instptr();
> 
> ?
> Placing the `debugName` parameter before the vector parameters makes it 
> easier to reason about IMO.

Good point. Initially, I intended to keep `debugName` optional, but I don't see 
why we can't require its presence as other constants. Fixed.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/24462#discussion_r2047598327

Reply via email to