Victor Hugo had heard nothing from his publishers for an unconscionably
long time
so he sent them a letter:
?
and they replied with this:
!
Richmond.
Oh, and, Yes, I have been longing to find somewhere I can use the word
"unconscionably".
On 29.06.2016 21:14, Mike Bonner wrote:
What woul
>>What would a text to speech app do if you asked it to read a sentence
comprised of three spaces and a period?
A dramatic silence.
___
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage you
All handler names are single words. Send and call expect that, as they
should, and will see the statement as requesting a handler named "end" with
a parameter "mouseUp" . There is no handler named "end", nor can there be,
since "end" is a designated terminator - - bodybuilders aside.
What woul
As you discovered, you can. With exit. YOu can exit a handler, exit a
repeat, exit to top..
Care should be used with exit to top, depending on what you want to do.
If you have a handler that calls another handler and you "exit to top" from
the second handler, the first handler also exits. (So,
Um: "You're trying to execute a terminator." I'll avoid the off-colour
remarks about
the Styrian bodybuilder and what he did to Tookie Williams.
Why can one not 'call' a terminator in Livecode? Rather like one can use
*break* in a *switch* statement.
Richmond.
On 29.06.2016 20:03, J. Landman
Richmond.
What jacque said.
Turn it upside down. Imagine you tried to:
send "on mouseUp" to...
Craig
-Original Message-
From: J. Landman Gay
To: How to use LiveCode
Sent: Wed, Jun 29, 2016 1:03 pm
Subject: Re: Stopping a script
You can only send or call handler
You can only send or call handler names. The "end" statement simply
designates where the handler ends, much like the period at the end of a
sentence. You're trying to execute a terminator.
Jacqueline Landman Gay | jac...@hyperactivesw.com
HyperActive Software | http://
Hi Richmond,
> Am 29.06.2016 um 18:30 schrieb Richmond :
>
> Don't worry:
I don't worry, because I know it's YOU, Richmond! :-D
> I solved that problem in the easiest, simplest way, that makes me feel very
> stupid
> indeed because it took me 24 hours to "get it":
>
> on mouseEnter
> exit to
Don't worry: I solved that problem in the easiest, simplest way, that
makes me feel very stupid
indeed because it took me 24 hours to "get it":
on mouseEnter
exit to top
end mouseEnter
http://forums.livecode.com/viewtopic.php?f=7&t=27546
Richmond.
On 29.06.2016 19:23, Klaus major-k wrote:
Hi Richmond,
> Am 29.06.2016 um 18:13 schrieb Richmond :
>
> Maybe I'm just being a bit simplistic, BUT what is wrong with
> having a button containing this script:
>
> on mouseUp
> send "end mouseUp' to button "XYZ"
> end mouseUp
>
> this generates an error message:
>
> (Handler: can't find
Maybe I'm just being a bit simplistic, BUT what is wrong with
having a button containing this script:
on mouseUp
send "end mouseUp' to button "XYZ"
end mouseUp
this generates an error message:
(Handler: can't find handler) near "end"
?
Richmond.
__
Since you're using a repeat until.. You can do repeat until (your first
requirement) or not myflag
where on mouseenter you set myflag to true
on mouseleave you set it to false.
As a quick example (not using a flag, but even so you get the idea...)
repeat until the thumbpos of me >= the endvalue
Agreed. The send moveFigure to me in the moveFigure handler could be removed if
you only want the figure to move once each time the mouse enters the object.
I handed my students a stack with a similar script where a button would jump to
a new loc each time the tried to press it. (The loc was ran
Arg. I mean cancel in mouseLeave.
> On Jun 28, 2016, at 1:49 PM, Dar Scott wrote:
>
> This could end up with several copies of moveFigure in pending messages.
> Don't resend if the flag is false. Or, cancel the message.
>
> (And you might be able to do this with moveStopped instead of sen
This could end up with several copies of moveFigure in pending messages. Don't
resend if the flag is false. Or, cancel the message.
(And you might be able to do this with moveStopped instead of send.)
> On Jun 28, 2016, at 1:45 PM, Tore Nilsen wrote:
>
> The variables needs to be global ra
The variables needs to be global rather than local if the scripts are to be
placed in both the card script and the script of the figure that should be
moved. The first line of the card script and the first line of the script in
the object should then read:
global sMoveLine,sMoveSteps,sMove
To
I am not quite sure I understand what you are trying to do , but I’ll have a go
at it:
/*This is what I would put into the cardscript*/
local sMoveLine,sMoveSteps,sMove
on openCard
put field "moveSpots" into sMoveSteps --put the coordinates into a variable for
faster execution of script
put
When testing repeats I usually include a line something like;
if the altKey is down then exit repeat -- or you could use exit to top
Paul
> On Jun 28, 2016, at 11:32 AM, Richmond wrote:
>
> I have tried *STOP MOVING* to interrupt that script, but that does *NOT* work
> because the graphic is e
correction: the walking figure used 'send' not 'move'
> On Jun 28, 2016, at 12:59 PM, Dar Scott wrote:
>
> Maybe this is a good time to introduce the event style of programming.
>
> Focus on 'move...without waiting', and 'moveStopped' and maybe 'send'.
>
> Well, if the details allow that.
Maybe this is a good time to introduce the event style of programming.
Focus on 'move...without waiting', and 'moveStopped' and maybe 'send'.
Well, if the details allow that. If using moveStopped makes things jerky, then
you might need to do something else. However, I think my grandson mad
I have a *button* which, when I click on it, sends a *graphic object*
off on a mad journey all over
a *card* based on reading positions from a*listField*.
I have tried *STOP MOVING* to interrupt that script, but that does *NOT*
work
because the graphic is executing a large number of very short
21 matches
Mail list logo