On Mon, May 4, 2015 at 5:56 PM, Alexei Starovoitov
wrote:
> On Mon, May 04, 2015 at 04:02:40PM -0700, Tom Herbert wrote:
>> In flow dissector if an MPLS header contains an entropy label this is
>> saved in the new extra entropy field of flow_keys. The entropy label is
>> then represented in the fl
3.2.69-rc1 review patch. If anyone has any objections, please let me know.
--
From: Markos Chandras
commit 87f966d97b89774162df04d2106c6350c8fe4cb3 upstream.
On a MIPS Malta board, tons of fifo underflow errors have been observed
when using u-boot as bootloader instead of YAMO
From: Florian Westphal
Date: Mon, 4 May 2015 22:54:43 +0200
> #2 keep fragments attached to reassembled
>
> The idea is to attach the original skbs to the reassembled one, so the
> networking stack can choose which ones to use depending on the use
> case. Forwarding would operate on the origina
From: Eric Dumazet
Date: Mon, 04 May 2015 16:00:04 -0700
> On Mon, 2015-05-04 at 15:44 -0700, Cong Wang wrote:
>
>> So your request is only valid for patches ready for review. Focus on
>> the bug.
>
> Yep, I was trying to, but couldn't reply on your patch, and this is not
> the first time it ha
From: Mahesh Bandewar
Date: Mon, 4 May 2015 15:58:59 -0700
> On Fri, May 1, 2015 at 6:12 PM, David Miller wrote:
>> I am sorry but I am going to put my foot down and not allow another
>> instance of this to happen again. We already have this being done by
>> netfilter, and I consider it unaccep
From: Linus Lüssing
Date: Tue, 5 May 2015 00:19:35 +0200
>> net/core/skbuff.c:4108:13: sparse: incorrect type in assignment (different
>> base types)
>> net/ipv6/mcast_snoop.c:63 ipv6_mc_check_exthdrs() warn: unsigned 'offset' is
>> never less than zero.
>
> Introduced by 9afd85c9e4552b276e2f
Signed-off-by: Alexander Duyck
---
drivers/net/ethernet/ti/netcp_core.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/ethernet/ti/netcp_core.c
b/drivers/net/ethernet/ti/netcp_core.c
index 43efc3a0cda5..0a28c07361cf 100644
--- a/drivers/net/ethernet/ti/netcp_c
From: Jason Baron
Date: Thu, 30 Apr 2015 10:34:17 -0400
> Just curious if anybody had any further reaction on this issue.
> I think making the epoll edge trigger case, as least match what
> we are seeing for poll()/select()/epoll() level trigger seems
> reasonable here.
Ok Jason I think I unders
In flow dissector if a GRE header contains a keyid this is saved in the
new extra entropy field of flow_keys. The GRE keyid is then represented
in the flow hash function input.
Signed-off-by: Tom Herbert
---
include/net/flow_keys.h | 1 +
net/core/flow_dissector.c | 15 ++-
2 file
This patch changes flow hashing to use jhash2 over the flow_keys
structure instead just doing jhash_3words over src, dst, and ports.
This method will allow us take more input into the hashing function
so that we can include full IPv6 addresses, VLAN, flow labels etc.
without needing to resort to xo
BR_GROUPFWD_RESTRICTED bitmask restricts users from setting values to
/sys/class/net/brX/bridge/group_fwd_mask that allow forwarding of
some IEEE 802.1D Table 7-10 Reserved addresses:
(MAC Control) 802.3 01-80-C2-00-00-01
(Link Aggregation) 802.301-80-C2-00-00-0
Hello,
We would like to propose this patchset again. Only minor details
changed since the last version, we incorporated the suggestion from
Jesse to always store the size of the largest fragment received,
regardless of the DF bit.
Thus we never generate bigger fragments as originally received
reg
From: Vlad Yasevich
Date: Mon, 04 May 2015 15:55:48 -0400
> Can you also queue it for stable. This has been broken for a while.
Done.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.ke
From: Sowmini Varadhan
Date: Mon, 4 May 2015 15:29:08 -0400
> On (05/04/15 14:47), David Miller wrote:
>>
>> I think adding 64K of data to this module just to solve this rare
>> issue is excessive.
>
> I'd based that number mostly as a heuristic based on rds_conn_hash[].
> Any suggestions for w
From: Hariprasad Shenai
Date: Mon, 4 May 2015 21:58:16 +0530
> Also changed the name of t4_hw.c:get_mps_bg_map() to t4_get_mps_bg_map()
> and make it an exported routine with a definition in cxgb4.h.
>
> Signed-off-by: Hariprasad Shenai
> ---
> drivers/net/ethernet/chelsio/cxgb4/cxgb4.h
From: Johannes Berg
Date: Mon, 04 May 2015 13:02:09 +0200
> As I was sick last week this dragged out for a bit, but given we have
> -rc2 out I figured I'd send you something sooner rather than later.
>
> Let me know if there are any issues.
Pulled, thanks Johannes.
Feel better soon.
--
To unsu
From: Yuval Mintz
Date: Mon, 4 May 2015 12:34:12 +0300
> Submit 909d9faae2a44 ("bnx2x: Prevent inner-reload while VFs exist")
> contained a bug - MTU change was not prevented by it; Instead, it
> `randomally' prevented bnx2x_resume() from running [harmless yet wrong].
>
> This moves the check to
From: Jeff Kirsher
Date: Mon, 4 May 2015 02:40:19 -0700
> This series contains updates to igb, e100, e1000e and ixgbe.
Pulled, thanks Jeff.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://v
From: Johan Hedberg
Date: Mon, 4 May 2015 12:34:36 +0300
> Here's the first bluetooth-next pull request for 4.2:
>
> - Various fixes for at86rf230 driver
> - ieee802154: trace events support for rdev->ops
> - HCI UART driver refactoring
> - New Realtek IDs added to btusb driver
> - Off-by-o
From: David Ahern
Date: Mon, 4 May 2015 11:51:38 -0400
> c0adf54a109 introduced new sparse warnings:
> CHECK /home/dahern/kernels/linux.git/net/rds/ib_cm.c
> net/rds/ib_cm.c:191:34: warning: incorrect type in initializer (different
> base types)
> net/rds/ib_cm.c:191:34:expected unsigne
From: Linus Walleij
Date: Mon, 4 May 2015 15:18:39 +0200
> On Tue, Mar 17, 2015 at 8:05 PM, David Miller wrote:
>> From: Robert Jarzmik
>> Date: Mon, 16 Mar 2015 22:06:13 +0100
>>
>>> David Miller writes:
>>>
From: Robert Jarzmik
Date: Thu, 19 Feb 2015 21:48:49 +0100
> Linu
From:
Date: Mon, 4 May 2015 14:39:49 +0530
> From: Kamlakant Patel
>
> When smsc911x uses GPIO as the interrupt controller, and if both are
> loaded as modules, we get following error:
>
> "smsc911x: Could not allocate irq resource"
>
> This issue is because of smsc911x using platform_get_res
From: Ying Xue
Date: Mon, 4 May 2015 10:36:43 +0800
> Not only function names declared in subscr.c are very confused, but
> also topology server's locking policy is not designed very well, for
> instance, usually leading to panic in some special corner cases.
>
> In this series, we attempt to el
From: Vladislav Yasevich
Date: Sat, 2 May 2015 21:33:44 -0400
> The code in __netdev_upper_dev_link() has an over-stringent
> loop detection logic that actually prevents valid configurations
> from working correctly.
>
> In particular, the logic returns an error if an upper device
> is already
From: Tilman Schmidt
Date: Sat, 02 May 2015 19:23:22 +0200
> As German phone operators are discontinuing ISDN service, neither
> Hansjörg nor I will be able to maintain the Gigaset ISDN drivers
> any longer. Paul Bolle offered to step into the breach for odd
> fixes.
>
> Signed-off-by: Tilman Sc
From: Linus Lüssing
Date: Sat, 2 May 2015 14:01:05 +0200
> The multicast optimizations in batman-adv are yet only usable and
> enabled in non-bridged scenarios. To be able to support bridged setups
> batman-adv needs to be able to detect IGMP/MLD queriers and reports on
> mesh nodes without brid
From: Sowmini Varadhan
Date: Sat, 2 May 2015 07:55:08 -0400
> When running RDS over TCP, the active (client) side connects to the
> listening ("passive") side at the RDS_TCP_PORT. After the connection
> is established, if the client side reboots (potentially without even
> sending a FIN) the se
From: Stephen Hemminger
Date: Mon, 4 May 2015 08:37:51 -0700
> On Mon, 13 Apr 2015 16:00:59 +0200
> Pavel Šimerda wrote:
>
>> From: Pavel Šimerda
>>
>> Signed-off-by: Pavel Šimerda
>> ---
>> ip/iproute.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> I understand your concern
From: Sathya Perla
Date: Mon, 4 May 2015 02:47:17 -0400
> From: Kalesh AP
>
> The driver so far, on load, always tried to enable RX/TX general pause.
> This setting always fails on certain profiles (like FCoE) where PFC is
> needed. Such failures cannot be effectively communicated to the stack
From: Sathya Perla
Date: Mon, 4 May 2015 02:47:13 -0400
> From: Kalesh AP
>
> This patch adds support for spoofchk configuration for VFs.
> When it is enabled, "spoof checking" is done for both MAC-address and VLAN.
> This feature is supported in Skyhawk FW version 10.6.31.0 and above.
>
> Si
On Tue, 28 Apr 2015 13:18:21 +0300
Mathias Nyman wrote:
> It is hard to quickly find what you are looking for in the output of the
> ip command. Color helps.
>
> This patch adds a '-c' flag to highlight these with individual colors:
> - interface name
> - ip address
> - mac address
> - u
Hi,
This patch series adds the following.
Discard packet if length is greater than MTU, move sge monitor code to a
new routine, add device node to ULD info, add congestion notification from
SGE for ingress queue and freelists and for T5, setting up the Congestion
Manager values of the new RX Ether
On Sun, 03 May 2015 22:12:43 -0700
Alexei Starovoitov wrote:
> On 5/3/15 8:42 AM, Jesper Dangaard Brouer wrote:
> >
> > I was actually expecting to see a higher performance boost.
> > improvement diff = -2.85 ns
> ...
> > The patch is removing two atomic operations, spin_{un,}lock, which I
>
Hi Dave,
Here's the first bluetooth-next pull request for 4.2:
- Various fixes for at86rf230 driver
- ieee802154: trace events support for rdev->ops
- HCI UART driver refactoring
- New Realtek IDs added to btusb driver
- Off-by-one fix for rtl8723b in btusb driver
- Refactoring of btbcm dri
From: Kalesh AP
Use be_virtfn() to determine a VF instead of !be_physfn() for better
readability.
Signed-off-by: Kalesh AP
Signed-off-by: Sathya Perla
---
drivers/net/ethernet/emulex/benet/be_cmds.c | 4 ++--
drivers/net/ethernet/emulex/benet/be_main.c | 11 ++-
2 files changed, 8 in
35 matches
Mail list logo