On Fri, 2016-02-19 at 09:07 -0500, Ilia Mirkin wrote:
> On Feb 19, 2016 8:05 AM, "Samuel Iglesias Gonsálvez" a.com> wrote:
> >
> > On Wed, Feb 17, 2016 at 08:46:36PM -0500, Ilia Mirkin wrote:
> > > Only minor differences to the existing ARB_texture_border_clamp
> support.
> > >
> > > Signed-off-by
Hi Marek;
Was this commit fixing some issues/problems? Why would we not expose
configs with accumulation buffer?
--- 8< ---
commit 396cbabbefaae64deac6d33c79898bb07db8a621
Author: Marek Olšák
Date: Thu Apr 9 23:25:07 2015 +0200
egl/dri: don't expose configs with an accumulation buffer
From: Daniel Czarnowski
Patch provides a default for a set pbuffer surface size when
EGL_LARGEST_PBUFFER is used by the client. MIN2 macro is moved
to egldefines so that it can be shared.
Fixes following Piglit test:
egl-create-largest-pbuffer-surface
From EGL 1.5 spec:
"Use EGL_LARGEST_P
Brian Paul writes:
> On Sat, Feb 20, 2016 at 2:41 PM, Jason Ekstrand
> wrote:
>
>>
>> On Feb 20, 2016 1:19 PM, "Rob Clark" wrote:
>> >
>> > fwiw, I think a *small* number of topic branches in certain cases
>> > makes sense.. I'm definitely in support of a TTL limit (ie.
>> > automatically nuke
On Sun, Feb 21, 2016 at 5:17 PM, Dave Airlie wrote:
> From: Dave Airlie
>
> This drops the amount of symbols visible down, vulkaninfo/vkcube
> still execute.
Thanks. It was always the intention to use this, but I guess we forgot
to turn it on.
Reviewed-by: Kristian Høgsberg
> ---
> src/intel
On Sun, Feb 21, 2016 at 5:17 PM, Dave Airlie wrote:
> From: Dave Airlie
>
> This drops the amount of symbols visible down, vulkaninfo/vkcube
> still execute.
> ---
> src/intel/isl/Makefile.am| 1 +
> src/intel/vulkan/Makefile.am | 1 +
> 2 files changed, 2 insertions(+)
>
> diff --git a/src/
From: Dave Airlie
This drops the amount of symbols visible down, vulkaninfo/vkcube
still execute.
---
src/intel/isl/Makefile.am| 1 +
src/intel/vulkan/Makefile.am | 1 +
2 files changed, 2 insertions(+)
diff --git a/src/intel/isl/Makefile.am b/src/intel/isl/Makefile.am
index 72f5460..8f812d
On Sun, Feb 21, 2016 at 9:19 AM, Samuel Pitoiset
wrote:
> Signed-off-by: Samuel Pitoiset
> ---
> src/gallium/drivers/nouveau/nvc0/nvc0_compute.c | 4 +++-
> src/gallium/drivers/nouveau/nvc0/nvc0_context.c | 4 +++-
> src/gallium/drivers/nouveau/nvc0/nvc0_screen.h | 1 +
> src/gallium/drivers/no
On 02/22/2016 12:19 AM, Ilia Mirkin wrote:
Should you instead move nvc0_compute_validate into nvc0_shader_state?
Currently that's where all this stuff lives. I see
nvc0_program_validate as more of an "internal" module function that
shouldn't be exported across files.
Fine by me.
On Sun, Fe
Should you instead move nvc0_compute_validate into nvc0_shader_state?
Currently that's where all this stuff lives. I see
nvc0_program_validate as more of an "internal" module function that
shouldn't be exported across files.
On Sun, Feb 21, 2016 at 9:19 AM, Samuel Pitoiset
wrote:
> Reduce the amo
On 02/22/2016 12:15 AM, Ilia Mirkin wrote:
Nope. This will be needed on nvc0 as well if it's to support OpenCL.
I was thinking the same thing actually but I was not sure.
I think we should also validate those global buffers on Fermi.
On Sun, Feb 21, 2016 at 9:19 AM, Samuel Pitoiset
wrote:
Nope. This will be needed on nvc0 as well if it's to support OpenCL.
On Sun, Feb 21, 2016 at 9:19 AM, Samuel Pitoiset
wrote:
> This function is currently only used for the compute validation path
> on GK104+. While we are at it, also rename it to
> nvc0_compute_validate_globals() and update its p
On 02/22/2016 12:08 AM, Ilia Mirkin wrote:
On Sun, Feb 21, 2016 at 9:18 AM, Samuel Pitoiset
wrote:
/* 3d bufctx (during draw_vbo, blit_3d) */
-#define NVC0_BIND_FB0
-#define NVC0_BIND_VTX 1
-#define NVC0_BIND_VTX_TMP 2
-#define NVC0_BIND_IDX 3
-#define
On Sun, Feb 21, 2016 at 9:18 AM, Samuel Pitoiset
wrote:
>
> /* 3d bufctx (during draw_vbo, blit_3d) */
> -#define NVC0_BIND_FB0
> -#define NVC0_BIND_VTX 1
> -#define NVC0_BIND_VTX_TMP 2
> -#define NVC0_BIND_IDX 3
> -#define NVC0_BIND_TEX(s, i) ( 4 + 32 * (s
On Sun, 2016-02-21 at 12:01 +, Steven Newbury wrote:
> On Sun, 2016-02-21 at 11:28 +, Steven Newbury wrote:
> > On Sun, 2016-02-21 at 10:56 +, Steven Newbury wrote:
> > > On Sun, 2016-02-21 at 10:16 +, Steven Newbury wrote:
> > > > Hi Jason,
> > > >
> > > > commit f6d95876888c81559
On Sun, 2016-02-21 at 10:56 +, Steven Newbury wrote:
> On Sun, 2016-02-21 at 10:16 +, Steven Newbury wrote:
> > Hi Jason,
> >
> > commit f6d95876888c81559d4ba773e4e6c82b184e708e in the vulkan
> > branch
> > has broken out-of-source-tree builds. The generated header files
> > should be inc
On Sun, 2016-02-21 at 10:16 +, Steven Newbury wrote:
> Hi Jason,
>
> commit f6d95876888c81559d4ba773e4e6c82b184e708e in the vulkan branch
> has broken out-of-source-tree builds. The generated header files
> should be included from the build tree, instead of the source tree.
--- src/intel/vul
--
此致
礼
罗勇刚
Yours
sincerely,
Yonggang Luo
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev
Hi Jason,
commit f6d95876888c81559d4ba773e4e6c82b184e708e in the vulkan branch
has broken out-of-source-tree builds. The generated header files
should be included from the build tree, instead of the source tree.
___
mesa-dev mailing list
mesa-dev@lists
On Sun, 2016-02-21 at 11:28 +, Steven Newbury wrote:
> On Sun, 2016-02-21 at 10:56 +, Steven Newbury wrote:
> > On Sun, 2016-02-21 at 10:16 +, Steven Newbury wrote:
> > > Hi Jason,
> > >
> > > commit f6d95876888c81559d4ba773e4e6c82b184e708e in the vulkan
> > > branch
> > > has broken o
Reviewed-by: Ilia Mirkin
Thanks for taking care of it!
On Sun, Feb 21, 2016 at 1:40 PM, Samuel Pitoiset
wrote:
> Actually OP_SELP doesn't need to be a compare instruction. Instead we
> just need to set the NOT modifier when building the instruction.
> While we are at it, fix the dst register ty
For the series:
Reviewed-by: Marek Olšák
Marek
On Sat, Feb 20, 2016 at 10:39 PM, Nicolai Hähnle wrote:
> From: Nicolai Hähnle
>
> The reason is that the shader image atoms call st_finalize_texture, which
> may set ST_NEW_FRAMEBUFFER.
>
> This fixes an assertion triggered by a subtest of pigli
On 02/21/2016 06:49 PM, Ilia Mirkin wrote:
On Wed, Feb 17, 2016 at 4:27 PM, Samuel Pitoiset
wrote:
Loosely based on 3D.
Changs from v3:
- invalidate COMPUTE CBs after validating 3D CBs because they are
aliased
Changes from v2:
- get rid of the 's' param to nvc0_cb_bo_push() because
This function is currently only used for the compute validation path
on GK104+. While we are at it, also rename it to
nvc0_compute_validate_globals() and update its prototype.
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_context.h| 2 --
src/gallium/drivers/n
Signed-off-by: Axel Davy
---
src/gallium/state_trackers/nine/nine_shader.c | 31 +--
1 file changed, 15 insertions(+), 16 deletions(-)
diff --git a/src/gallium/state_trackers/nine/nine_shader.c
b/src/gallium/state_trackers/nine/nine_shader.c
index a7a7da2..f0c5236 100644
On Sat, 2016-02-20 at 13:41 -0800, Jason Ekstrand wrote:
> On Feb 20, 2016 1:19 PM, "Rob Clark" wrote:
> >
> > fwiw, I think a *small* number of topic branches in certain cases
> > makes sense.. I'm definitely in support of a TTL limit (ie.
> > automatically nuke topic branches with no activity
https://bugs.freedesktop.org/show_bug.cgi?id=94232
Bug ID: 94232
Summary: Problems compiling mesa with glibc 2.23
Product: Mesa
Version: git
Hardware: Other
OS: All
Status: NEW
Severity: normal
P
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c | 4 +++-
src/gallium/drivers/nouveau/nvc0/nvc0_context.c | 4 +++-
src/gallium/drivers/nouveau/nvc0/nvc0_screen.h | 1 +
src/gallium/drivers/nouveau/nvc0/nve4_compute.c | 4 +++-
4 files changed, 10 insertions(+)
Hi,
This series reworks the validation path for compute.
There are no regressions for both piglit and deqp on my NVD9. I also tested
MP performance counters which use a compute program to read the counters,
works fine too.
Please review.
Samuel Pitoiset (6):
nvc0: move nvc0_validate_global_re
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/mme/com90c0.mme | 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c | 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_macros.h | 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_screen.c | 2 +-
4 files changed, 4 insertions(+),
Hi Micheal,
no problem, I'm learning so much and you and Emil have both shown amounts
of patience with me.
I've tested the following patch and it works
Mauro
>From a00b1182fd74ec6af37e09e53dd3febec36af27d Mon Sep 17 00:00:00 2001
From: Mauro Rossi
Date: Sun, 21 Feb 2016 20:31:21 +0100
Subject
On Wed, Feb 17, 2016 at 4:27 PM, Samuel Pitoiset
wrote:
> Loosely based on 3D.
>
> Changs from v3:
> - invalidate COMPUTE CBs after validating 3D CBs because they are
>aliased
>
> Changes from v2:
> - get rid of the 's' param to nvc0_cb_bo_push() because it doesn't
>matter to upload cons
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c| 4 +-
src/gallium/drivers/nouveau/nvc0/nvc0_context.c| 18 ++---
src/gallium/drivers/nouveau/nvc0/nvc0_context.h| 58 +++---
.../drivers/nouveau/nvc0/nvc0_shader_state.c | 4 +-
src/gal
This will be used to rework the validation path for compute.
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/Makefile.sources | 1 +
src/gallium/drivers/nouveau/nvc0/nvc0_context.h| 3 --
.../drivers/nouveau/nvc0/nvc0_state_validate.c | 38 ++
.
Actually OP_SELP doesn't need to be a compare instruction. Instead we
just need to set the NOT modifier when building the instruction.
While we are at it, fix the dst register type and use a GPR.
Suggested by Ilia Mirkin.
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/codegen/nv
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_context.c| 28 +++---
src/gallium/drivers/nouveau/nvc0/nvc0_context.h| 24 +--
.../drivers/nouveau/nvc0/nvc0_shader_state.c | 8 +++
src/gallium/drivers/nouveau/nvc0/nvc0_st
Sooo I know I'm the one who suggested this change in the first
place. But having slept on it, I think this is wrong. The point of a
CmpInstruction is when you're comparing two things and you need a
comparison operator and stuff like that. This is a much simpler
situation -- you can only have a
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c| 96 ++---
.../drivers/nouveau/nvc0/nvc0_query_hw_sm.c| 28 +++
src/gallium/drivers/nouveau/nvc0/nvc0_tex.c| 6 +-
src/gallium/drivers/nouveau/nvc0/nvc0_winsys.h | 6 +-
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c| 4 +-
src/gallium/drivers/nouveau/nvc0/nvc0_context.c| 16 +++
src/gallium/drivers/nouveau/nvc0/nvc0_context.h| 2 +-
.../drivers/nouveau/nvc0/nvc0_shader_state.c | 4 +-
src/gallium/drive
When the semantic is position (which can happen with index 0 only),
use the helper to get position input.
Signed-off-by: Axel Davy
---
The other changes of the initial patch (forbid POSITION0, etc)
will be part of another serie.
src/gallium/state_trackers/nine/nine_shader.c | 7 +++
1 file
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c | 44 +
src/gallium/drivers/nouveau/nvc0/nve4_compute.c | 41 +--
2 files changed, 31 insertions(+), 54 deletions(-)
diff --git a/src/gallium/drivers/nouveau/nvc0/nvc0_c
Signed-off-by: Samuel Pitoiset
---
.../drivers/nouveau/codegen/nv50_ir_emit_nvc0.cpp | 35 +++---
1 file changed, 25 insertions(+), 10 deletions(-)
diff --git a/src/gallium/drivers/nouveau/codegen/nv50_ir_emit_nvc0.cpp
b/src/gallium/drivers/nouveau/codegen/nv50_ir_emit_nvc0.cpp
On Sat, Feb 20, 2016 at 9:05 PM, Ilia Mirkin wrote:
> Signed-off-by: Ilia Mirkin
> ---
>
> dEQP tests mostly pass... they reveal some pre-existing issues with packed
> varyings and interpolateAt* - the interpolants become temporaries, which
> breaks
> everything. However fixing this should be un
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c| 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_context.c| 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_screen.h | 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_state_validate.c | 4 ++--
src/gall
Reduce the amount of duplicated code by re-using
nvc0_program_validate(). While we are at it, change the prototype
to return void.
Signed-off-by: Samuel Pitoiset
---
src/gallium/drivers/nouveau/nvc0/nvc0_compute.c| 32 ++
src/gallium/drivers/nouveau/nvc0/nvc0_compute.h
Hi there,
This series only contains cosmetic changes to improve consistency between
3D and COMPUTE pipelines.
Please review.
Thanks!
Samuel Pitoiset (5):
nvc0: rename nvc0_context::dirty to nvc0_context::dirty_3d
nvc0: rename NVXX_COMPUTE to NVXX_CP
nvc0: prefix compute macros with _CP_ in
On Sat, Feb 20, 2016 at 2:41 PM, Jason Ekstrand
wrote:
>
> On Feb 20, 2016 1:19 PM, "Rob Clark" wrote:
> >
> > fwiw, I think a *small* number of topic branches in certain cases
> > makes sense.. I'm definitely in support of a TTL limit (ie.
> > automatically nuke topic branches with no activity
On Sat, Feb 20, 2016 at 4:41 PM, Jason Ekstrand wrote:
> On Feb 20, 2016 1:19 PM, "Rob Clark" wrote:
>>
>> fwiw, I think a *small* number of topic branches in certain cases
>> makes sense.. I'm definitely in support of a TTL limit (ie.
>> automatically nuke topic branches with no activity in N m
On Sat, Feb 20, 2016 at 5:36 PM, Rob Clark wrote:
> On Sat, Feb 20, 2016 at 4:41 PM, Jason Ekstrand
> wrote:
> > On Feb 20, 2016 1:19 PM, "Rob Clark" wrote:
> >>
> >> fwiw, I think a *small* number of topic branches in certain cases
> >> makes sense.. I'm definitely in support of a TTL limit (
49 matches
Mail list logo