On Tue, 2014-10-28 at 22:14 +, Bruno Jimenez wrote:
> On Wed, 2014-10-29 at 07:49 +1100, Timothy Arceri wrote:
> > On Mon, 2014-10-27 at 20:04 +, Bruno Jimenez wrote:
> > > [snip]
> > > > >> +
> > > > >> + if (aligned_count >= 4) {
> > > > > ^^
> > > > >
> > > >
Ack
On Oct 28, 2014 7:24 PM, "Kenneth Graunke" wrote:
> Hello,
>
> I'd like to rename some files in i965:
>
> - brw_gs.c -> brw_ff_gs.c
> - brw_gs.h -> brw_ff_gs.h
> - brw_gs_emit.c -> brw_ff_gs_emit.c
> - brw_vec4_gs.c -> brw_gs.c
> - brw_vec4_gs.h -> brw_gs.h
>
> The current "brw_gs"
On Tue, Oct 28, 2014 at 7:27 PM, Kenneth Graunke wrote:
> I'd like to rename some files in i965:
>
> - brw_gs.c -> brw_ff_gs.c
> - brw_gs.h -> brw_ff_gs.h
> - brw_gs_emit.c -> brw_ff_gs_emit.c
> - brw_vec4_gs.c -> brw_gs.c
> - brw_vec4_gs.h -> brw_gs.h
Sounds good to me.
Acked-by: Matt
Hello,
I'd like to rename some files in i965:
- brw_gs.c -> brw_ff_gs.c
- brw_gs.h -> brw_ff_gs.h
- brw_gs_emit.c -> brw_ff_gs_emit.c
- brw_vec4_gs.c -> brw_gs.c
- brw_vec4_gs.h -> brw_gs.h
The current "brw_gs" files are about emulating fixed-function functionality
(VF primitive decom
On Tue, Oct 28, 2014 at 5:48 PM, Kenneth Graunke wrote:
> I believe Eric introduced the name, and it's been around for quite a while
> now. Feel free to submit a patch to rename it.
Oh, yuck. Okay.
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.o
On Tuesday, October 28, 2014 04:25:05 PM Matt Turner wrote:
> On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg
wrote:
> > This flag signals that we have a SIMD8 VS shader so we can set up the
> > corresponding state accordingly. This boils down to setting
> > the BDW+ SIMD8 enable bit in 3DSTA
On Tue, Oct 28, 2014 at 5:23 PM, Jason Ekstrand
wrote:
>
>
>
> On Tue, Oct 28, 2014 at 12:29 PM, Matt Turner wrote:
>
>> On Tue, Oct 28, 2014 at 12:10 PM, Jason Ekstrand
>> wrote:
>> >
>> > On Oct 28, 2014 11:57 AM, "Matt Turner" wrote:
>> >>
>> >> On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstra
On Tue, Oct 28, 2014 at 3:59 PM, Matt Turner wrote:
>>> - assert(stage == MESA_SHADER_FRAGMENT);
>>
>> I like removing these asserts from the function bodies, but I'm
>> confused why you're doing it. The VS isn't going to call
>> fire_fb_write, or emit a derivative instruction.
>
> Oh, you're ac
On Tue, Oct 28, 2014 at 12:29 PM, Matt Turner wrote:
> On Tue, Oct 28, 2014 at 12:10 PM, Jason Ekstrand
> wrote:
> >
> > On Oct 28, 2014 11:57 AM, "Matt Turner" wrote:
> >>
> >> On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstrand
> >> wrote:
> >> > Before, we used the a signed d-word for booleans
On Tue, Oct 28, 2014 at 4:50 PM, Kenneth Graunke wrote:
> On Tuesday, October 28, 2014 03:41:45 PM Matt Turner wrote:
>> On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg
> wrote:
>> > The LOAD_PAYLOAD opcode can't saturate its sources, so skip
>> > saturating MOVs. The register coalescing afte
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> This patch uses the previous refactoring to add a new run_vs() method
> that generates vertex shader code using the scalar visitor and
> optimizer.
>
> Signed-off-by: Kristian Høgsberg
> ---
> src/mesa/drivers/dri/i965/brw_fs.cpp
On Tuesday, October 28, 2014 03:41:45 PM Matt Turner wrote:
> On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg
wrote:
> > The LOAD_PAYLOAD opcode can't saturate its sources, so skip
> > saturating MOVs. The register coalescing after lower_load_payload()
> > will clean up the extra MOVs.
> >
>
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> These last few operations all only apply when we've actually generated code,
> optimized and allocated registers. The dummy and the repclear shaders don't
> touch uncompressed_stack, don't need the gen4 send workaround, and don't
> spill
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> The scalar vertex shader will use the ATTR register file for vertex
> attributes. This patch adds support for the ATTR file to fs_visitor.
>
> Signed-off-by: Kristian Høgsberg
> ---
> src/mesa/drivers/dri/i965/brw_fs.cpp | 12
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> This flag signals that we have a SIMD8 VS shader so we can set up the
> corresponding state accordingly. This boils down to setting
> the BDW+ SIMD8 enable bit in 3DSTATE_VS and making UBO and pull
> constant buffers use dword pitch.
>
>
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> This is all we need from the generator for SIMD8 vertex shaders. This
> opcode is just the send instruction, all the hard work will happen
> in the visitor using LOAD_PAYLOAD.
>
> Signed-off-by: Kristian Høgsberg
> ---
> src/mesa/drive
On Tue, Oct 28, 2014 at 3:58 PM, Matt Turner wrote:
> On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
>> This removes all stage specific data from the generator, and lets us
>> create a generator for any stage.
>>
>> Signed-off-by: Kristian Høgsberg
>> ---
>> src/mesa/drivers/dri/i965
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> This removes all stage specific data from the generator, and lets us
> create a generator for any stage.
>
> Signed-off-by: Kristian Høgsberg
> ---
> src/mesa/drivers/dri/i965/brw_blorp_blit_eu.cpp | 5 ++---
> src/mesa/drivers/dri/i96
Reviewed-by: Charmaine Lee
From: mesa-dev on behalf of Brian Paul
Sent: Monday, October 27, 2014 2:04 PM
To: mesa-dev@lists.freedesktop.org
Subject: [Mesa-dev] [PATCH] st/mesa: use PIPE_BIND_DISPLAY_TARGET when
checking for sRGB capability
When we're
On Tue, Oct 28, 2014 at 3:17 PM, Kristian Høgsberg wrote:
> The LOAD_PAYLOAD opcode can't saturate its sources, so skip
> saturating MOVs. The register coalescing after lower_load_payload()
> will clean up the extra MOVs.
>
> Signed-off-by: Kristian Høgsberg
> ---
> src/mesa/drivers/dri/i965/br
We'll reuse this toplevel optimization driver for the scalar VS.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs.cpp | 136 ++-
src/mesa/drivers/dri/i965/brw_fs.h | 1 +
2 files changed, 72 insertions(+), 65 deletions(-)
diff --git a/src
The scalar vertex shader will use the ATTR register file for vertex
attributes. This patch adds support for the ATTR file to fs_visitor.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs.cpp | 12 ++--
src/mesa/drivers/dri/i965/brw_fs.h | 3 +++
This removes all stage specific data from the generator, and lets us
create a generator for any stage.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_blorp_blit_eu.cpp | 5 ++---
src/mesa/drivers/dri/i965/brw_fs.cpp| 2 +-
src/mesa/drivers/dri/i965/brw_fs.h
With everything in place, we can now use the scalar backend compiler for
vertex shaders on BDW+. We make scalar vertex shaders the default on
BDW+ but add a new vec4vs debug option to force the vec4 backend.
No piglit regressions.
Performance impact is minimal, I see a ~1.5 improvement on the T-
This is all we need from the generator for SIMD8 vertex shaders. This
opcode is just the send instruction, all the hard work will happen
in the visitor using LOAD_PAYLOAD.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_defines.h | 1 +
src/mesa/drivers/dri/i965/br
fs_generator no longer knows what stage it's generating code for, so
we have to set the debug name of the shader from the call site.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_blorp_blit_eu.cpp | 4 +++-
src/mesa/drivers/dri/i965/brw_fs.cpp| 13 ++-
s
This flag signals that we have a SIMD8 VS shader so we can set up the
corresponding state accordingly. This boils down to setting
the BDW+ SIMD8 enable bit in 3DSTATE_VS and making UBO and pull
constant buffers use dword pitch.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_
Now that the caller passes in the shader debug name, we don't need this
anymore.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_blorp_blit_eu.cpp | 2 +-
src/mesa/drivers/dri/i965/brw_fs.cpp| 2 +-
src/mesa/drivers/dri/i965/brw_fs.h | 2 --
src/mesa/d
This chunk of code is repeated in a few places, and we're going to add
a MESA_SHADER_VERTEX case to it soon.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs_visitor.cpp | 37
1 file changed, 16 insertions(+), 21 deletions(-)
diff --git a/src/me
These last few operations all only apply when we've actually generated code,
optimized and allocated registers. The dummy and the repclear shaders don't
touch uncompressed_stack, don't need the gen4 send workaround, and don't
spill. This means we can move these lines into the else-branch, which w
Now that fs_visitor::run is back to being only fragment
shader compilation, we can clean up a few stage == MESA_SHADER_FRAGMENT
conditions and rename it to run_fs.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs.cpp | 31 +--
src/mesa/drivers/dri
The LOAD_PAYLOAD opcode can't saturate its sources, so skip
saturating MOVs. The register coalescing after lower_load_payload()
will clean up the extra MOVs.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp | 6 +-
1 file changed, 5 insertions(+), 1
This patch uses the previous refactoring to add a new run_vs() method
that generates vertex shader code using the scalar visitor and
optimizer.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs.cpp | 101 -
src/mesa/drivers/dri/i965/brw_fs.h | 21 +-
This will be reused for the scalar VS pass.
Signed-off-by: Kristian Høgsberg
---
src/mesa/drivers/dri/i965/brw_fs.cpp | 132 +++
src/mesa/drivers/dri/i965/brw_fs.h | 1 +
2 files changed, 71 insertions(+), 62 deletions(-)
diff --git a/src/mesa/drivers/dri/i96
With Broadwell we have the option to run vertex shaders in scalar (SIMD8)
mode which potentially gives us better throughput and more vertices
per thread dispatch. This patch series implements this by repurposing our
fs backend to also work for vertex shaders.
Kristian Høgsberg (14):
i965: Don't
On Wed, 2014-10-29 at 07:49 +1100, Timothy Arceri wrote:
> On Mon, 2014-10-27 at 20:04 +, Bruno Jimenez wrote:
> > [snip]
> > > >> +
> > > >> + if (aligned_count >= 4) {
> > > > ^^
> > > >
> > > > Hi,
> > > >
> > > > I have been thinking and I think that you can ch
On 10/28/2014 01:08 PM, Marek Olšák wrote:
From: Marek Olšák
This reverts commit 20836c81851e0df29a8ee9c86e5e5388738c840b.
255 is a huge number. If you have a loop with 255 iterations, unrolling it
will exceed the SM3 instruction limit. Let's use the default again.
The comment about a SM3 lim
On Tuesday, October 28, 2014 12:10:11 PM Jason Ekstrand wrote:
> On Oct 28, 2014 11:57 AM, "Matt Turner" wrote:
> >
> > On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstrand
> wrote:
> > > Before, we used the a signed d-word for booleans and the immedates we
> > > emitted varried between signed and uns
Yes, thanks!
Reviewed-by: Marek Olšák
Marek
On Sat, Oct 25, 2014 at 10:42 AM, wrote:
> From: Mathias Fröhlich
>
> Hi Marek,
>
> Did you have something like below in mind?
>
> Mathias
>
>
> This removes the need for the gallium rasterizer state
> to listen to viewport changes.
> Thanks to Mar
Kenneth Graunke writes:
> Is UST expressed in a particular unit? I thought it was just "monotonically
> increasing" but otherwise meaningless. At which point, our FPS would be
> "frames per...something?" :)
UST in GL's extension is not defined, but Present uses microseconds. As
this is all h
On Mon, 2014-10-27 at 20:04 +, Bruno Jimenez wrote:
> [snip]
> > >> +
> > >> + if (aligned_count >= 4) {
> > > ^^
> > >
> > > Hi,
> > >
> > > I have been thinking and I think that you can change that 4 for an 8. In
> > > the case aligned_count == 4 there's no gain
Hi,
On Tuesday, October 28, 2014 19:43:23 Neil Roberts wrote:
> I think if you change the clip depth mode without changing the clip
> origin then only the _NEW_VIEWPORT state would be set. Does that mean we
> have to add _NEW_VIEWPORT to the state for the gen7_clip_state atom as
> well to make su
On Tuesday, October 28, 2014 11:12:40 AM Keith Packard wrote:
> Kenneth Graunke writes:
>
> > The code is cut-and-pasted from dri2_glx.c; we can't quite share it
> > because we have to use different structures.
>
> It might be fun to use the UST value provided in the
> PRESENT_COMPLETE_NOTIFY ev
I think if you change the clip depth mode without changing the clip
origin then only the _NEW_VIEWPORT state would be set. Does that mean we
have to add _NEW_VIEWPORT to the state for the gen7_clip_state atom as
well to make sure that upload_clip_state is called?
There is also some state for the f
On Tue, Oct 28, 2014 at 12:10 PM, Jason Ekstrand wrote:
>
> On Oct 28, 2014 11:57 AM, "Matt Turner" wrote:
>>
>> On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstrand
>> wrote:
>> > Before, we used the a signed d-word for booleans and the immedates we
>> > emitted varried between signed and unsigned.
On Oct 28, 2014 11:57 AM, "Matt Turner" wrote:
>
> On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstrand
wrote:
> > Before, we used the a signed d-word for booleans and the immedates we
> > emitted varried between signed and unsigned. This commit changes the
type
> > to unsigned (I think that makes mo
From: Marek Olšák
This reverts commit 20836c81851e0df29a8ee9c86e5e5388738c840b.
255 is a huge number. If you have a loop with 255 iterations, unrolling it
will exceed the SM3 instruction limit. Let's use the default again.
The comment about a SM3 limit doesn't make sense. For SM3, we generally
On Thu, Oct 16, 2014 at 3:40 PM, Jason Ekstrand wrote:
> Before, we used the a signed d-word for booleans and the immedates we
> emitted varried between signed and unsigned. This commit changes the type
> to unsigned (I think that makes more sense) and makes immediates more
> consistent. This al
On inspection it looks like this would potentially break
_mesa_meta_Clear when it is using GLSL because that does not save the
MESA_META_TRANSFORM state.
I wonder if MESA_META_TRANSFORM is not the right state flag for this
because all of the other state in it is about fixed-function stuff which
is
Kenneth Graunke writes:
> The code is cut-and-pasted from dri2_glx.c; we can't quite share it
> because we have to use different structures.
It might be fun to use the UST value provided in the
PRESENT_COMPLETE_NOTIFY event instead of a local gettimeofday call? That
way you'd get the presentatio
https://bugs.freedesktop.org/show_bug.cgi?id=85425
Neil Roberts changed:
What|Removed |Added
Status|NEW |RESOLVED
Resolution|---
On Tue, Oct 28, 2014 at 1:19 AM, Kenneth Graunke wrote:
> The GL functions and driver hooks use corresponding names---for example,
> glMapBufferRange and Driver.MapBufferRange. But our implementation was
> called "intel_bufferobj_map_range," which has the words "map" and
> "buffer" swapped, as we
https://bugs.freedesktop.org/show_bug.cgi?id=85419
--- Comment #5 from Roland Scheidegger ---
(In reply to James Evans from comment #2)
> Thanks for the tip with '~0' I was unaware of that. I only used '0x'
> because that was what was used in the red book examples.
I suspect they were usi
Reviewed-by: Marek Olšák
Marek
On Tue, Oct 28, 2014 at 8:09 AM, Kenneth Graunke wrote:
> The code is cut-and-pasted from dri2_glx.c; we can't quite share it
> because we have to use different structures.
>
> Signed-off-by: Kenneth Graunke
> Cc: Keith Packard
> ---
> src/glx/dri3_glx.c | 35
https://bugs.freedesktop.org/show_bug.cgi?id=85467
José Fonseca changed:
What|Removed |Added
Assignee|mesa-dev@lists.freedesktop. |srol...@vmware.com
|org
https://bugs.freedesktop.org/show_bug.cgi?id=85467
--- Comment #3 from José Fonseca ---
$ gdb --args ./bin/gl-1.0-dlist-beginend -auto
[...]
Program received signal SIGSEGV, Segmentation fault.
0x77eb8288 in ?? ()
(gdb) disassemble 0x77eb8240,0x77eb82ff
Dump of assembler c
https://bugs.freedesktop.org/show_bug.cgi?id=85467
--- Comment #2 from José Fonseca ---
This is probably along the same lines as
https://bugs.freedesktop.org/show_bug.cgi?id=85377
However it seems that, this time around, its not in an unit test, but that
we're actually making some invalida assum
https://bugs.freedesktop.org/show_bug.cgi?id=84566
--- Comment #44 from Iago Toral ---
(In reply to Iago Toral from comment #43)
(...)
> 3) Luminance formats have special requirements. A conversion to Luminance
> from RGBA requires to do L=R+G+B for example. This is something that
> _mesa_format_
Hi,
Comments below.
On ti, 2014-10-28 at 12:44 +0100, Axel Davy wrote:
> On 28/10/2014 10:19, Joonas Lahtinen wrote :
> > Hi,
> >
> > On pe, 2014-10-24 at 17:37 +, Emil Velikov wrote:
> >> Hi Joonas,
> >>
> >> On 22/10/14 18:17, Joonas Lahtinen wrote:
> >>> Hi,
> >>>
> >>> This patch introduc
On 28/10/14 09:19, Joonas Lahtinen wrote:
> Hi,
>
> On pe, 2014-10-24 at 17:37 +, Emil Velikov wrote:
>> Hi Joonas,
>>
>> On 22/10/14 18:17, Joonas Lahtinen wrote:
>>> Hi,
>>>
>>> This patch introduced DRI3 support to the EGL backend.
>>>
>>> Patch is on top of current master. With the patch y
https://bugs.freedesktop.org/show_bug.cgi?id=84566
--- Comment #43 from Iago Toral ---
Jason, we are running into some issues when attempting to use
_mesa_format_convert for glReadPixels and glGetTexImage.
Generally, one thing that is different in this case is that the current
implementation nev
On 28/10/2014 10:19, Joonas Lahtinen wrote :
Hi,
On pe, 2014-10-24 at 17:37 +, Emil Velikov wrote:
Hi Joonas,
On 22/10/14 18:17, Joonas Lahtinen wrote:
Hi,
This patch introduced DRI3 support to the EGL backend.
Patch is on top of current master. With the patch you can observe
reduced CP
Hi,
On pe, 2014-10-24 at 17:37 +, Emil Velikov wrote:
> Hi Joonas,
>
> On 22/10/14 18:17, Joonas Lahtinen wrote:
> > Hi,
> >
> > This patch introduced DRI3 support to the EGL backend.
> >
> > Patch is on top of current master. With the patch you can observe
> > reduced CPU stress when many
https://bugs.freedesktop.org/show_bug.cgi?id=59225
Andrés Gómez García changed:
What|Removed |Added
Status|NEW |NEEDINFO
--
You are receiving thi
https://bugs.freedesktop.org/show_bug.cgi?id=59225
--- Comment #1 from Andrés Gómez García ---
Is this valid any more?
piglit: b13d0bb86d175e36e013dbd528a50e59308adad0 (master)
mesa: 17d98ae25491d5781356da39658f926ed55f2eb5 (master)
$ ./piglit run -t arb_es2_compatibility tests/all results/fb59
The GL functions and driver hooks use corresponding names---for example,
glMapBufferRange and Driver.MapBufferRange. But our implementation was
called "intel_bufferobj_map_range," which has the words "map" and
"buffer" swapped, as well as randomly adding "obj."
FlushMappedBufferRange was even tri
The code is cut-and-pasted from dri2_glx.c; we can't quite share it
because we have to use different structures.
Signed-off-by: Kenneth Graunke
Cc: Keith Packard
---
src/glx/dri3_glx.c | 35 ++-
src/glx/dri3_priv.h | 6 +-
2 files changed, 39 insertions(+),
67 matches
Mail list logo