On Thu, Jun 26, 2003 at 11:10:47AM +0200, Andre' Poenitz wrote:
> > | lyx::Assert(&*startpit);
> > | lyx::Assert(&*endpit);
>
> Yes. &*startpit is in every implementation I know never zero and it just
> invokes undefined behaviour
... if startpit == paragraphs.end() or endpit == paragraphs
On Thu, Jun 26, 2003 at 10:05:28AM +0200, Lars Gullik Bjønnes wrote:
> Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> | What about trying to find things like
> |
> | bool CutAndPaste::copySelection(ParagraphList::iterator startpit,
> | ParagraphList::iterator endpit,
>
Andre Poenitz <[EMAIL PROTECTED]> writes:
| What about trying to find things like
|
| bool CutAndPaste::copySelection(ParagraphList::iterator startpit,
| ParagraphList::iterator endpit,
| int start, int end, textclass_type tc)
| {
|
What about trying to find things like
bool CutAndPaste::copySelection(ParagraphList::iterator startpit,
ParagraphList::iterator endpit,
int start, int end, textclass_type tc)
{
lyx::Assert(&*startpit);
lyx::Assert(&*e
On Mon, Mar 17, 2003 at 11:37:18AM +0100, Jean-Marc Lasgouttes wrote:
> It would probably be a good idea to run some profiler on this and see
> whether things remain sensible.
The results seem a bit odd (playing with TableExamples.lyx) :
0811dec4 594 1.26399 LyXTabular::row_of_cell(int)
On Mon, Mar 17, 2003 at 11:37:18AM +0100, Jean-Marc Lasgouttes wrote:
> It would probably be a good idea to run some profiler on this and see
> whether things remain sensible. The only things I would worry about is
> complexity effects (like what happens with large tables).
I'd even expect these t
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> On Sun, Mar 16, 2003 at 07:44:07PM +, John Levon wrote:
>> Continuing in the same vein. Trying to make this stuff somewhat
>> understandable. Note that this probably makes CHANGED_IN_DRAW
>> somewhat slower.
Andre> Have you che
On Sun, Mar 16, 2003 at 07:44:07PM +, John Levon wrote:
> Continuing in the same vein. Trying to make this stuff somewhat
> understandable. Note that this probably makes CHANGED_IN_DRAW
> somewhat slower.
Have you checked whether it is still usable on some older machine?
Apart from that I rea
On Sun, Mar 16, 2003 at 09:30:49PM +0100, Lars Gullik Bj?nnes wrote:
> This one is not as obvious to me as the first one, but it seems to
> make things clearer.
It's really a first step more than anything else. I really want to deal
with all the status() checks in insettext.C somehow (that is, ma
John Levon <[EMAIL PROTECTED]> writes:
| Continuing in the same vein. Trying to make this stuff somewhat
| understandable. Note that this probably makes CHANGED_IN_DRAW
| somewhat slower.
|
| 7 files changed, 95 insertions(+), 130 deletions(-)
|
| Next we see if we can remove the "refresh_y" al
Continuing in the same vein. Trying to make this stuff somewhat
understandable. Note that this probably makes CHANGED_IN_DRAW
somewhat slower.
7 files changed, 95 insertions(+), 130 deletions(-)
Next we see if we can remove the "refresh_y" altogether in the
postRowPaint() case. It should not be
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> please apply
Done.
JMarc
please apply
thanks
john
p.s. shouldn't we have a 1.2.0 branch ?
--
"Yes, I understand your point, but This Is UA, and not some fluffy creche."
- Topper
various.diff.gz
Description: application/gunzip
Hey guys,
I've made a few changes to the structure of the gnome frontend.
Simplified the constructor, moved common functionality into the
GnomeBase class. This patch doesn't fix the problem I've been having
with OK being called twice, I hope to have another look at that this
weekend, but it simp
the hfill change is as pointed out by Michael.
The rest just re-organises the code to remove duplicate code
and make things into smaller more readable functions
thanks
john
--
"Faced with the prospect of rereading this book, I would rather have
my brains ripped out by a plastic fork."
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> I merged some code for startPipe - the fix makes sure :
John> 1) we open the two pipes in the right modes (so we can write to
John> one)
John> 2) that the callback is not registered for both (leading to lyx
John> reading its own INFO:
On Mon, Nov 12, 2001 at 06:27:45PM +0100, Jean-Marc Lasgouttes wrote:
> What does the "fix" part do?
sorry.
I merged some code for startPipe - the fix makes sure :
1) we open the two pipes in the right modes (so we can write to one)
2) that the callback is not registered for both (leading to
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> On Mon, Nov 12, 2001 at 10:27:44AM +0100, Jean-Marc Lasgouttes
John> wrote:
>> I think it was having inPipeName() and outPipeName() to replace all
>> the places where we have explicitely pipename + ".in" in the code.
John> here it is.
On Mon, Nov 12, 2001 at 10:27:44AM +0100, Jean-Marc Lasgouttes wrote:
> I think it was having inPipeName() and outPipeName() to replace all
> the places where we have explicitely
> pipename + ".in"
> in the code.
here it is. I also made lyxserver work again (don't shout at me, it's not
friday
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> (what did you want me to clean up in lyxserver again ? the
John> pipenames somehow ?)
I think it was having inPipeName() and outPipeName() to replace all
the places where we have explicitely
pipename + ".in"
in the code.
JMarc
On Fri, Nov 09, 2001 at 11:19:37AM +0100, Jean-Marc Lasgouttes wrote:
> When I see a patch named 'cleanup' I expect to understand easily what
> it does. Saying that all these --- and +++ are just a reorg og
> GetVisibleRow is enough for me, but it needs to be said.
sorry, I /was/ a bit brief !
>>>>> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> On Thu, Nov 08, 2001 at 12:15:30PM +0100, Jean-Marc Lasgouttes
John> wrote: several cleanups. Lars, I added ::WORKAREA instead of
John> removing the debug.
>> Concerning the helpers you a
On Thu, Nov 08, 2001 at 12:15:30PM +0100, Jean-Marc Lasgouttes wrote:
> John> several cleanups. Lars, I added ::WORKAREA instead of removing
> John> the debug.
> Concerning the helpers you added:
argh, why do people only complain when I've done a changelog ?!!
>
>>>>> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> several cleanups. Lars, I added ::WORKAREA instead of removing
John> the debug.
Concerning the helpers you added:
- isMetaInset should be renamed to isInset (we don't care about meta)
- isE
several cleanups. Lars, I added ::WORKAREA instead of removing the debug.
Can someone apply my lyxserver patch too please ?
thanks
john
--
"This bulletin discusses three security vulnerabilities that are unrelated
except in the sense that both affect ISA Server 2000"
-
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> This cleans up a
John> couple of things mentioned 2 weeks ago.
Since it seems that consensus was that the patch is OK, I applied it.
JMarc
t;[EMAIL PROTECTED]> writes: | |
| Lars> John> Attached is very | John> minor cleanups for mathed and
| Lars> support. | | Applied.
|
| Lars> When we are in the process of cleaning up mathed, run _all_
| Lars> paches to mathed thru me. (aarrgghh...)
|
| Sorry, I thought it was s
>>>>> "Lars" == Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
Lars> Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes: |
Lars> >>>>> "John" == John Levon <[EMAIL PROTECTED]> writes: | |
Lars> John> Attached is very
Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
| >>>>> "John" == John Levon <[EMAIL PROTECTED]> writes:
|
| John> Attached is very
| John> minor cleanups for mathed and support.
|
| Applied.
When we are in the process of cleaning up mathed, ru
>>>>> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> Attached is very
John> minor cleanups for mathed and support.
Applied.
JMarc
On Mon, 26 Feb 2001, Dekel Tsur wrote:
> On Mon, Feb 26, 2001 at 11:42:09AM +0100, Juergen Vigna wrote:
> >
> > On 26-Feb-2001 Dekel Tsur wrote:
> >
> > > If you use the filter frequently then it is better to define an appropriate
> > > converter in the preferences dialog.
> >
> > Yes but I find
On Mon, Feb 26, 2001 at 11:42:09AM +0100, Juergen Vigna wrote:
>
> On 26-Feb-2001 Dekel Tsur wrote:
>
> > If you use the filter frequently then it is better to define an appropriate
> > converter in the preferences dialog.
>
> Yes but I find it sometimes usefull to just try to run some filters
On 26-Feb-2001 Lars Gullik Bjønnes wrote:
> No, but you ran away to reenable code that we really don't want
> reenabled.
Well don't put me in that "we"! (shouldn't that have been a "me")
> I have a feeling you are commenting on my comments just to put in
> another comment.
Should I comment to
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 26-Feb-2001 Lars Gullik Bjønnes wrote:
|
| > Yes, we should. Especially when the features are redundant or near to
| > be reduntant. How much do you thing it'd take to make the export code
| > to the same as the sendto code?
|
| I didn't say it wou
On 26-Feb-2001 Lars Gullik Bjønnes wrote:
> Yes, we should. Especially when the features are redundant or near to
> be reduntant. How much do you thing it'd take to make the export code
> to the same as the sendto code?
I didn't say it would be not a good idea to remove LyXSendto and move it
to
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 26-Feb-2001 Lars Gullik Bjønnes wrote:
|
| > That is just a way of saying: "Delete this we are not going to
| > support it anyway."
|
| ahh I didn't get that!
|
| > And where do you see the KDE/QT support for this or GTK?
| > _all_ xforms dependan
On 26-Feb-2001 Lars Gullik Bjønnes wrote:
> That is just a way of saying: "Delete this we are not going to
> support it anyway."
ahh I didn't get that!
> And where do you see the KDE/QT support for this or GTK?
> _all_ xforms dependant code is going to frontends/xforms eventually.
so we shoul
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 26-Feb-2001 John Levon wrote:
| >
| > Because it is 4x the work to port it to GUI, for each frontend ...
|
| Ahhh, then we should really leave it in GUI and not port it to GUII
| (and may be some other Forms too), so we don't have any work to do at
On 26-Feb-2001 John Levon wrote:
>
> Because it is 4x the work to port it to GUI, for each frontend ...
Ahhh, then we should really leave it in GUI and not port it to GUII
(and may be some other Forms too), so we don't have any work to do at
all, as it's already there!
Jürgen
--
-._-._-
On Mon, 26 Feb 2001, Juergen Vigna wrote:
>
> On 23-Feb-2001 Lars Gullik Bjønnes wrote:
>
> > And you feel that is the right way to support this feature in LyX?
>
> It is just a custom filter on different output-types which you can use
> on the fly. I think we can have some things which are us
On 26-Feb-2001 Dekel Tsur wrote:
> If you use the filter frequently then it is better to define an appropriate
> converter in the preferences dialog.
Yes but I find it sometimes usefull to just try to run some filters and
sometimes the params of the call change so I would have to reedit it
in p
On Mon, Feb 26, 2001 at 09:55:08AM +0100, Juergen Vigna wrote:
>
> On 23-Feb-2001 Dekel Tsur wrote:
>
> > Why. What can you do with the form that you can't with the new export code?
>
> I don't have to edit preference files and I can do it on the fly with
> whatever filter I want!
If you use t
On 23-Feb-2001 Lars Gullik Bjønnes wrote:
> Why... you don't use it anyway.
That's not true! I use it quite a lot (it's just that we here still use
1.0.4 ;) so I didn't notice this in the 1.1.x version.
> And why can't this be handled by the more general export code instead?
Well if you can s
On 23-Feb-2001 Lars Gullik Bjønnes wrote:
> And you feel that is the right way to support this feature in LyX?
It is just a custom filter on different output-types which you can use
on the fly. I think we can have some things which are usable generally!
Also you (f.ex) can use a2ps to make what
On 23-Feb-2001 Dekel Tsur wrote:
> Why. What can you do with the form that you can't with the new export code?
I don't have to edit preference files and I can do it on the fly with
whatever filter I want!
Jürgen
--
-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._
D
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 23-Feb-2001 John Levon wrote:
| >
| > How ? What's the code path that reaches MenuSendto() ?
| > Where is LFUN_MENUSENDTO handled ?
|
| Ohh I see what you mean! Someone disabled this! I really want
| this enabled and will do so as soon as I've some
On Fri, Feb 23, 2001 at 05:06:13PM +0100, Juergen Vigna wrote:
>
> On 23-Feb-2001 John Levon wrote:
> >
> > How ? What's the code path that reaches MenuSendto() ?
> > Where is LFUN_MENUSENDTO handled ?
>
> Ohh I see what you mean! Someone disabled this! I really want
> this enabled and will do
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 23-Feb-2001 Lars Gullik Bjønnes wrote:
|
| > I'd say yes... I'll let others decide that one.
| > (I have never used it...)
|
| Definitively NO! Why should we remove this functionallity?
| I use it for example to print series of letters out of LyX!
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 23-Feb-2001 John Levon wrote:
| >
| > Attached is very minor cleanups for mathed and support.
| >
|
| This seems also good to me!
mmm...yes
Lgb
On 23-Feb-2001 John Levon wrote:
>
> How ? What's the code path that reaches MenuSendto() ?
> Where is LFUN_MENUSENDTO handled ?
Ohh I see what you mean! Someone disabled this! I really want
this enabled and will do so as soon as I've some time!
Jürgen
--
-._-._-._-._-._-._-._-._-._-._
On Fri, 23 Feb 2001, Juergen Vigna wrote:
>
> On 23-Feb-2001 Lars Gullik Bjønnes wrote:
>
> > I'd say yes... I'll let others decide that one.
> > (I have never used it...)
>
> Definitively NO! Why should we remove this functionallity?
> I use it for example to print series of letters out of Ly
On 23-Feb-2001 Lars Gullik Bjønnes wrote:
> I'd say yes... I'll let others decide that one.
> (I have never used it...)
Definitively NO! Why should we remove this functionallity?
I use it for example to print series of letters out of LyX!
Jürgen
--
-._-._-._-._-._-._-._-._-._-._-._-._-
John Levon <[EMAIL PROTECTED]> writes:
| This cleans up a couple of things mentioned 2 weeks ago.
This is ok.
| p.s. can we remove LyXSendTo.C ???
I'd say yes... I'll let others decide that one.
(I have never used it...)
Lgb
Juergen Vigna <[EMAIL PROTECTED]> writes:
| On 23-Feb-2001 John Levon wrote:
| >
| > This cleans up a couple of things mentioned 2 weeks ago.
|
| This seems good to me, Lars what do you say?
Just give me time to have a look.
Lgb
On 23-Feb-2001 John Levon wrote:
>
> Attached is very minor cleanups for mathed and support.
>
This seems also good to me!
Jürgen
--
-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._
Dr. Jürgen VignaE-Mail: [EMAIL PROTECTED]
Italienallee 13/N
Attached is very minor cleanups for mathed and support.
john
--
On Year 2000 compliance :
"Unfortunately, it is not possible to gather similar
assurances on the compliance of viruses."
- Dr. Solomon's RIP
diff -u -p -r1.40 ChangeLog
--- src/mathed/ChangeLog2
On 23-Feb-2001 John Levon wrote:
>
> This cleans up a couple of things mentioned 2 weeks ago.
This seems good to me, Lars what do you say?
Jürgen
--
-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._
Dr. Jürgen VignaE-Mail: [EMAIL PROTECTED]
Italienallee 13/
This cleans up a couple of things mentioned 2 weeks ago.
john
p.s. can we remove LyXSendTo.C ???
--
On Year 2000 compliance :
"Unfortunately, it is not possible to gather similar
assurances on the compliance of viruses."
- Dr. Solomon's RIP
Index: src/ChangeLog
===
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> This is the last non-substantial KDE patch I promise !
John> It includes some changes from Angus like #including config.h. I
John> am going to the tattoo parlour now.
Applied.
JMarc
This is the last non-substantial KDE patch I promise !
It includes some changes from Angus like #including config.h. I am going
to the tattoo parlour now.
thanks
john
--
"If you can't say anything good about someone, sit right here by me."
- Alice Roosevelt Longworth
kdeangus.diff.
On Thu, 30 Nov 2000, Allan Rae wrote:
> Seems some systems implementation of sort respond slightly differently to
> the -f and -d flags.
>
> Allan. (ARRae)
RH Linux 6.2
p40:1001 rpm -qf `which sort`
textutils-2.0e-6
john
--
"Creating laws which cannot be universally enforced leads to arbit
On Wed, 29 Nov 2000, John Levon wrote:
> p.s. is there any chance POTFILES.in can get cvs removed ? It is very
> galling having to delete it each time from the diff
Then don't delete it.
It is possible to build POTFILES.in from autogen.sh (if we copy it back in
there from po/Makefile.in.in (not
The attached patch is three little cleanups intended for LyX 1.1.6.
thanks
john
p.s. is there any chance POTFILES.in can get cvs removed ? It is very
galling having to delete it each time from the diff
--
"We signed to play until the day we died, and we did."
- Jimmy Greav
63 matches
Mail list logo