Vincent van Ravesteijn wrote:
> I like it, but I can imagine that others wouldn't.
Well ...
> Small glitch, when you choose None, one of the dialog buttons reads:
> ..assign to ' ' ?
I have added a specific message for this case, and committed.
Jürgen
rgheck wrote:
> Actually, I realized there was a much better way to do that generally,
> and committed it at r21890 and r21891.
>
> Jurgen, this should also go to branch, OK?
Yes, OK.
Jürgen
Jürgen Spitzmüller wrote:
> Jürgen Spitzmüller wrote:
> > > yes, quick test looks good. maybe i would kill the tooltip for
> > > "assigned to group" label. you can put it in i think.
> >
> > I've removed that tooltip, and commit now.
>
> attached is the backport to branch.
>
> Pavel, OK?
as you
>> When there is no remaining problem, this should go in.
>
> I agree.
There was still a problem: I escaped the "#" character in the URL field to "\#". But this was wrong,
in the URL field is mustn't be escaped, but in the name field. We got yesterday a bug report on the
lyx-users list about th
rgheck wrote:
I recently committed some "improvements" to InsetCitation, designed to
display things like:
G\"odel
using the corresponding unicode. It has now occurred to me, though,
that this can cause problems with searching, since one will now need
to search not for G\"odel but for some
I recently committed some "improvements" to InsetCitation, designed to
display things like:
G\"odel
using the corresponding unicode. It has now occurred to me, though, that
this can cause problems with searching, since one will now need to
search not for G\"odel but for something else. I'm
Vincent van Ravesteijn wrote:
With this patch, LyX fills the command buffer history with the
commands that were used before.
Remarks or objections ?
I remark that this is very cool.
rh
With this patch, LyX fills the command buffer history with the commands
that were used before.
Remarks or objections ?
Vincent
Index: src/frontends/qt4/GuiCommandBuffer.cpp
===
--- src/frontends/qt4/GuiCommandBuffer.cpp (revis
Guenter Milde ha scritto:
It depends on what the user expects.
Currently,
* if you copy/kill from *inside* a math box, you will get math that
inserts correct into another math box.
* if you copy/kill a complete math box (or text containing a math box), you
will get text that inserts correc
Jürgen Spitzmüller schreef:
Vincent van Ravesteijn wrote:
> No, it didn't change with the UI. But, I did lose the symmetry. Creating
> a new group now needs an extra explicit step (in comparison to 1.6.1 and
> the combobox), while deleting a group is still an automatic process.
> This somehow fe
Vincent van Ravesteijn wrote:
> No, it didn't change with the UI. But, I did lose the symmetry. Creating
> a new group now needs an extra explicit step (in comparison to 1.6.1 and
> the combobox), while deleting a group is still an automatic process.
> This somehow feels uncomfortable.
try the att
Vincent van Ravesteijn wrote:
> It is nice to have a new group button, but it is less fun that a group
> without any images disappears. Would it be an idea to give a warning that a
> certain group becomes empty
also you will need additional changes to code for removing graphics inset from
doc.
Jürgen Spitzmüller schreef:
Pavel Sanda wrote:
> > I think to achieve this (correctly), we will need to store the
groups in
> > the document params (which is a file format change).
>
> my view from the very begining. to produce what you want needs to switch
> from group to template philosophy.
Jürgen Spitzmüller wrote:
> Pavel Sanda wrote:
> > > I think to achieve this (correctly), we will need to store the groups in
> > > the document params (which is a file format change).
> >
> > my view from the very begining. to produce what you want needs to switch
> > from group to template philos
Pavel Sanda wrote:
> > I think to achieve this (correctly), we will need to store the groups in
> > the document params (which is a file format change).
>
> my view from the very begining. to produce what you want needs to switch
> from group to template philosophy.
But this didn't change with the
Jürgen Spitzmüller wrote:
> Vincent van Ravesteijn wrote:
> > It is nice to have a new group button, but it is less fun that a group
> > without any images disappears. Would it be an idea to give a warning
> > that a certain group becomes empty and ask the user whether he would
> > like to retain t
Vincent van Ravesteijn wrote:
> It is nice to have a new group button, but it is less fun that a group
> without any images disappears. Would it be an idea to give a warning
> that a certain group becomes empty and ask the user whether he would
> like to retain the group or whether the group can be
Vincent van Ravesteijn wrote:
> I just forgot adding 'update', but it is basically the same. And I was
> trying to add a checkout command. It works quite well, except that LyX does
> not which file top open. Maybe we would like another flag indicating that
> we should automatically open a FileOp
Jürgen Spitzmüller schreef:
Pavel Sanda wrote:
> i wonder why filename->setText(current_filename) & QString
current_filename
> = filename->text() gymnastics is needed; isn't this done by
par.filename =
> params_.filename; ?
The rationale is: if you change the filename of an existing graphics
Jürgen Spitzmüller wrote:
> > yes, quick test looks good. maybe i would kill the tooltip for
> > "assigned to group" label. you can put it in i think.
>
> I've removed that tooltip, and commit now.
attached is the backport to branch.
Pavel, OK?
Jürgen
Index: src/frontends/qt4/GuiGraphics.cpp
===
Pavel Sanda wrote:
> ok, is par.filename = params_.filename; needed now ?
No.
Jürgen
Commit:
vc-command DS "." "TortoiseProc /command:commit /path:$$p"
Revert:
vc-command DR "." "TortoiseProc /command:revert /path:$$p"
Checkout (does not really work yet):
vc-command R "." "TortoiseProc /command:checkout /path:$$p"
don't be decieved by the terminology, you want svn updat
Jürgen Spitzmüller wrote:
> Pavel Sanda wrote:
> > i wonder why filename->setText(current_filename) & QString current_filename
> > = filename->text() gymnastics is needed; isn't this done by par.filename =
> > params_.filename; ?
>
> The rationale is: if you change the filename of an existing grap
Pavel Sanda wrote:
> i wonder why filename->setText(current_filename) & QString current_filename
> = filename->text() gymnastics is needed; isn't this done by par.filename =
> params_.filename; ?
The rationale is: if you change the filename of an existing graphics without
applying, and then assig
sp...@lyx.org wrote:
> Author: spitz
> Date: Fri Jan 16 15:54:25 2009
> New Revision: 28184
>
> URL: http://www.lyx.org/trac/changeset/28184
> Log:
> * GuiGraphics.{cpp,h}:
> * GraphicsUi.ui:
> - polish UI for graphics groups.
> +
> + // filename might have been changed
> + QSt
Vincent van Ravesteijn wrote:
> For using TortoiseSVN, the following commands are needed. (Maybe something
> for on a wiki page if it exists):
or Customization.lyx.
> Commit:
> vc-command DS "." "TortoiseProc /command:commit /path:$$p"
>
> Revert:
> vc-command DR "." "TortoiseProc /command:rever
Pavel Sanda wrote:
> yes, quick test looks good. maybe i would kill the tooltip for
> "assigned to group" label. you can put it in i think.
I've removed that tooltip, and commit now.
BTW I think it would be a good idea to indicate in the dialog's header if a
group is used, because then the dialo
Dear LyXers,
I wonder whether it would be possible to cache the auxiliary files from a
latex run, so that subsequent runs will be faster also after closing and
re-opening LyX. (no second/third run if the aux files are still up to
date)
This could be of special use if we were to introduce a real s
attached the new patch.
pavel
Some notions from a happy user (=me).
For using TortoiseSVN, the following commands are needed. (Maybe
something for on a wiki page if it exists):
Commit:
vc-command DS "." "TortoiseProc /command:commit /path:$$p"
Revert:
vc-command DR "." "TortoiseProc /c
Jean-Marc Lasgouttes wrote:
> You are definitely right. The return value should be ::setenv(...) == 0,
> like for putenv.
I just committed a change to trunk. I also chenged the thir argument to an
int.
I'll commit to branch as well in a minute.
Jürgen
Jürgen Spitzmüller wrote:
> Pavel Sanda wrote:
> > > I understand correctly, is wrong: in the current approach, the graphics
> > > params are changed without the user pressing apply (simply if the group
> > > widget's content is changes).
> >
> > no, they are not changed without apply.
>
> Yes, I
Jürgen Spitzmüller writes:
> Jean-Marc, is this OK, or should we rather try to make the backend aware of
> LC_NUMERIC? If so, I need your help.
While I am not sure about whre you are headed, here is a patch that
might help in the translation dept. It gets rid of the
setDefaultLanguage thing, and
Pavel Sanda wrote:
> > I understand correctly, is wrong: in the current approach, the graphics
> > params are changed without the user pressing apply (simply if the group
> > widget's content is changes).
>
> no, they are not changed without apply.
Yes, I misunderstood why the reloading of the par
Jürgen Spitzmüller writes:
> BTW, I noticed that LyX::setRcGuiLanguage() always reports a failure
> when trying to set a different language from rc.gui_language. My
> inpression is that this report is wrong. Looking at Environment.cpp, I
> see the bool SetEnv return ::setenv(name.c_str(), encoded.
Jürgen Spitzmüller wrote:
> I understand correctly, is wrong: in the current approach, the graphics
> params
> are changed without the user pressing apply (simply if the group widget's
> content is changes).
no, they are not changed without apply.
pavel
Also sprach Jürgen Spitzmüller:
> > there is one serious bug with your patch though - you need to load group
> > settings into the dialog when selected in the combobox, otherwise you
> > destroy group settings by the current one after apply.
>
> I don't understand. Can you provide a recipe?
OK, I
Roland Clobus wrote:
> > Pavel Sanda wrote:
> > you are right, that there is a bug that $$p is not used. however this
> > patch
> > looks suspicious from the first sight, as $$i is stuffed from infile2
> > while
> > your $$p is stuffed from orig_from. according to the doc $$p should
> > originate
>
Pavel Sanda wrote:
> yes i understood your plan :) this way when you create new group and then
> click on another image without applying the group is gone. but i dont care
> much about it, if you like it this way, we can use it.
Yes, I prefer it that way. On the contrary, I think the current behav
"Roland Clobus" writes:
>> Just a question: is this with MSVC or configure/mingw?
>
> MSVC2008, as recommended in INSTALL.Win32
Not my department, then :)
Thanks.
JMarc
Jürgen Spitzmüller wrote:
> Pavel Sanda wrote:
> > because there is no list of groups themselves (all this info is always
> > gathered from scanning all images in the document) and there is nothing
> > reasonable to be done as an action after pushing this button. one has to
> > apply settings of th
Vincent van Ravesteijn wrote:
> Why not something like "" then ?
>
> If I don't get the intention immediately, it might not be clear to
> everyone.
FWIW, in my proposal, the combo has an item "None".
Jürgen
Pavel Sanda schreef:
Vincent van Ravesteijn - TNW wrote:
> A. There is always an empty item at top of the list.
intended for canceling the group
Why not something like "" then ?
If I don't get the intention immediately, it might not be clear to everyone.
Vincent
Vincent van Ravesteijn - TNW wrote:
> A. There is always an empty item at top of the list.
intended for canceling the group
> B. Why is the group name box disabled if 'Show in LyX' is unchecked ?
independent bug
> C. Do the following:
> . Insert Graphics
> . Select an image
> . Enter some name
Pavel Sanda wrote:
> because there is no list of groups themselves (all this info is always
> gathered from scanning all images in the document) and there is nothing
> reasonable to be done as an action after pushing this button. one has to
> apply settings of the whole dialog. if you only add the
Jürgen Spitzmüller wrote:
> Pavel Sanda wrote:
> > > > Add editable combobox for groups in graphics dialogs as discussed in
> > > > http://www.mail-archive.com/lyx-us...@lists.lyx.org/msg70194.html
> > >
> > > i have tested this myself
> >
> > Juergen?
>
> I have not tested it thouroughly, neither
> Yes, it would feel much better. But that is the reason that I added the
> following sentence to the commit log: "This is in the same style as the
> replacements made for math-insert commands". When considering the
> math-insert commands the findPng function is used (Why not for all
> commands ??,
>> I did this in http://www.lyx.org/trac/changeset/27977. Now, the icons
>> should be named:
>>
>> paragraph-params_backslashalign_block
>> ..etc.
>
>wouldn't be better to use some dash e.g. ('\\', "_backslash_")
>for better parsing of filenames?
>
>pavel
>
Yes, it would feel much better. But t
> Author: sanda
> Date: Wed Jan 14 16:10:15 2009
> New Revision: 28160
>
> URL: http://www.lyx.org/trac/changeset/28160
> Log:
> Add editable combobox for groups in graphics dialogs as discussed in
> http://www.mail-archive.com/lyx-us...@lists.lyx.org/msg70194.html
>
>i have tested this myself,
>Also, is there a rationale as to which ones get the
>and which ones don't? I'm guessing there is, but I couldn't
>figure it out.
The idea was that the 'Help' items would tell the user what he should do
if he wants to use a specific feature. Thus, Insert->Branch would tell
the user to 'set a br
Pavel Sanda wrote:
> > > Add editable combobox for groups in graphics dialogs as discussed in
> > > http://www.mail-archive.com/lyx-us...@lists.lyx.org/msg70194.html
> >
> > i have tested this myself
>
> Juergen?
I have not tested it thouroughly, neither carefully read the patch, but from a
quick
Uwe Stöhr wrote:
> You can use such strange paths as they are now with my patch. As it is,
> surely a bit rash, in trunk, I would like when you could give it a try and
> report back when there are still problems I was not aware of, because I
> don't have access to Unix.
I tested it, and it actuall
>> The Edit->Math menu item is _always_ enabled. This is caused by the
>> command "math-insert \textstyle"...
>>
>> The patch fixes this.
>>
>> Objections ?
>
>I'd prefer a name like math-font, since textstyle makes me
>think of text-in-math-mode.
I called it math-font-style now (hope it makes
Pavel Sanda wrote:
> Jürgen Spitzmüller wrote:
> > It is supposed to respect the user's settings. However, our language
> > setting (GuiApplication::setGuiLanguage()) is broken. It always uses
> > Messages::defaultLanguage(), which overwrites manual LC_NUMERIC changes
> > (the latter might be a bug
Jeam-Marc Lasgouttes writes:
> "Roland Clobus" writes:
> > I found out that LyX will not build under Windows XP SP3 (Branch
1.6)
> > when the directory for the source contains spaces (I had the sources
> > in C:\Documents and Settings\Myname\LyX)
> Just a question: is this with MSVC or configure
"Roland Clobus" writes:
> Hello,
>
> I've created a small patch to make LyX configure correctly on my
> computer.
>
> I found out that LyX will not build under Windows XP SP3 (Branch 1.6)
> when the directory for the source contains spaces (I had the sources in
> C:\Documents and Settings\Myname\
Pavel Sanda writes:
> ok i changed it to the real number with not problematic binary expansion
> after decimal point.
Clever.
JMarc
> > Roland Clobus wrote:
> > ...
> > In the
> > code (Converter.cpp) I found "$$p" which was declared but not in
use.
> > This patch places the path to the current LyX file in $$p, which can
> > be used by the converter to reach the images.
> Pavel Sanda wrote:
> you are right, that there is a bug
57 matches
Mail list logo