e hours to move
spl-foreach hooking into the engine.
Here is the diff:
http://marcus-boerger.de/php/ext/ze2/ze2-spl-20030630.diff.tgz
Here are modified tests:
http://marcus-boerger.de/php/ext/ze2/ze2-spl-tests-20030630.tgz
Here is the diff needed for sqlite:
http://marcus-boerger.de/php/ext/ze2/ze2-
It would be alot nicer if you could provide the majority of these as
object variables (and/or) functions, it would enable
print_r(new PHP_Function('counter'));
which would save a lot of messing around, and writing code for general
queries..
Regards
Alan
$obj = new PHP_Function("counter");
print
Hello Andi,
you asked for a spl patch against ZE2. Ok, i spent some hours to move
spl-foreach hooking into the engine.
Here is the diff:
http://marcus-boerger.de/php/ext/ze2/ze2-spl-20030630.diff.tgz
Here are modified tests:
http://marcus-boerger.de/php/ext/ze2/ze2-spl-tests-20030630.tgz
Here is
Ya, no problem, Ill include that with my doc work.
-Jason
On Mon, 2003-06-30 at 14:45, Davey wrote:
> I have been working on the sockets and pcntl docs somewhat, there is a
> bug open (which I opened in the first place) here
> http://bugs.php.net/23849, it shows my progress - do you want to tak
Done. :)
-Sterling
On Mon, 2003-06-30 at 17:25, Andi Gutmans wrote:
> Nuke along.
>
> At 03:55 PM 30/6/2003 -0400, Sterling Hughes wrote:
> >Hey,
> >
> >Edin pointed out that we no longer need to reserve the "main" keyword in
> >zend engine 2. As the main:: keyword was only reserved for the mai
Nuke along.
At 03:55 PM 30/6/2003 -0400, Sterling Hughes wrote:
Hey,
Edin pointed out that we no longer need to reserve the "main" keyword in
zend engine 2. As the main:: keyword was only reserved for the main::
namespace in the first place. We no longer have namespaces, therefore
we no longer
Hey,
Edin pointed out that we no longer need to reserve the "main" keyword in
zend engine 2. As the main:: keyword was only reserved for the main::
namespace in the first place. We no longer have namespaces, therefore
we no longer need to reserve main.
Attached is a patch to zend_compile.c that
Jason Greene wrote:
All,
I am sure many of you have noticed that I haven't been around for about
the last 6 months. This was mainly due to a large amount of commitment
required for a large project by my employer, and other events in my life
that limited my free time.
I will be catching back up in
On Mon, 30 Jun 2003, George Schlossnagle wrote:
> Oh. Should be fine now. Plus the naming change for the class.
Why aren't you using PHP_METHOD() macro?
-Andrei
* Entropy isn't what it used to be. *
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.
On Monday, June 30, 2003, at 03:10 PM, Andi Gutmans wrote:
At 02:01 PM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 02:48 PM, Andi Gutmans wrote:
At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrot
Andi Gutmans wrote:
> Reflection_Function
+1
--
Sebastian Bergmann
http://sebastian-bergmann.de/ http://phpOpenTracker.de/
Das Buch zu PHP 5: http://professionelle-softwareentwicklung-mit-php5.de/
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visi
At 02:01 PM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 02:48 PM, Andi Gutmans wrote:
At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:
A look in sqlite answered my question - I should be using
At 07:54 PM 30/6/2003 +0200, Marcus Börger wrote:
AG> Can you please post a patch for the foreach() stuff (i.e. collection and
AG> iterator)?
AG> I don't exactly remember what you mean by array hooking. Is that what
AG> Andrei wants or does it also include a user-land interface to overload?
Please
On Monday, June 30, 2003, at 02:48 PM, Andi Gutmans wrote:
At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:
A look in sqlite answered my question - I should be using
ZEND_NAMED_FE. Will update patch momentarily.
Updated
Hello Jon,
Monday, June 30, 2003, 9:58:07 AM, you wrote:
JP> Everything is working well for me now, and I'd prefer to keep it that
JP> way.
If you did had a closer look then you'd've find out that essential things are
not working. Did you try the new oo stuff?
JP> I'm wary of adding new featur
Hello Andi,
Monday, June 30, 2003, 5:58:42 PM, you wrote:
AG> At 08:54 AM 30/6/2003 +0200, Marcus Börger wrote:
>>Hello Andi,
>>
>>Monday, June 30, 2003, 8:10:30 AM, you wrote:
>>
>>AG> At 07:43 AM 30/6/2003 +0200, Andi Gutmans wrote:
>> >>Hey,
>> >>
>> >>In my opinion beta 1 should be labeled as
At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:
A look in sqlite answered my question - I should be using
ZEND_NAMED_FE. Will update patch momentarily.
Updated now.
I still get the old .diff via the URL you posted. Can yo
Oriol,
try valgrind (aka memory checker) and you will hopefully find where your
problem resides
Andrey
- Original Message -
From: "Oriol" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Monday, June 30, 2003 7:13 PM
Subject: [PHP-DEV] Simple question
>
> Hello! I'm trying to writ
Hello! I'm trying to write a trim function which expects a zval* of type
string, as follows:
int zstrtrim(zval *z)
{
char *ptr1 = Z_STRVAL_P(z), *ptr2;
if (Z_STRLEN_P(z) == 0) return;
ptr2 = &ptr1[Z_STRLEN_P(z)-1];
while (*ptr1 != 0)
{
if (*ptr1 > ' ') break;
On Mon, 30 Jun 2003, Elfyn McBratney wrote:
> On Mon, 30 Jun 2003, Elfyn McBratney wrote:
>
> > Bringing the docs for the DOM extension up-to-date, and working on
> > the DOM extension itself. so phpdoc and/or ext/dom :)
>
> Forgot to mention, Sascha said to get an account. :)
Sorry for the noice
On Mon, 30 Jun 2003, Elfyn McBratney wrote:
> Bringing the docs for the DOM extension up-to-date, and working on
> the DOM extension itself. so phpdoc and/or ext/dom :)
Forgot to mention, Sascha said to get an account. :)
Elfyn
--
--
PHP Internals - PHP Runtime Development Mailing List
To un
On Mon, 30 Jun 2003, George Schlossnagle wrote:
> On Monday, June 30, 2003, at 12:04 PM, Andi Gutmans wrote:
>
> >I must be thick. I don't quite understand how the source relates to
> >what is described in the .png. Take for example the following from the
> >api.c file:
>
> I talked this over
Bringing the docs for the DOM extension up-to-date, and working on the DOM extension
itself. so phpdoc and/or ext/dom :)
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Mon, 30 Jun 2003, Elfyn McBratney wrote:
> On Mon, 30 Jun 2003, George Schlossnagle wrote:
>
> > On Monday, June 30, 2003, at 12:04 PM, Andi Gutmans wrote:
> >
> > > I must be thick. I don't quite understand how the source relates to
> > > what is described in the .png. Take for example the fo
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:
A look in sqlite answered my question - I should be using
ZEND_NAMED_FE. Will update patch momentarily.
Updated now.
-- George Schlossnagle
-- Principal Consultant
-- OmniTI Computer Consulting, Inc.
-- +1.410.872.4910 x202
-- 1
On Mon, 30 Jun 2003, George Schlossnagle wrote:
> On Monday, June 30, 2003, at 12:04 PM, Andi Gutmans wrote:
>
> > I must be thick. I don't quite understand how the source relates to
> > what is described in the .png. Take for example the following from the
> > api.c file:
>
> I talked this over
On Monday, June 30, 2003, at 11:32 AM, George Schlossnagle wrote:
On Monday, June 30, 2003, at 12:04 PM, Andi Gutmans wrote:
I must be thick. I don't quite understand how the source relates to
what is described in the .png. Take for example the following from
the api.c file:
I talked this ove
On Monday, June 30, 2003, at 12:04 PM, Andi Gutmans wrote:
I must be thick. I don't quite understand how the source relates to
what is described in the .png. Take for example the following from the
api.c file:
I talked this over with Marcus. The FE/FALIAS pairs are designed to
avoid namespace
On Mon, 30 Jun 2003, Edin Kadribasic wrote:
> Hi guys,
>
> Could we please stop playing around with the CVSROOT/modules? The
> win32 snapshot builder is broken because someone decided to remove
> php5 alias from the file on disk instead of commiting it to CVSROOT.
>
> I need that alias, or php-src
All,
I am sure many of you have noticed that I haven't been around for about
the last 6 months. This was mainly due to a large amount of commitment
required for a large project by my employer, and other events in my life
that limited my free time.
I will be catching back up in the next few weeks,
I must be thick. I don't quite understand how the source relates to what is
described in the .png. Take for example the following from the api.c file:
static zend_function_entry php_function_functions[] = {
ZEND_FE(php_function, NULL) ZEND_FE(php_function_isinternal, NULL)
ZEND_FALIAS(isinterna
At 08:54 AM 30/6/2003 +0200, Marcus Börger wrote:
Hello Andi,
Monday, June 30, 2003, 8:10:30 AM, you wrote:
AG> At 07:43 AM 30/6/2003 +0200, Andi Gutmans wrote:
>>Hey,
>>
>>In my opinion beta 1 should be labeled as a beta. The fact that we are
>>fixing a few features doesn't mean it's alpha. I kn
Translating the PHP manual to Arabic.
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Mon, 30 Jun 2003, Zeev Suraski wrote:
> Yes, we will.
Good.
-Andrei
* if you hold a unix shell to your ear, do you hear the c? *
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
At 16:10 30/06/2003, Andrei Zmievski wrote:
I know we're all giddy with the idea of having a PHP 5 Beta out the
door, but I want to ask once again: are we going to have support for
indexers, aka OE_IS_ARRAY style overloading, before the final release?
Yes, we will.
Zeev
--
PHP Internals - PHP Run
I know we're all giddy with the idea of having a PHP 5 Beta out the
door, but I want to ask once again: are we going to have support for
indexers, aka OE_IS_ARRAY style overloading, before the final release?
Without it, a lot of PHP-GTK programs will stop to work, thus exposing
the fact the PHP 5 i
New forum, dedicated to XML/PHP, from the PHP/XML based site xmlmania.com
(main site currently in development).
Completely new, join NOW!
--
PHP Announcements Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php
On Mon, 30 Jun 2003, Uwe Schindler wrote:
> I think your problem with that comes from the fact, that in PHP4 the apache
> sapi module define this variable in the wrong way (mistake of original
> programmer). But a lot of scripts depend on that so we did not fix it in
> the PHP_4_3 branch. I thi
I think your problem with that comes from the fact, that in PHP4 the apache
sapi module define this variable in the wrong way (mistake of original
programmer). But a lot of scripts depend on that so we did not fix it in
the PHP_4_3 branch. I think there is a former discussion about this in this
no thats right.
PATH_TRANSLATED ist the translated PATH_INFO variable, which is after the
scriptname till the "?". Look into CGI spec. Other SAPI modules to the
same: http://134.1.2.11/test.php/pathinfotest?item=value
Uwe
At 11:57 30.06.2003 +0200, you wrote:
Hey,
with this URL: http://dru-nl/
Sascha,
I believe this is directed at you (please do correct me if I'm
wrong[*]). If you didn't manage to gather support to remove the php5
alias, which you didn't, please refrain from doing it on your own. The
fact you chose to hide by doing it using vi instead of using CVS
illustrates that
As of latest PHP cvs and PHP 5.0.0beta1 one has to specify both
--with-libxml-dir=/myprefix --with-simplexml=/myprefix
to enable libxml in user defined prefix. It would be nice
if --with-libxml-dir would suffice.
The problem can be solved by moving
PHP_ARG_WITH(libxml-dir, libxml install dir,
Hi guys,
Could we please stop playing around with the CVSROOT/modules? The
win32 snapshot builder is broken because someone decided to remove
php5 alias from the file on disk instead of commiting it to CVSROOT.
I need that alias, or php-src-ze2 as it was before it was made
"consistent".¨
Edin
Hey,
with this URL: http://dru-nl/b.php/1/r/2/1/1
I get back the following server variables (PHP 5.0.0b1, apache 1
module):
'REQUEST_URI' => '/b.php/1/r/2/1/1'
'SCRIPT_NAME' => '/b.php'
'PATH_INFO' => '/1/r/2/1/1'
'PATH_TRANSLATED' => '/home/httpd/html/dru/modules/user/1/r/2/1/1'
'PHP_S
On Mon, 30 Jun 2003, Zeev Suraski wrote:
> At 08:31 30/06/2003, Derick Rethans wrote:
> >On Sun, 29 Jun 2003, Rasmus Lerdorf wrote:
> >
> > > feature-complete full-steam ahead for release. And that means bug fixes
> > > only from here on and it also means a PHP_5_0 branch.
>
> It doesn't mean th
On Sun, Jun 29, 2003 at 11:14:38PM -0400, Sterling Hughes wrote:
> > > Without going into detail on any of these specific items, I think that
> > > the only work that should be undertaken between now and the release of
> > > PHP 5 is cleanup and bug fixing. There's plenty of that to go around,
>
At 08:20 30/06/2003, Sterling Hughes wrote:
I refer you to the jargon file, which is about as good a definition that
you can get:
http://info.astrian.net/jargon/terms/b/beta.html
"Mostly working, but still under test; usu. used with `in': `in beta'.
In the Real World, systems (hardware or software
At 08:31 30/06/2003, Derick Rethans wrote:
On Sun, 29 Jun 2003, Rasmus Lerdorf wrote:
> I agree. I think the beta was extremely premature, but now that it is out
> we are on a release track as far as I am concerned. Beta in my view means
> feature-complete full-steam ahead for release. And that
# [EMAIL PROTECTED] / 2003-06-29 14:53:40 -0400:
> On Sun, 2003-06-29 at 14:19, Sterling Hughes wrote:
> >
> > - Due to issues surrounding the MySQL 4.0 license, the MySQL libraries
> > are no longer bundled with PHP. For more information on these
> > licensing changes please see the MyS
We have taken some steps to clean up our release process, but let's nail
it down completely to avoid arguments every time we release something.
Can we agree on the following?
All new development happens on HEAD. Snapshot and alpha releases are
released right from the development branch with a TAG
Hello Rasmus,
Monday, June 30, 2003, 3:11:03 AM, you wrote:
RL> I agree. I think the beta was extremely premature, but now that it is out
RL> we are on a release track as far as I am concerned. Beta in my view means
RL> feature-complete full-steam ahead for release. And that means bug fixes
RL
> Hello,
>
> On 06/29/2003 04:16 PM, Sascha Schumann wrote:
> - Due to issues surrounding the MySQL 4.0 license, the MySQL libraries
> are no longer bundled with PHP. For more information on these
> licensing changes please see the MySQL licensing policy [1]
>
> [1]
Hello Sterling,
Monday, June 30, 2003, 7:20:37 AM, you wrote:
SH> [...]
SH> PHP 5 is almost there, and prematurely imposing rules on ourselves
SH> because we now labeled a "beta" seems like an unwise choice. The
SH> majority of the changes marcus is talking about are not far reaching,
SH> and a
53 matches
Mail list logo