Re: [Harbour] Compile defines

2008-06-03 Thread Randy Portnoff
Hi Viktor, IMO, all environment vars and compiler switches should default for maximum performance - If a user wants profiling, tracing, debugging, etc., they can enable them as required. In general I don't agree that we should aim for maximum performance. Sorry, I forgot about the binary bui

Re: [Harbour] Compile defines

2008-06-03 Thread Szakáts Viktor
Hi Randy, IMO, all environment vars and compiler switches should default for maximum performance - If a user wants profiling, tracing, debugging, etc., they can enable them as required. In general I don't agree that we should aim for maximum performance. Performance is not the only aspect

Re: [Harbour] Compile defines

2008-06-03 Thread Randy Portnoff
Hi Viktor, IMO, all environment vars and compiler switches should default for maximum performance - If a user wants profiling, tracing, debugging, etc., they can enable them as required. Randy. At 04:43 PM 6/2/2008, you wrote: What do you think of making this a runtime option? (a Set())

Re: [Harbour] Compile defines

2008-06-02 Thread Szakáts Viktor
Hi Przemek, Just like for most of others. Probably only HB_GUI is HB_NO_PROFILER are important because pending code is executed in each HVM loop (for each PCODE). I'll make speed test for HB_GUI to check current difference. #define N_LOOP 1 proc main() local t, i t:=secondsCP

Re: [Harbour] Compile defines

2008-06-02 Thread Przemyslaw Czerpak
On Mon, 02 Jun 2008, Szakáts Viktor wrote: Hi Viktor, > >Just like for most of others. Probably only HB_GUI is HB_NO_PROFILER > >are important because pending code is executed in each HVM loop (for > >each PCODE). I'll make speed test for HB_GUI to check current > >difference. #define N_LOO

Re: [Harbour] Compile defines

2008-06-02 Thread Szakáts Viktor
What do you think of making this a runtime option? (a Set()) The idea of using this macro was eliminating all possible overhead from main HVM loop. Using and RT switch like new set() does not make it. Anyhow current code can/should be updated. See the note about hb_set.HB_SET_KEYPOLL I left in m

Re: [Harbour] Compile defines

2008-06-02 Thread Przemyslaw Czerpak
On Mon, 02 Jun 2008, Szakáts Viktor wrote: Hi Viktor, > >>-DHB_GUI > >It disables inkey polling in main HVM loop. > >In normal programs it means that K_ALT_C and K_ALT_D will > >not work. It gives some small speed improvement. > What do you think of making this a runtime option? > (a Set()) The

Re: [Harbour] Compile defines

2008-06-02 Thread Przemyslaw Czerpak
On Mon, 02 Jun 2008, Szakáts Viktor wrote: > >Since we already have a TRACE functionality on the > >C level which has nothing to do with this, I'd like > >to rename this to HB_NO_TRACEPRG. Or rather, shouldn't > >we tie this functionality to PROFILER? Opinions? HB_NO_TRACEPRG is OK for me though I

Re: [Harbour] Compile defines

2008-06-02 Thread Szakáts Viktor
It disables the possibility of function call tracing which can be enabled in default builds by: __TRACEPRGCALLS( [ ] ) -> It gives some small speed improvement. There is also HB_NO_DEBUG macro which disables debugger also giving some small speed improvement. Okay, so it does in fact exist,

Re: [Harbour] Compile defines

2008-06-02 Thread Szakáts Viktor
-DHB_GUI It disables inkey polling in main HVM loop. In normal programs it means that K_ALT_C and K_ALT_D will not work. It gives some small speed improvement. What do you think of making this a runtime option? (a Set()) -DHB_NO_TRACE It disables the possibility of function call tracing wh

Re: [Harbour] Compile defines

2008-06-02 Thread Randy Portnoff
Hi Viktor, -DHB_NO_PROFILER Valid. I cannot find any docs on the purpose of HB_NO_PROFILER - Can you please offer a brief explanation of what it is used for? TIA. Randy. ___ Harbour mailing list Harbour@harbour-project.org http://lists.harbou

Re: [Harbour] Compile defines

2008-06-02 Thread Enrico Maria Giordano
-Messaggio Originale- Da: "Przemyslaw Czerpak" <[EMAIL PROTECTED]> A: "Harbour Project Main Developer List." Data invio: lunedi 2 giugno 2008 20.44 Oggetto: Re: [Harbour] Compile defines Thank you. EMG -- EMAG Software Homepage: http://www.emagsoftwar

Re: [Harbour] Compile defines

2008-06-02 Thread Enrico Maria Giordano
-Messaggio Originale- Da: "Szakáts Viktor" <[EMAIL PROTECTED]> A: "Harbour Project Main Developer List." Data invio: lunedì 2 giugno 2008 20.34 Oggetto: Re: [Harbour] Compile defines Thank you. EMG -- EMAG Software Homepage: http://www.emagsoftware.it

Re: [Harbour] Compile defines

2008-06-02 Thread Przemyslaw Czerpak
On Mon, 02 Jun 2008, Enrico Maria Giordano wrote: > Which of the following symbols are still useful/mandatory? > -DHB_FM_STATISTICS_OFF It's still functional. Default is HB_FM_STATISTICS > -DHB_GUI It disables inkey polling in main HVM loop. In normal programs it means that K_ALT_C and K_ALT_D w

Re: [Harbour] Compile defines

2008-06-02 Thread Szakáts Viktor
-DHB_FM_STATISTICS_OFF Valid. -DHB_GUI ? Still exists. I think we should somehow remove this (meaning: replace with some superior solution) in the future. Since this is yet another thing to remember at build-time and yet another thing to badly interact with a multi GT app. Actually somethin

[Harbour] Compile defines

2008-06-02 Thread Enrico Maria Giordano
Which of the following symbols are still useful/mandatory? -DHB_FM_STATISTICS_OFF -DHB_GUI -DHB_NO_PROFILER -DHB_NO_TRACE -DHB_WIN32_IO Thank you in advance. EMG -- EMAG Software Homepage: http://www.emagsoftware.it The EMG's ZX-Spectrum Page: http://www.emagsoftware.it/spectrum The Best o