It disables the possibility of function call tracing which can be
enabled
in default builds by:
__TRACEPRGCALLS( [ <lOnOff> ] ) -> <lPrevSetting>
It gives some small speed improvement.
There is also HB_NO_DEBUG macro which disables debugger also giving
some small speed improvement.
Okay, so it does in fact exist, but does
something completely different :)
Since we already have a TRACE functionality on the
C level which has nothing to do with this, I'd like
to rename this to HB_NO_TRACEPRG. Or rather, shouldn't
we tie this functionality to PROFILER? Opinions?
Inspecting it a little more, I think we
should just use another HB_TRACE level
for these messages, and leave the full
control to the HB_TRACE setting, rather
having another control layer above.
Harbour uses DEBUG level for most messages,
rarely some INFOs, so I think we should
simply make those PRG trace calls to the
INFO level.
The .prg level switch can be guarded
with #if HB_TR_LEVEL >= HB_TR_INFO so
the check won't cause any runtime overhead
if someone has built Harbour with higher
HB_TRACE level.
Opinions?
Brgds,
Viktor
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour