-DHB_GUI

It disables inkey polling in main HVM loop.
In normal programs it means that K_ALT_C and K_ALT_D will
not work. It gives some small speed improvement.

What do you think of making this a runtime option?
(a Set())

-DHB_NO_TRACE

It disables the possibility of function call tracing which can be enabled
in default builds by:
  __TRACEPRGCALLS( [ <lOnOff> ] ) -> <lPrevSetting>
It gives some small speed improvement.

There is also HB_NO_DEBUG macro which disables debugger also giving
some small speed improvement.

Okay, so it does in fact exist, but does
something completely different :)

Since we already have a TRACE functionality on the
C level which has nothing to do with this, I'd like
to rename this to HB_NO_TRACEPRG. Or rather, shouldn't
we tie this functionality to PROFILER? Opinions?

For HB_NO_DEBUG we're talking about maybe 4-6 CPU instructions
per Harbour function call. Do we really need this? Is this
measurable?

Brgds
Viktor

_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour

Reply via email to