On Tue, Dec 04, 2012 at 08:53:50AM -0500, Diego Novillo wrote:
>On Tue, Dec 4, 2012 at 4:24 AM, Bernhard Reutner-Fischer
> wrote:
>> contrib/ChangeLog:
>>
>> 2012-12-01 Bernhard Reutner-Fischer
>>
>> * testsuite-management/validate_failures.py
>> (IsInterestingResult): Only strip
The -fdump-go-spec option handles types that are never defined by
outputting a dummy definition of the type. However, it does not handle
types are defined but whose definition could not be represented in Go.
This patch fixes that problem: if the definition was found but could not
be printed, we pr
After so many changes in LRA ppc target was broken. The following patch
fixes PPC bootstrap.
The patch was successfully bootstrapped on x86/x86-64 and PPC.
Committed as rev. 194180.
2012-12-05 Vladimir Makarov
* rtl.h (struct rtx_def): Add comment for field jump.
(SUBREG_M
I've merged revision 194178 from trunk to the gccgo branch.
Ian
The Go language accepts an optional comma after an expression in a type
conversion. This is because type conversions can look like function
calls. The Go frontend was incorrectly rejecting these valid programs.
This patch fixes that. Bootstrapped and ran Go testsuite on
x86_64-unknown-linux-gnu.
Because of the efforts the Go frontend takes to avoid knock-on errors,
it was possible for some erroneous code to get through without an error
message. Specifically, code like v().NonexistentFunction() would not
produce an error when v was not a function. This patch fixes that
problem. Bootstrap
This patch to the Go frontend implements better checks for constants
passed to the predefined function make. It gives an error for using
negative numbers, and when the length is larger than the capacity.
These are required by the language spec, but were never enforced by the
compiler until now. T
Il 04/12/2012 23:30, H.J. Lu ha scritto:
> On Tue, Nov 27, 2012 at 8:00 AM, Paolo Bonzini wrote:
>> Hi,
>>
>> this bug triggers in the compilation of QEMU with GCC 4.7.2. It is
>> latent on trunk because reg_known_value is completely broken. I'll
>> send a separate patch, but this one applies th
On Tue, Dec 4, 2012 at 10:18 PM, Xinliang David Li wrote:
> Was it a bug then?
Yup, a bug.
One I introduced myself with the passes.c changes.
With the attached patch I get this dump:
- 8< ---
digraph "" {
overlap=false;
subgraph "foo" {
color="black";
label="foo";
OK
/Marcus
On 4 December 2012 10:36, James Greenhalgh wrote:
>
> Hi,
>
> This patch improves our code generation for some cases of
> constant vector permutation. In particular, we are able to
> generate better code for patterns which match the output
> of the zip, uzp and trn instructions.
>
> Th
OK
/Marcus
On 4 December 2012 10:31, James Greenhalgh wrote:
>
> Hi,
>
> This patch adds support for Vector Shuffle style operations
> through support for TARGET_VECTORIZE_VEC_PERM_CONST_OK and
> the vec_perm and vec_perm_const standard patterns.
>
> In this patch we add the framework and suppor
Like this. Tested on powerpc-linux and installed as obvious.
Andreas.
* include/Makefile.am (${host_builddir}/c++config.h): Replace
[] by [].
* include/Makefile.in: Regenerate.
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 44200ee
On Tue, Nov 27, 2012 at 8:00 AM, Paolo Bonzini wrote:
> Hi,
>
> this bug triggers in the compilation of QEMU with GCC 4.7.2. It is
> latent on trunk because reg_known_value is completely broken. I'll
> send a separate patch, but this one applies there too.
>
> The problem arises when you have -f
The problem here is that we are setting __OBJC2__ regardless of what
language we are compiling.
Tested by building a cross cc1/cc1obj for x86_64-unknown-darwin, and
doing the following:
reynosa:/build/trunk-darwin-objc/gcc$ echo "" | ./cc1obj -E -dM -
-quiet |grep OBJ
#define __OBJC__ 1
#d
On Tue, Dec 4, 2012 at 1:31 PM, Jeff Law wrote:
> On 12/03/2012 01:08 PM, Sriraman Tallam wrote:
>>
>> Hi Jeff,
>>
>> Wondering if you got a chance to do this?
>
> Hmm, thinking more about this, it couldn't have been a 32 bit HPUX issue.
> First that port claims to not support -ffunction-secti
On Tue, Dec 4, 2012 at 12:47 PM, Steven Bosscher wrote:
> On Tue, Dec 4, 2012 at 9:14 PM, Xinliang David Li wrote:
>> I assume the graph dump does not support multiple function dump (I
>> noticed that the previous function's dump gets overwritten). This
>> reminds me that I need to resurrect my p
On Tue, Dec 4, 2012 at 9:14 PM, Xinliang David Li wrote:
> I assume the graph dump does not support multiple function dump (I
> noticed that the previous function's dump gets overwritten). This
> reminds me that I need to resurrect my per-function dump support, and
> dump-before/after patches at s
Richard Henderson writes:
> My recent change to fix PR48076 broke arm-linux, and probably mips-linux,
> where one must defer to the kernel in order to achieve a memory barrier
> for the currently running cpu.
>
> The __sync* family of functions was put into libgcc.a, and not into the
> shared libr
Nice. We used to just do post-processing of the dumps with -blocks option.
I assume the graph dump does not support multiple function dump (I
noticed that the previous function's dump gets overwritten). This
reminds me that I need to resurrect my per-function dump support, and
dump-before/after
On Thu, Nov 29, 2012 at 10:26 AM, Sterling Augustine
wrote:
> This patch backports to gcc-google-4_7 the many changes to the fission
> implementation required to merge fission into trunk.
Committed as posted. Thanks!
Hello,
Just comment updates, and a bit of documentation.
Not sure if the comment changes need a ChangeLog.
OK for trunk?
Ciao!
Steven
ra_comments_janitor.diff
Description: Binary data
My recent change to fix PR48076 broke arm-linux, and probably mips-linux,
where one must defer to the kernel in order to achieve a memory barrier
for the currently running cpu.
The __sync* family of functions was put into libgcc.a, and not into the
shared library, so that invocations of these func
On 12/4/12, Diego Novillo wrote:
> On Tue, Dec 4, 2012 at 4:23 AM, Richard Biener
> wrote:
>> On Mon, Dec 3, 2012 at 9:14 PM, Lawrence Crowl
>> wrote:
>>> On 12/3/12, Diego Novillo wrote:
On 2012-12-01 20:44 , Lawrence Crowl wrote:
> Index: gcc/gimple-fold.c
> =
On Mon, 2012-12-03 at 13:16 +0100, Eric Botcazou wrote:
> > 2012-11-19 Eric Botcazou
> >
> > * config/ia64/ia64.c (ia64_compute_frame_size): Allocate the scratch
> > area if the function allocates dynamic stack space.
> > (ia64_initial_elimination_offset): Adjust offsets to above ch
> > here is updated patch. It should get the bounds safe enough to not have
> > effect on codegen of complette unrolling.
> >
> > There is IMO no way to cut the walk of loop body w/o affecting codegen in
> > unrolling for size mode. The condition on unroling to happen is
> >
> > unrolled_size
On Tue, Dec 4, 2012 at 10:06 AM, Uros Bizjak wrote:
> On Tue, Dec 4, 2012 at 5:28 PM, Marc Glisse wrote:
>> On Tue, 4 Dec 2012, Marc Glisse wrote:
>>
>>> Do you agree?
>>
>>
>> Like this ? (only tested on the new testcases, and then I'd need to ask Eric
>> his opinion)
>>
>> 2012-12-04 Marc Glis
On Tue, Dec 4, 2012 at 5:28 PM, Marc Glisse wrote:
> On Tue, 4 Dec 2012, Marc Glisse wrote:
>
>> Do you agree?
>
>
> Like this ? (only tested on the new testcases, and then I'd need to ask Eric
> his opinion)
>
> 2012-12-04 Marc Glisse
>
> PR target/54855
> gcc/
> * simplify-rtx
Ping.
Thanks,
Kyrill
> -Original Message-
> From: gcc-patches-ow...@gcc.gnu.org [mailto:gcc-patches-
> ow...@gcc.gnu.org] On Behalf Of Kyrylo Tkachov
> Sent: 26 November 2012 14:40
> To: gcc-patches@gcc.gnu.org
> Cc: Ramana Radhakrishnan; Richard Earnshaw
> Subject: [PATCH][ARM] AArch32 v
Oops, thought I had sent this before.
On 11/17/2012 10:23 AM, Dodji Seketeli wrote:
- if (cp_parser_parse_definitely (parser))
+ /* Note that if we actually see the '=' token after the
+identifier, cp_parser_alias_declaration commits the
+tentative parse.
David Edelsohn wrote:
I have not tried this patch, but will it actually fix it? The error
is real_kinds(3) is outside the array bounds. Your patch fixes
addresses a runtime problem, not a compile-time problem, if I
understand correctly.
Yes, I realized it myself - after a hint by Dominique. Th
On Tue, 4 Dec 2012, Marc Glisse wrote:
Do you agree?
Like thisĀ ? (only tested on the new testcases, and then I'd need to ask Eric
his opinion)
2012-12-04 Marc Glisse
PR target/54855
gcc/
* simplify-rtx.c (simplify_binary_operation_1) : Replace
with VEC_MERGE.
On Tue, Dec 04, 2012 at 05:03:10PM +0100, Tobias Burnus wrote:
> +2012-12-04 Tobias Burnus
> +
> + * gfortran.dg/quad_3.f90: Fix a condition,
> + which wrongly required ordered/lazy evaluation.
> +
> 2012-12-04 Marcus Shawcroft
>
> * gcc.target/aarch64/121127.c: New test.
> I
Tobias,
I have not tried this patch, but will it actually fix it? The error
is real_kinds(3) is outside the array bounds. Your patch fixes
addresses a runtime problem, not a compile-time problem, if I
understand correctly.
/nasfarm/dje/src/src/gcc/testsuite/gfortran.dg/quad_3.f90:17.47:
if (
Clang hasn't fully switched to dylib interposition yet.
The -fsanitize=address still links the static version of the runtime.
On Tue, Dec 4, 2012 at 7:24 PM, Jack Howarth wrote:
> On Tue, Dec 04, 2012 at 07:10:27PM +0400, Konstantin Serebryany wrote:
>> On Tue, Dec 4, 2012 at 7:03 PM, Jack Howart
David Edelsohn:
The quad_3.f90 testcase fails on AIX, which does not have quad math enabled. I
do not understand how the following line can be correct.
Well, obviously, it is not correct - otherwise you wouldn't see a
failure :-)
Corrected by the attached patch (Rev. 194155).
Sorry for the
2012-10-19 Paulo Matos
* gcc/testsuite/gcc.dg/tree-ssa/vector-3.c: Ensure we are looking
for 0.0 and not for something like 3000, which matches current 0.0
pattern.
0001-Improve-regexp-to-ensure-that-numbers-like-3000-do-n.patch
Description: 0001-Improve-regexp-to-
Hi,
when working at the IPA-SRA misalignment problems I have noticed that
the traditional intraprocedural SRA can also produce this when the
MEM_REF it is after is hidden below a handled component. Fortunately,
now that get_object_alignment looks into MEM_REFS for alignment, we
can use it directl
On Tue, Dec 04, 2012 at 07:10:27PM +0400, Konstantin Serebryany wrote:
> On Tue, Dec 4, 2012 at 7:03 PM, Jack Howarth wrote:
> > On Tue, Dec 04, 2012 at 11:02:01AM +0400, Konstantin Serebryany wrote:
> >> r194120.
> >> I've tested it on Linux, but not on Mac.
> >
> > kcc,
> >Tested at r194135
On 29 November 2012 15:26, Yufeng Zhang wrote:
> Please find the updated patch that improves the comment added to the test in
> the generic part of the testsuite.
OK
/Marcus
On Tue, Dec 4, 2012 at 7:03 PM, Jack Howarth wrote:
> On Tue, Dec 04, 2012 at 11:02:01AM +0400, Konstantin Serebryany wrote:
>> r194120.
>> I've tested it on Linux, but not on Mac.
>
> kcc,
>Tested at r194135 on x86_64-apple-darwin12. Thanks for the commit.
>Jack
> ps Since clang i
Hi,
I have just merged upstream gcc-4_7-branch into ARM/aarch64-4.7-branch, up
to r194062.
This merge didn't cause any regressions.
Thanks
Sofiane
On Tue, Dec 04, 2012 at 11:02:01AM +0400, Konstantin Serebryany wrote:
> r194120.
> I've tested it on Linux, but not on Mac.
kcc,
Tested at r194135 on x86_64-apple-darwin12. Thanks for the commit.
Jack
ps Since clang in svn trunk has already switched to the mac function imposition
v
On 27/11/12 16:51, James Greenhalgh wrote:
Hi,
This patch adds support for vectorizing across some of the rounding
functions in the C math library to the AArch64 back-end.
In particular, we add support for vectorizing across:
ceil (), ceilf (), lceil (),
floor (), floorf (), lfloor (),
round
Tobias,
The quad_3.f90 testcase fails on AIX, which does not have quad math enabled.
I do not understand how the following line can be correct. Fortran
does not have early exit and the line is evaluated at compile time, so
real_kinds(3) is not valid because real_kinds array does not have that
man
On 04/12/12 13:53, Dinar Temirbulatov wrote:
Hi,
During investigation of some defect, I found that for HImode reload
pass generated three instruction with QImode but for modern arm
machines that could be done with just one instruction. Attached patch
adds that capability.
On Tue, Dec 4, 2012 at 4:23 AM, Richard Biener
wrote:
> On Mon, Dec 3, 2012 at 9:14 PM, Lawrence Crowl wrote:
>> On 12/3/12, Diego Novillo wrote:
>>> On 2012-12-01 20:44 , Lawrence Crowl wrote:
Index: gcc/gimple-fold.c
===
On Mon, 3 Dec 2012, Uros Bizjak wrote:
On Mon, Dec 3, 2012 at 4:34 PM, Marc Glisse wrote:
However, looking a bit more into the usage cases for these patterns,
they are only used through intrinsics with _m128 operands. While your
proposed patch makes these patterns more general (they can use 6
Hi,
I've committed the attached patch which enables the CC of x+constant
instructions to be used in more situations on z9 or higher.
No regressions on s390 and s390x (--with-arch=z196).
Bye,
-Andreas-
2012-12-04 Andreas Krebbel
* config/s390/s390.c (s390_select_ccmode): Enable usin
On Mon, Dec 3, 2012 at 4:10 PM, Lawrence Crowl wrote:
> Before the change, lto-streamer.h output_block::string_hash_table was
> an htab_t. The element type was opaque, i.e. implicit in the void*
> casting in the hash functions provided at the htab_create call site.
>
> With the change to hash_ta
On Tue, Dec 4, 2012 at 4:24 AM, Bernhard Reutner-Fischer
wrote:
> contrib/ChangeLog:
>
> 2012-12-01 Bernhard Reutner-Fischer
>
> * testsuite-management/validate_failures.py
> (IsInterestingResult): Only strip line a second time if we did split.
> Rephrase return statemen
Hi,
During investigation of some defect, I found that for HImode reload
pass generated three instruction with QImode but for modern arm
machines that could be done with just one instruction. Attached patch
adds that capability.
thanks, Dinar.
reload_o
Now that the main part of the compiler no-longer supports generating
code for the FPA or obsolete targets, this patch cleans up the code in
libgcc that handles it.
* config.host: (arm*-*-freebsd*): Remove.
(arm*-*-linux*, arm*-*-uclinux*): Simplify logic.
(arm*-*-elf*): Re
Another minor cleanup following the removal of the Cirrus Maverick
support. Now that we no-longer support the Maverick instruction set
extensions, we no-longer need the option to fix up the breakage in early
implementations. The code to do this went with the initial purge, but
the option managed
On Mon, Dec 3, 2012 at 9:03 PM, Etienne Le Sueur wrote:
> First ping... anyone?
A sysroot of /dev/null does not sound like something that we should support.
If we do the semantics of this setting should be documented somewhere.
Richard.
> On 28/11/12 1:21 PM, Etienne Le Sueur wrote:
>>
>> Hi,
>
Hi!
asan.exp tests obviously require libsanitizer, but were only checking for
-fsanitize=address compiler support (plus looking for the libsanitizer
and if found, adding link options as needed).
This patch let's us skip all asan tests if the library isn't available.
Committed as obvious after tes
Hello
> Ok.
That was checked in:
http://gcc.gnu.org/ml/gcc-cvs/2012-12/msg00075.html
http://gcc.gnu.org/ml/gcc-cvs/2012-12/msg00077.html
Thanks, K
LGTM with my limited gcc internals knowledge
On Sat, Dec 1, 2012 at 3:56 AM, Jakub Jelinek wrote:
> On Fri, Nov 30, 2012 at 09:00:30PM +0400, Dmitry Vyukov wrote:
>> and thanks for the nand catch!
>
> Here is updated atomics instrumentation patch, including the 16-byte
> atomics, nand, success/fa
We freed the renamed symbol for intrinsic modules too early, if they
actually exist on the disk as the name is used in trans*.c. (For "file"
modules, the data is later freed with the namespace by calling
gfc_free_use_stmts.)
Build and regtested on x86-64-gnu-linux.
OK for the trunk?
Tobias
20
Hi,
This patch improves our code generation for some cases of
constant vector permutation. In particular, we are able to
generate better code for patterns which match the output
of the zip, uzp and trn instructions.
This patch adds support for these cases.
This patch has been tested with no reg
Hi,
This patch adds support for Vector Shuffle style operations
through support for TARGET_VECTORIZE_VEC_PERM_CONST_OK and
the vec_perm and vec_perm_const standard patterns.
In this patch we add the framework and support for the
generic tbl instruction. This can be used to handle any
vector perm
contrib/ChangeLog:
2012-12-01 Bernhard Reutner-Fischer
* testsuite-management/validate_failures.py
(IsInterestingResult): Only strip line a second time if we did split.
Rephrase return statement while at it.
(CollectSumFiles): Also ignore .git directory.
Signed
On Mon, Dec 3, 2012 at 9:14 PM, Lawrence Crowl wrote:
> On 12/3/12, Diego Novillo wrote:
>> On 2012-12-01 20:44 , Lawrence Crowl wrote:
>>> Index: gcc/gimple-fold.c
>>> ===
>>> --- gcc/gimple-fold.c(revision 193902)
>>> +++ g
On Mon, Dec 3, 2012 at 5:54 PM, Steven Bosscher wrote:
> Hello,
>
> This is the last patch in this series for now, unless I can convince
> everyone that some files should be renamed after all these changes :-)
>
> The attached patch makes graph.c independent of the IR contained in
> the CFG it dum
This is what I finally settled for as suitable solution for this
PR in stage3. There are multiple issues with the PRE implementation
and the basic insert algorithm from the paper (sic). The implementation
already has several hacks in place to mitigate the issues in most
cases - but as usual, one
An inverted slice range (with the low index larger than the high index)
is invalid in Go. An inverted slice range using constant indexes is
supposed to be detected at compile time. This patch implements that in
gccgo. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu.
Committed to ma
On Tue, Dec 04, 2012 at 12:59:11PM +0530, Senthil Kumar Selvaraj wrote:
> As a follow-up to this discussion
> (http://gcc.gnu.org/ml/gcc/2012-11/msg00307.html), I have a patch that
> makes dwarf2out.c emit correct location information for a FP register spanning
> multiple hard regs.
>
> Before the
66 matches
Mail list logo