Re: Send events to parallel operator instances

2015-06-02 Thread Aljoscha Krettek
This already sounds awfully complicated. Is there no other way to implement the delta windows? On Wed, Jun 3, 2015 at 7:52 AM, Gyula Fóra wrote: > Hi Ufuk, > > In the concrete use case I have in mind I only want to send events to > another subtask of the same task vertex. > > Specifically: if we

Re: Send events to parallel operator instances

2015-06-02 Thread Gyula Fóra
Hi Ufuk, In the concrete use case I have in mind I only want to send events to another subtask of the same task vertex. Specifically: if we want to do distributed delta based windows we need to send after every trigger the element that has triggered the current window. So practically I want to br

Re: "Validate" (commons) versus "checkArgument" (guava)

2015-06-02 Thread Lokesh Rajaram
Hello Ufuk, Robert, @Ufuk if you can create a ticket and assign it to me that would be very helpful @Robert I can definitely update those two documents. Just now I was checking and looks like we can control this using checkstyle http://checkstyle.sourceforge.net/config_imports.html#IllegalImport

[jira] [Created] (FLINK-2139) Test Streaming Outputformats

2015-06-02 Thread JIRA
Márton Balassi created FLINK-2139: - Summary: Test Streaming Outputformats Key: FLINK-2139 URL: https://issues.apache.org/jira/browse/FLINK-2139 Project: Flink Issue Type: Test Compo

[jira] [Created] (FLINK-2138) PartitionCustom for streaming

2015-06-02 Thread JIRA
Márton Balassi created FLINK-2138: - Summary: PartitionCustom for streaming Key: FLINK-2138 URL: https://issues.apache.org/jira/browse/FLINK-2138 Project: Flink Issue Type: New Feature

[jira] [Created] (FLINK-2137) Expose partitionByHash for WindowedDataStream

2015-06-02 Thread JIRA
Márton Balassi created FLINK-2137: - Summary: Expose partitionByHash for WindowedDataStream Key: FLINK-2137 URL: https://issues.apache.org/jira/browse/FLINK-2137 Project: Flink Issue Type: New

[jira] [Created] (FLINK-2136) Test the streaming scala API

2015-06-02 Thread JIRA
Márton Balassi created FLINK-2136: - Summary: Test the streaming scala API Key: FLINK-2136 URL: https://issues.apache.org/jira/browse/FLINK-2136 Project: Flink Issue Type: Test Compo

Re: [2/2] flink git commit: [ml] Replaces RichMapFunctions with mapWithBcVariable in FlinkML

2015-06-02 Thread Till Rohrmann
If it helps you with your task, then you can add it. The best thing is probably to implement it similarly to the mapWithBcVariable. Cheers, Till ​ On Tue, Jun 2, 2015 at 7:25 PM, Sachin Goel wrote: > Should I go ahead and add this method then? The mapWithBcSet I mean. > > Regards > Sachin Goel

Re: Send events to parallel operator instances

2015-06-02 Thread Ufuk Celebi
On 02 Jun 2015, at 22:45, Gyula Fóra wrote: > I am wondering, what is the suggested way to send some events directly to > another parallel instance in a flink job? For example from one mapper to > another mapper (of the same operator). > > Do we have any internal support for this? The first thin

Send events to parallel operator instances

2015-06-02 Thread Gyula Fóra
Hi, I am wondering, what is the suggested way to send some events directly to another parallel instance in a flink job? For example from one mapper to another mapper (of the same operator). Do we have any internal support for this? The first thing that we thought of is iterations but that is clea

Re: ClassNotFoundException : org.apache.flink.api.common.operators.util.UserCodeObjectWrapper, while trying to run locally

2015-06-02 Thread santosh_rajaguru
Thanks Robert and Stephan. I executed the program in maven environment. It works fine. However, in Plugin environment, though i have included all the dependencies and dependent jars, it says classnotfoundexception while executing the env. -- View this message in context: http://apache-flink

Re: "Validate" (commons) versus "checkArgument" (guava)

2015-06-02 Thread Robert Metzger
Adding an entry here: http://flink.apache.org/coding-guidelines.html is certainly good, yes. You can contribute to the website here: https://github.com/apache/flink-web We enforce coding guidelines using the maven checkstyle plugin. Maybe there is a way of forbidding certain imports On Tue, Jun 2

Re: "Validate" (commons) versus "checkArgument" (guava)

2015-06-02 Thread Ufuk Celebi
On 02 Jun 2015, at 21:18, Lokesh Rajaram wrote: > Hello Robert, > > I worked on that issue, if it's ok I can take this task. > > Btw, how is anything enforced in Flink? Do I have to update how to contribute > guide or any thing else need to be done? The how to contribute guide is a good star

Re: "Validate" (commons) versus "checkArgument" (guava)

2015-06-02 Thread Lokesh Rajaram
Hello Robert, I worked on that issue, if it's ok I can take this task. Btw, how is anything enforced in Flink? Do I have to update how to contribute guide or any thing else need to be done? Sent from my iPhone > On Jun 2, 2015, at 12:11 PM, Robert Metzger wrote: > > We have now replaced all

Re: "Validate" (commons) versus "checkArgument" (guava)

2015-06-02 Thread Robert Metzger
We have now replaced all commons validate calls with guava preconditions but its not written down anywhere or enforced by anything. Who would like to take care of that? On Thu, Mar 26, 2015 at 11:03 AM, Robert Metzger wrote: > I didn't know that there was already an issue for this. I closed > F

Re: Memory management overhaul

2015-06-02 Thread Ufuk Celebi
On 02 Jun 2015, at 20:12, Alexander Alexandrov wrote: > During an offline chat some time ago Stephan Ewen mentioned that there is > an ongoing effort for a dynamic memory allocation in some feature branch > lying around. Can you point me to that, as I would like to look at the > code? Thanks.

Memory management overhaul

2015-06-02 Thread Alexander Alexandrov
During an offline chat some time ago Stephan Ewen mentioned that there is an ongoing effort for a dynamic memory allocation in some feature branch lying around. Can you point me to that, as I would like to look at the code? Thanks.

Re: Travis build failing

2015-06-02 Thread Ufuk Celebi
I'm looking into the last one already. On Tuesday, June 2, 2015, Sachin Goel wrote: > Ah. This is a known issue then. > > Regards > Sachin Goel > > On Tue, Jun 2, 2015 at 9:14 PM, Aljoscha Krettek > > wrote: > > > The last one is actually SuccessAfterNetworkBuffersFailureITCase which > > uses C

Re: [2/2] flink git commit: [ml] Replaces RichMapFunctions with mapWithBcVariable in FlinkML

2015-06-02 Thread Sachin Goel
Should I go ahead and add this method then? The mapWithBcSet I mean. Regards Sachin Goel On Tue, Jun 2, 2015 at 10:43 PM, Till Rohrmann wrote: > Yes you’re right Sachin. The mapWithBcVariable is only syntactic sugar if > you have a broadcast DataSet which contains only one element. If you have

Re: [2/2] flink git commit: [ml] Replaces RichMapFunctions with mapWithBcVariable in FlinkML

2015-06-02 Thread Till Rohrmann
Yes you’re right Sachin. The mapWithBcVariable is only syntactic sugar if you have a broadcast DataSet which contains only one element. If you have multiple elements in your DataSet then you can’t use this method. But we can define another method mapWithBcSet which takes a function f: (element: T,

Re: [2/2] flink git commit: [ml] Replaces RichMapFunctions with mapWithBcVariable in FlinkML

2015-06-02 Thread Sachin Goel
Further, I think we should return just broadcastVariable = getRuntimeContext. getBroadcastVariable[B]("broadcastVariable") in BroadcastSingleElementMapper User may wish to have a list broadcasted, and not just want to access the first element. For example, this would make sense in the kmeans algori

Re: Writing test suites

2015-06-02 Thread Aljoscha Krettek
Hi, the difference is that the IT (Integration Test) suites are only run when "mvn verify" or "mvn install" is executed. The other suites (or tests) are ran when "mvn test" is executed. Typically the non-IT tests are more lightweight while the IT tests can do heavy stuff that takes a bit longer. W

Writing test suites

2015-06-02 Thread Sachin Goel
Hi What's the convention with using an "ITSuite" in the name instead of just "Suite"? Regards Sachin Goel

[jira] [Created] (FLINK-2135) Java plan translation fails with ClassCastException (probably in first())

2015-06-02 Thread Robert Metzger (JIRA)
Robert Metzger created FLINK-2135: - Summary: Java plan translation fails with ClassCastException (probably in first()) Key: FLINK-2135 URL: https://issues.apache.org/jira/browse/FLINK-2135 Project: Fl

Re: Travis build failing

2015-06-02 Thread Sachin Goel
Ah. This is a known issue then. Regards Sachin Goel On Tue, Jun 2, 2015 at 9:14 PM, Aljoscha Krettek wrote: > The last one is actually SuccessAfterNetworkBuffersFailureITCase which > uses ConnectedComponents. > > On Tue, Jun 2, 2015 at 5:42 PM, Robert Metzger > wrote: > > Hi, > > I think there

Re: Travis build failing

2015-06-02 Thread Aljoscha Krettek
The last one is actually SuccessAfterNetworkBuffersFailureITCase which uses ConnectedComponents. On Tue, Jun 2, 2015 at 5:42 PM, Robert Metzger wrote: > Hi, > I think there are currently at least three tests randomly failing on Travis: > - the yarn failure you've just reported > - the KafkaITCase

Re: Travis build failing

2015-06-02 Thread Robert Metzger
Hi, I think there are currently at least three tests randomly failing on Travis: - the yarn failure you've just reported - the KafkaITCase - a ConnectedComponent test (Ufuk posted something about this 2 hrs ago) On Tue, Jun 2, 2015 at 5:41 PM, Sachin Goel wrote: > I recently merged the master br

Travis build failing

2015-06-02 Thread Sachin Goel
I recently merged the master branch to something I've been working on. However, the travis build is failing with this error: I have made no changes to the existing files, only added some new files and the tests for those actually pass properly. The build is here: https://travis-ci.org/apache/flink/

Re: [2/2] flink git commit: [ml] Replaces RichMapFunctions with mapWithBcVariable in FlinkML

2015-06-02 Thread Sachin Goel
Hi Till This works only when there is only one variable to be broadcasted, doesn't it? What about the case when we need to broadcast two? Is it advisable to create a BroadcastDoubleElementMapper class or perhaps we could just send a tuple of all the variables? Perhaps that is a better idea. Regard

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Aljoscha Krettek
By the way, we also should rename the corresponding Streaming API method accordingly. On Tue, Jun 2, 2015 at 3:24 PM, Maximilian Michels wrote: > +1 for printOnTaskManager(prefix) > > On Tue, Jun 2, 2015 at 1:54 PM, Kostas Tzoumas wrote: > >> +1 for printOnTaskManager(prefix) >> >> On Tue, Jun 2

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Maximilian Michels
+1 for printOnTaskManager(prefix) On Tue, Jun 2, 2015 at 1:54 PM, Kostas Tzoumas wrote: > +1 for printOnTaskManager(prefix) > > On Tue, Jun 2, 2015 at 1:35 PM, Till Rohrmann > wrote: > > > +1 for printOnTaskManager(prefix) > > > > On Tue, Jun 2, 2015 at 12:08 PM, Fabian Hueske > wrote: > > > >

[jira] [Created] (FLINK-2134) Deadlock in SuccessAfterNetworkBuffersFailureITCase

2015-06-02 Thread Ufuk Celebi (JIRA)
Ufuk Celebi created FLINK-2134: -- Summary: Deadlock in SuccessAfterNetworkBuffersFailureITCase Key: FLINK-2134 URL: https://issues.apache.org/jira/browse/FLINK-2134 Project: Flink Issue Type: Bug

[jira] [Created] (FLINK-2133) Possible deadlock in ExecutionGraph

2015-06-02 Thread Aljoscha Krettek (JIRA)
Aljoscha Krettek created FLINK-2133: --- Summary: Possible deadlock in ExecutionGraph Key: FLINK-2133 URL: https://issues.apache.org/jira/browse/FLINK-2133 Project: Flink Issue Type: Bug

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Kostas Tzoumas
+1 for printOnTaskManager(prefix) On Tue, Jun 2, 2015 at 1:35 PM, Till Rohrmann wrote: > +1 for printOnTaskManager(prefix) > > On Tue, Jun 2, 2015 at 12:08 PM, Fabian Hueske wrote: > > > +1 for writeToWorkerStdOut(prefix) > > On Jun 2, 2015 11:42, "Aljoscha Krettek" wrote: > > > > > +1 for pri

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Till Rohrmann
+1 for printOnTaskManager(prefix) On Tue, Jun 2, 2015 at 12:08 PM, Fabian Hueske wrote: > +1 for writeToWorkerStdOut(prefix) > On Jun 2, 2015 11:42, "Aljoscha Krettek" wrote: > > > +1 for printOnTaskManager(prefix) > > > > On Tue, Jun 2, 2015 at 11:35 AM, Robert Metzger > > wrote: > > > I woul

Re: [FLINK-1731] [ML] Issues with vector to breeze converter while implementing KMeans

2015-06-02 Thread Till Rohrmann
Hi Florian, I just wrote a patch for this problem. I wait until all tests pass and then I’ll merge the fix. Thus, it will be included in the current master in the late afternoon. If you don’t want to wait that long, then you can also solve the issue with .fromBreeze[org.apache.flink.ml.math.Vecto

[FLINK-1731] [ML] Issues with vector to breeze converter while implementing KMeans

2015-06-02 Thread Florian Gößler
Hi Flink Community, we are implementing a KMeans algorithm in the ML part of Flink, but after recent updates we ran into an issues with the vector to breeze converter. We are getting the following compile error: Error:(200, 75) ambiguous implicit values: both value denseVectorConverter in obje

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Fabian Hueske
+1 for writeToWorkerStdOut(prefix) On Jun 2, 2015 11:42, "Aljoscha Krettek" wrote: > +1 for printOnTaskManager(prefix) > > On Tue, Jun 2, 2015 at 11:35 AM, Robert Metzger > wrote: > > I would like to reach consensus on this before the 0.9 release. > > > > So far we have the following ideas: > >

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Aljoscha Krettek
+1 for printOnTaskManager(prefix) On Tue, Jun 2, 2015 at 11:35 AM, Robert Metzger wrote: > I would like to reach consensus on this before the 0.9 release. > > So far we have the following ideas: > > writeToWorkerStdOut(prefix) > printOnTaskManager(prefix) (+1) > logOnTaskManager(prefix) > > I'm a

Re: Changed the behavior of "DataSet.print()"

2015-06-02 Thread Robert Metzger
I would like to reach consensus on this before the 0.9 release. So far we have the following ideas: writeToWorkerStdOut(prefix) printOnTaskManager(prefix) (+1) logOnTaskManager(prefix) I'm against logOnTM because we are not logging the output, we are writing or printing it. *I would vote for d

Re: MultipleLinearRegression - Strange results

2015-06-02 Thread Till Rohrmann
Great to hear. This should no longer be a pain point once we support proper cross validation. On Tue, Jun 2, 2015 at 11:11 AM, Felix Neutatz wrote: > Yes, grid search solved the problem :) > > 2015-06-02 11:07 GMT+02:00 Till Rohrmann : > > > The SGD algorithm adapts the learning rate accordingly

Re: MultipleLinearRegression - Strange results

2015-06-02 Thread Felix Neutatz
Yes, grid search solved the problem :) 2015-06-02 11:07 GMT+02:00 Till Rohrmann : > The SGD algorithm adapts the learning rate accordingly. However, this does > not help if you choose the initial learning rate too large because then you > calculate a weight vector in the first iterations from whi

Re: Storm compatibility layer currently does not support Storm's SimpleJoin example

2015-06-02 Thread Szabó Péter
@Robert Thanks! I think the PR will be ready to merge soon :) @Matthias I fixed the finite-source issue on my branch, now every example and ITCase runs and stopps without throwing an exception. Also, in case of finite sources, the spout wrapper will not loop infinitely. I will study your branch an

Re: MultipleLinearRegression - Strange results

2015-06-02 Thread Till Rohrmann
The SGD algorithm adapts the learning rate accordingly. However, this does not help if you choose the initial learning rate too large because then you calculate a weight vector in the first iterations from which it takes really long to recover. Cheer, Till On Mon, Jun 1, 2015 at 7:15 PM, Sachin G

[jira] [Created] (FLINK-2132) Java version parsing is not working for OpenJDK

2015-06-02 Thread Ufuk Celebi (JIRA)
Ufuk Celebi created FLINK-2132: -- Summary: Java version parsing is not working for OpenJDK Key: FLINK-2132 URL: https://issues.apache.org/jira/browse/FLINK-2132 Project: Flink Issue Type: Bug