Hi, This series converts open-coded 'str' type to enum type for 'status'.
This conversion will be more convenient for future extensibility. Actually, I will add a MIG_STATE_COLO state for COLO, and i also saw Dave added MIG_STATE_POSTCOPY_ACTIVE for postcopy. Patch 1 and 2 are preparation for the conversion, patch 3 completes the conversion. Besides, i add a additional patch (patch 4) to expose 'cancelling' to user, it will influence libvirt side. And i have CC libvirt development. One more thing, i have to replace MIG_STATE_ERROR with MIG_STATE_FAILED, and it begin from 0, not its original -1. I think it has no side effect. Please review. v3: - Use longer name for Migration status macro. (Eric Blake) - Rename internal-only typename 'MigrationStatus'. (Eric, Dave, Markus) - Expose 'cancelling' state. (Eric Blake) Thanks for their comments. ;) v2: - Remove '(since xyz)' strings. (Eric Blake) zhanghailiang (4): migration: Rename abbreviated macro MIG_STATE_* to MIGRATION_STATUS_* hmp: Rename 'MigrationStatus' to 'HMPMigrationStatus' migration: Convert 'status' of MigrationInfo to use an enum type migration: Expose 'cancelling' status to user hmp.c | 15 ++++---- migration/migration.c | 95 ++++++++++++++++++++++++--------------------------- qapi-schema.json | 34 +++++++++++++++--- 3 files changed, 81 insertions(+), 63 deletions(-) -- 1.7.12.4