zhanghailiang <zhang.zhanghaili...@huawei.com> writes: > The original 'status' is an open-coded 'str' type, convert it to use an > enum type. > This conversion is backwards compatible, better documented and > more convenient for future extensibility. > > We also rename 'MIGRATION_STATUS_ERROR' to 'MIGRATION_STATUS_FAILED'. > In addition, Fix a typo for qapi-schema.json: comppleted -> completed > > Signed-off-by: zhanghailiang <zhang.zhanghaili...@huawei.com> [...] > diff --git a/qapi-schema.json b/qapi-schema.json > index e16f8eb..3b5904b 100644 > --- a/qapi-schema.json > +++ b/qapi-schema.json > ## > # @MigrationInfo > # > # Information about current migration process. > # > -# @status: #optional string describing the current migration status. > -# As of 0.14.0 this can be 'setup', 'active', 'completed', 'failed' > or > -# 'cancelled'. If this field is not returned, no migration process > +# @status: #optional @MigState describing the current migration status. > +# If this field is not returned, no migration process > # has been initiated > # > # @ram: #optional @MigrationStats containing detailed migration > # status, only returned if status is 'active' or > -# 'completed'. 'comppleted' (since 1.2) > +# 'completed'. 'completed' (since 1.2)
Shouldn't this just be +# 'completed' (since 1.2) ? > # > # @disk: #optional @MigrationStats containing detailed disk migration > # status, only returned if status is 'active' and it is a block > @@ -453,7 +477,7 @@ > # Since: 0.14.0 > ## > { 'type': 'MigrationInfo', > - 'data': {'*status': 'str', '*ram': 'MigrationStats', > + 'data': {'*status': 'MigrationStatus', '*ram': 'MigrationStats', > '*disk': 'MigrationStats', > '*xbzrle-cache': 'XBZRLECacheStats', > '*total-time': 'int',