On Wed, Jun 30, 2021 at 8:34 AM Dilip Kumar <dilipbal...@gmail.com> wrote: > > On Tue, Jun 29, 2021 at 8:15 PM <gkokola...@pm.me> wrote: > > > > Hi, > > > > The program pg_receivewal can use gzip compression to store the received > > WAL. > > This patch teaches it to be able to use lz4 compression if the binary is > > build > > using the -llz4 flag. > > +1 for the idea > > Some comments/suggestions on the patch > > 1. > @@ -90,7 +91,8 @@ usage(void) > printf(_(" --synchronous flush write-ahead log immediately > after writing\n")); > printf(_(" -v, --verbose output verbose messages\n")); > printf(_(" -V, --version output version information, then > exit\n")); > - printf(_(" -Z, --compress=0-9 compress logs with given > compression level\n")); > + printf(_(" -I, --compress-program use this program for compression\n")); > > Wouldn't it be better to call it compression method instead of > compression program?
I came here to say exactly that, just had to think up what I thought was the better name first. Either method or algorithm, but method seems like the much simpler choice and therefore better in this case. Should is also then not be --compression-method, rather than --compress-method? -- Magnus Hagander Me: https://www.hagander.net/ Work: https://www.redpill-linpro.com/