I don't have this problem. My switch seems to work normally. This is my
configuration:
config interface loopback
option ifname lo
 option proto static
option ipaddr 127.0.0.1
 option netmask 255.0.0.0
 config interface lan
option ifname eth0
 option type bridge
option proto static
 option ipaddr 192.168.1.1
option netmask 255.255.255.0
 option ip6assign 60
 config globals globals
option ula_prefix auto

config switch
option name 'rt305x'
option reset '1'
 option enable_vlan '0'

Are you using 'eth0' or something like 'eth0.1' as 'ifname'?

Regards,
Diego


On Thu, Sep 19, 2013 at 8:51 PM, jonsm...@gmail.com <jonsm...@gmail.com>wrote:

> On Thu, Sep 19, 2013 at 12:42 PM, Diego Lopez Recas <suelt...@gmail.com>
> wrote:
> > Hi Jon,
> >
> > I don't know what you mean with "default 'off' state", but I'm using an
> > RT3052F SoC and I have to explicitly specify the the pvid for the port in
> > vlan 2 to make it work properly. I think this is usual. From
> > http://wiki.openwrt.org/doc/uci/network/switch :
> >
> > "Tagged packets received on a port will be directed to the VLAN
> indicated by
> > the VID contained in the packet. Untagged packets received on a port
> will be
> > directed to the default port VLAN (usually called the PVID). A separate
> > config switch_port section is required to set the default port VLAN."
>
> This may be where the bug came from. How is the default routing
> getting set up when vlan=0?
>
> Maybe this default routing used to get set up automatically when
> vlan=0 and now that isn't happening any more.
>
>
> >
> >
> > So you should add this to your config:
> >
> > config 'switch_port'
> >     option 'port'      '0'
> >     option 'pvid'      '2'
> >
> > I hope it helps.
> >
> > Regards,
> > Diego
> >
> >
> > On Thu, Sep 19, 2013 at 4:21 PM, jonsm...@gmail.com <jonsm...@gmail.com>
> > wrote:
> >>
> >> Has anyone tried using the Ethernet switch on Ralink lately? I don't
> >> believe it is working correctly in the default 'off' state.  The
> >> failure is that the Ralink CPU can't receive any packets from Ethernet
> >> (or those packet are corrupted by the VLAN tag).
> >>
> >> If I enable the switch it works properly. I'm seeing this on the
> >> RT5350 but the code is generic to all Ralink
> >>
> >> diff --git a/files/etc/config/network b/files/etc/config/network
> >> new file mode 100644
> >> index 0000000..c608d0e
> >> --- /dev/null
> >> +++ b/files/etc/config/network
> >> @@ -0,0 +1,39 @@
> >> +config interface 'loopback'
> >> + option ifname 'lo'
> >> + option proto 'static'
> >> + option ipaddr '127.0.0.1'
> >> + option netmask '255.0.0.0'
> >> +
> >> +config globals 'globals'
> >> + option ula_prefix 'fd59:3f8d:cb3a::/48'
> >> +
> >> +config interface 'lan'
> >> + option ifname 'eth0.1'
> >> + option type 'bridge'
> >> + option proto 'static'
> >> + option ipaddr '192.168.1.85'
> >> + option netmask '255.255.255.0'
> >> + option ip6assign '60'
> >> +
> >> +config interface 'wan'
> >> + option ifname 'eth0.2'
> >> + option proto 'dhcp'
> >> +
> >> +config interface 'wan6'
> >> + option ifname '@wan'
> >> + option proto 'dhcpv6'
> >> +
> >> +config switch
> >> + option name 'rt305x'
> >> + option reset '1'
> >> + option enable_vlan '1'
> >> +
> >> +config switch_vlan
> >> + option device 'rt305x'
> >> + option vlan '1'
> >> + option ports '1 2 3 4 6t'
> >> +
> >> +config switch_vlan
> >> + option device 'rt305x'
> >> + option vlan '2'
> >> + option ports '0  6t'
> >>
> >> --
> >> Jon Smirl
> >> jonsm...@gmail.com
> >> _______________________________________________
> >> openwrt-devel mailing list
> >> openwrt-devel@lists.openwrt.org
> >> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
> >
> >
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
> >
>
>
>
> --
> Jon Smirl
> jonsm...@gmail.com
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

Reply via email to