Attention is currently required from: flichtenheld, its_Giaan, plaisthos.

cron2 has posted comments on this change. ( 
http://gerrit.openvpn.net/c/openvpn/+/763?usp=email )

Change subject: multiproto: move generic event handling code in dedicated files
......................................................................


Patch Set 10: Code-Review-2

(15 comments)

Patchset:

PS10:
I can't review this when half the patch is really `renaming of *ls to *sock`.  
Please split these off to a separate patch that does the renaming, and a patch 
that does actual code/file structure changes.


File src/openvpn/init.c:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/9d7d20e0_b9d8d37a :
PS10, Line 4926:                       struct link_socket *sock)
I agree that we might want to make this uniform across the whole code - that 
is, change all occurences to `struct link_socket *XXX` to either `*ls` or 
`*sock`.

But this should not be part of a "L" patchset, which is hard enough to review 
as it is - so please make this into its own patch.


File src/openvpn/mtcp.c:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/36397026_667042d4 :
PS10, Line 165: multi_tcp_context(struct multi_context *m, struct 
multi_instance *mi)
we lost the `inline` bit here by making it a global function.  Maybe move it to 
mtcp.h then, and make it a `static inline` again?


File src/openvpn/mudp.h:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/9b5c56a3_dce8eb89 :
PS10, Line 66:                                                      struct 
link_socket *sock);
see other comment, please move pure `ls/sock` renaming to a different patch


File src/openvpn/mudp.c:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/436366d0_85a29dd3 :
PS10, Line 189:                               struct link_socket *sock)
and here... without the renaming, there wouldn't be a change to `mudp.c` at all 
(much easier to understand)


File src/openvpn/multi.h:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/708a3ae7_1bc1f45f :
PS10, Line 178:     struct multi_protocol *multi_io;     /**< State specific to 
OpenVPN using TCP
If it's still `specific to TCP` (as the comment says), why rename it to 
`multi_protocol`?  This is confusing.


http://gerrit.openvpn.net/c/openvpn/+/763/comment/d2d8645d_1d44dadd :
PS10, Line 280:                                              struct link_socket 
*sock);
this


http://gerrit.openvpn.net/c/openvpn/+/763/comment/f86883ac_ccce439c :
PS10, Line 295:                          struct link_socket *sock);
and that


http://gerrit.openvpn.net/c/openvpn/+/763/comment/f67a320c_f48331b4 :
PS10, Line 363:                                  struct link_socket *sock);
and yet another one


File src/openvpn/multi.c:

http://gerrit.openvpn.net/c/openvpn/+/763/comment/76a11a87_3b464974 :
PS10, Line 754:                       struct link_socket *sock)
another rename


http://gerrit.openvpn.net/c/openvpn/+/763/comment/0d46a452_d8aea7ce :
PS10, Line 777:     inherit_context_child(&mi->context, &m->top, sock);
and this


http://gerrit.openvpn.net/c/openvpn/+/763/comment/a496614d_446989b1 :
PS10, Line 3129:                     struct link_socket *sock)
here


http://gerrit.openvpn.net/c/openvpn/+/763/comment/cfe09b5a_44dfaba8 :
PS10, Line 3185:     mi->context.c2.link_sockets[0] = sock;
and there


http://gerrit.openvpn.net/c/openvpn/+/763/comment/6cee5d39_c8c303fa :
PS10, Line 3335:                             const unsigned int mpp_flags, 
struct link_socket *sock)
and here...


http://gerrit.openvpn.net/c/openvpn/+/763/comment/7fd9250d_8fe8e422 :
PS10, Line 3356:         multi_set_pending(m, multi_get_create_instance_udp(m, 
&floated, sock));
this gets a bit boring



--
To view, visit http://gerrit.openvpn.net/c/openvpn/+/763?usp=email
To unsubscribe, or for help writing mail filters, visit 
http://gerrit.openvpn.net/settings

Gerrit-Project: openvpn
Gerrit-Branch: master
Gerrit-Change-Id: I1e5a84969988e4f027a18658d4ab268c13fbf929
Gerrit-Change-Number: 763
Gerrit-PatchSet: 10
Gerrit-Owner: its_Giaan <gianma...@mandelbit.com>
Gerrit-Reviewer: cron2 <g...@greenie.muc.de>
Gerrit-Reviewer: flichtenheld <fr...@lichtenheld.com>
Gerrit-Reviewer: plaisthos <arne-open...@rfc2549.org>
Gerrit-CC: openvpn-devel <openvpn-devel@lists.sourceforge.net>
Gerrit-Attention: plaisthos <arne-open...@rfc2549.org>
Gerrit-Attention: its_Giaan <gianma...@mandelbit.com>
Gerrit-Attention: flichtenheld <fr...@lichtenheld.com>
Gerrit-Comment-Date: Mon, 30 Dec 2024 19:16:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel

Reply via email to