https://bugs.kde.org/show_bug.cgi?id=374191
--- Comment #15 from Simon <freisi...@gmail.com> --- Hi Mario, I justed tested it and it worked as expected. I have a question/proposition: The existing slotNewDuplicatesSearch funciton accepts a generic album pointer and then determines what type (physical/tag) it is. You made two distinct functions for lists as arguments that still accept generic album pointers but named them to make it clear that either physical or tag albums are expected. Wouldn't it be cleaner and less error prone to use one function name (slotNewDuplicatesSearch) and overload it with different parameters (PAlbum*, TAlbum*, QList<PAlbum*> and QList<TAlbum*>)? -- You are receiving this mail because: You are watching all bug changes.