On Wed, May 01, 2019 at 09:05:19AM -0700, jake6...@gmail.com wrote: > There is nothing wrong with the code you presented. It is clear and readable. > If you find that it clutters the function too much, then make it into it's > only utility function.
But it is wrong, even from a readability perspective. You should not be writing an if chain like this, when we have case / switch operator. *If* you insist of doing that, at least use `else if` so that you don't test every single test case if you know that only one can ever be true. -- You received this message because you are subscribed to the Google Groups "golang-nuts" group. To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscr...@googlegroups.com. For more options, visit https://groups.google.com/d/optout.