On 03/10/2018 11:01 AM, Zhihong Wang wrote:
This patch adds APIs for datapath configuration.

The did of the vhost-user socket can be set to identify the backend device,
in this case each vhost-user socket can have only 1 connection. The did is
set to -1 by default when the software datapath is used.

Signed-off-by: Zhihong Wang <zhihong.w...@intel.com>
---
Changes in v4:

  1. Remove the "engine" concept in the lib.

  lib/librte_vhost/rte_vhost.h           | 35 +++++++++++++++++++++++++++++++++
  lib/librte_vhost/rte_vhost_version.map |  3 +++
  lib/librte_vhost/socket.c              | 36 ++++++++++++++++++++++++++++++++++
  lib/librte_vhost/vhost.c               | 25 +++++++++++++++++++++++
  lib/librte_vhost/vhost.h               |  9 +++++++++
  5 files changed, 108 insertions(+)

diff --git a/lib/librte_vhost/rte_vhost.h b/lib/librte_vhost/rte_vhost.h
index 671ea5053..d50f4c67d 100644
--- a/lib/librte_vhost/rte_vhost.h
+++ b/lib/librte_vhost/rte_vhost.h
@@ -200,6 +200,30 @@ int rte_vhost_driver_register(const char *path, uint64_t 
flags);
  int rte_vhost_driver_unregister(const char *path);
/**
+ * Set the device id, enforce single connection per socket
+ *
+ * @param path
+ *  The vhost-user socket file path
+ * @param did
+ *  Device id
+ * @return
+ *  0 on success, -1 on failure
+ */
+int __rte_experimental
+rte_vhost_driver_set_vdpa_did(const char *path, int did);

IIUC, we call this to attach a VDPA device to a Vhost-user port?

What about having this named explicitly? Something like:

rte_vhost_driver_attach_vdpa_did(const char *path, int did)
rte_vhost_driver_detach_vdpa_did(const char *path)

The later would set to did -1

This is not mandatory though

+
+/**
+ * Get the device id
+ *
+ * @param path
+ *  The vhost-user socket file path
+ * @return
+ *  Device id, -1 on failure
+ */
+int __rte_experimental
+rte_vhost_driver_get_vdpa_did(const char *path);
+
+/**
   * Set the feature bits the vhost-user driver supports.
   *
   * @param path
@@ -464,6 +488,17 @@ int rte_vhost_vring_call(int vid, uint16_t vring_idx);
   */
  uint32_t rte_vhost_rx_queue_count(int vid, uint16_t qid);
+/**
+ * Get vdpa device id for vhost device.
+ *
+ * @param vid
+ *  vhost device ID
+ * @return
+ *  device id
+ */
+int __rte_experimental
+rte_vhost_get_vdpa_did(int vid);
+
  #ifdef __cplusplus
  }
  #endif
diff --git a/lib/librte_vhost/rte_vhost_version.map 
b/lib/librte_vhost/rte_vhost_version.map
index 7bcffb490..6e2d5364a 100644
--- a/lib/librte_vhost/rte_vhost_version.map
+++ b/lib/librte_vhost/rte_vhost_version.map
@@ -64,4 +64,7 @@ EXPERIMENTAL {
        rte_vdpa_register_device;
        rte_vdpa_unregister_device;
        rte_vdpa_find_device_id;
+       rte_vhost_driver_set_vdpa_did;
+       rte_vhost_driver_get_vdpa_did;
+       rte_vhost_get_vdpa_did;
  } DPDK_18.02;
diff --git a/lib/librte_vhost/socket.c b/lib/librte_vhost/socket.c
index cfc31e179..3d58da94e 100644
--- a/lib/librte_vhost/socket.c
+++ b/lib/librte_vhost/socket.c
@@ -52,6 +52,13 @@ struct vhost_user_socket {
        uint64_t supported_features;
        uint64_t features;
+ /*
+        * Device id to identify a specific backend device.
+        * It's set to -1 for the default software implementation.
+        * If valid, one socket can have 1 connection only.
+        */
+       int did;
I would rename it to something like vdpa_did or even better,
vdpa_dev_id. At least prefix it with vdpa not to confuse the user.

+
        struct vhost_device_ops const *notify_ops;
  };
@@ -545,6 +552,35 @@ find_vhost_user_socket(const char *path)
  }
int
+rte_vhost_driver_set_vdpa_did(const char *path, int did)
+{
+       struct vhost_user_socket *vsocket;
+
+       pthread_mutex_lock(&vhost_user.mutex);
+       vsocket = find_vhost_user_socket(path);
+       if (vsocket)
+               vsocket->did = did;

I guess it is possible to know whether the did exists
at that time. Maybe we could check this?

+       pthread_mutex_unlock(&vhost_user.mutex);
+
+       return vsocket ? 0 : -1;
+}
+
+int
+rte_vhost_driver_get_vdpa_did(const char *path)
+{
+       struct vhost_user_socket *vsocket;
+       int did = -1;
+
+       pthread_mutex_lock(&vhost_user.mutex);
+       vsocket = find_vhost_user_socket(path);
+       if (vsocket)
+               did = vsocket->did;
+       pthread_mutex_unlock(&vhost_user.mutex);
+
+       return did;
+}
+
+int
  rte_vhost_driver_disable_features(const char *path, uint64_t features)
  {
        struct vhost_user_socket *vsocket;
diff --git a/lib/librte_vhost/vhost.c b/lib/librte_vhost/vhost.c
index f6f12a03b..1740cc1ab 100644
--- a/lib/librte_vhost/vhost.c
+++ b/lib/librte_vhost/vhost.c
@@ -283,6 +283,7 @@ vhost_new_device(void)
        dev->vid = i;
        dev->flags = VIRTIO_DEV_BUILTIN_VIRTIO_NET;
        dev->slave_req_fd = -1;
+       dev->did = -1;
return i;
  }
@@ -311,6 +312,20 @@ vhost_destroy_device(int vid)
  }
void
+vhost_set_vdpa_did(int vid, int did)
+{
+       struct virtio_net *dev = get_device(vid);
+
+       if (did < 0)
+               return;
+
+       if (dev == NULL)
+               return;
+
+       dev->did = did;
+}
+
+void
  vhost_set_ifname(int vid, const char *if_name, unsigned int if_len)
  {
        struct virtio_net *dev;
@@ -614,3 +629,13 @@ rte_vhost_rx_queue_count(int vid, uint16_t qid)
return *((volatile uint16_t *)&vq->avail->idx) - vq->last_avail_idx;
  }
+
+int rte_vhost_get_vdpa_did(int vid)
+{
+       struct virtio_net *dev = get_device(vid);
+
+       if (dev == NULL)
+               return -1;
+
+       return dev->did;
+}
diff --git a/lib/librte_vhost/vhost.h b/lib/librte_vhost/vhost.h
index 2e28e4026..2970c1eab 100644
--- a/lib/librte_vhost/vhost.h
+++ b/lib/librte_vhost/vhost.h
@@ -19,6 +19,7 @@
  #include <rte_rwlock.h>
#include "rte_vhost.h"
+#include "rte_vdpa.h"
/* Used to indicate that the device is running on a data core */
  #define VIRTIO_DEV_RUNNING 1
@@ -239,6 +240,12 @@ struct virtio_net {
        struct guest_page       *guest_pages;
int slave_req_fd;
+
+       /*
+        * Device id to identify a specific backend device.
+        * It's set to -1 for the default software implementation.
+        */
+       int                     did;

Same as for struct vhost_user_socket, it would be less confusing to
prefix it with vdpa.

  } __rte_cache_aligned;
@@ -365,6 +372,8 @@ void free_vq(struct vhost_virtqueue *vq); int alloc_vring_queue(struct virtio_net *dev, uint32_t vring_idx); +void vhost_set_vdpa_did(int vid, int did);
+
  void vhost_set_ifname(int, const char *if_name, unsigned int if_len);
  void vhost_enable_dequeue_zero_copy(int vid);
  void vhost_set_builtin_virtio_net(int vid, bool enable);

Reply via email to