<snip>
> > On Tue, Jan 19, 2021 at 04:52:19PM +0100, Thomas Monjalon wrote: > > 19/01/2021 15:56, Juraj Linkeš: > > > From: Thomas Monjalon <tho...@monjalon.net> > > > > 15/01/2021 14:26, Juraj Linkeš: > > > > > Add Arm SoC configuration to Arm meson.build and add a meson > > > > > option to enable those options for native builds. This is > > > > > preferable to specifying a cross file when doing aarch64 -> > > > > > aarch64 builds, since the cross file specifies the toolchain as well. > > > > > > > > > > Signed-off-by: Juraj Linkeš <juraj.lin...@pantheon.tech> > > > > > Reviewed-by: Honnappa Nagarahalli > <honnappa.nagaraha...@arm.com> > > > > [...] > > > > > --- a/config/arm/arm64_graviton2_linux_gcc > > > > > +++ b/config/arm/arm64_graviton2_linux_gcc > > > > > [properties] > > > > > -implementor_id = '0x41' > > > > > -implementor_pn = '0xd0c' > > > > > -max_lcores = 64 > > > > > -max_numa_nodes = 1 > > > > > -numa = false > > > > > +soc = 'graviton2' > > > > [...] > > > > > --- a/meson_options.txt > > > > > +++ b/meson_options.txt > > > > > +option('arm_soc', type: 'string', value: '', > > > > > + description: 'Specify if you want to build for a particular > > > > > +aarch64 Arm SoC when building on an aarch64 machine.') > > > > > > > > This is more elegant, I like how cross and native share almost the same > option. > > > > > > > > Why the option is named "arm_soc" and not just "soc"? > > > > The same option could be used by other archs, isn't it? > > > > > > Agree that a more generic name would be better. > > > I'll change it to "soc" if there are no other suggestions. > > > > Another name could be "machine". > > Should it be the same mechanism as compiling for a specific x86 CPU > > from an x86 machine? > > > I'd rather not re-use the term "machine", for a new use, better to use a new > term IMHO. +1, agree. 'soc' sounds good to me.