2014-10-31 01:39, Zhang, Helin: > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > > 2014-10-28 00:37, Zhang, Helin: > > > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > > > > 2014-10-22 19:53, Helin Zhang: > > > > > +#define RTE_BIT_WIDTH_64 (CHAR_BIT * sizeof(uint64_t)) > > > > > > > > How can it be different of 64? > > > > Using 64 would be simpler to understand than RTE_BIT_WIDTH_64. > > > > > > > > > + uint8_t reta[RTE_BIT_WIDTH_64]; /**< 64 redirection table > > > > > entries. */ > > > We always try to use macro in code to replace numeric, this can get the > > > numeric > > more understandable. > > > > How bit width 64 is more understandable than 64? > > Especially when you count a number of entries, not a bit width. > > RETA_ENTRIES_MAX would be more understandable. > > Renaming the macro is needed. I plan to rename it to RTE_RETA_GROUP_SIZE, > as it is a group of 64 reta entries, but not the maximum number of valid > entries.
OK, good. -- Thomas