On Mon, 24 Aug 2026 15:55:41 GMT, Markus Grönlund <[email protected]> wrote:
>> src/hotspot/share/cds/lambdaProxyClassDictionary.cpp line 325:
>>
>>> 323:
>>> InstanceKlass* caller_ik, TRAPS) {
>>> 324:
>>> 325: EventClassLoad class_load_event;
>>
>> I wonder if this EventClassLoad should be called JfrEventClassLoad?
>
> All the JFR events and their names are machine-generated from the
> jfr/metadata/metadata.xml file. That would entail changing the type names of
> all JFR events, across the entire VM.
I wouldn't want that. Thanks.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/32218#discussion_r3852536392