On Mon, 24 Aug 2026 13:04:32 GMT, Markus Grönlund <[email protected]> wrote:

>> Greetings,
>> 
>> Please see the problem description and rationale in the JIRA issue.
>> 
>> Testing: jdk_jfr, stress testing, tier1 - 6
>> 
>> Thanks
>> Markus
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Markus Grönlund has updated the pull request incrementally with one 
> additional commit since the last revision:
> 
>   Correct merge error.

The hotspot side looks good.  I had a question about the EventClassLoad name.

src/hotspot/share/cds/lambdaProxyClassDictionary.cpp line 325:

> 323:                                                                          
>    InstanceKlass* caller_ik, TRAPS) {
> 324: 
> 325:   EventClassLoad class_load_event;

I wonder if this EventClassLoad should be called JfrEventClassLoad?

src/hotspot/share/jfr/support/methodtracer/jfrMethodTracer.cpp line 245:

> 243:     const bool is_loaded = existing_ik->is_loaded();
> 244:     MutexLocker lock(ClassLoaderDataGraph_lock);
> 245:     if (!is_loaded && 
> placeholder_table()->contains(JfrTraceId::load_raw(existing_ik))) {

This must be a different placeholder than classfile/placeholders.hpp I hope.

-------------

PR Review: https://git.openjdk.org/jdk/pull/32218#pullrequestreview-5009744819
PR Review Comment: https://git.openjdk.org/jdk/pull/32218#discussion_r3845082963
PR Review Comment: https://git.openjdk.org/jdk/pull/32218#discussion_r3845064280

Reply via email to