On Mon, 24 Aug 2026 15:44:43 GMT, Coleen Phillimore <[email protected]> wrote:

>> Markus Grönlund has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Correct merge error.
>
> src/hotspot/share/cds/lambdaProxyClassDictionary.cpp line 325:
> 
>> 323:                                                                         
>>     InstanceKlass* caller_ik, TRAPS) {
>> 324: 
>> 325:   EventClassLoad class_load_event;
> 
> I wonder if this EventClassLoad should be called JfrEventClassLoad?

All the JFR events and their names are machine-generated from the 
jfr/metadata/metadata.xml file. That would entail changing the type names of 
all JFR events, across the entire VM.

> src/hotspot/share/jfr/support/methodtracer/jfrMethodTracer.cpp line 245:
> 
>> 243:     const bool is_loaded = existing_ik->is_loaded();
>> 244:     MutexLocker lock(ClassLoaderDataGraph_lock);
>> 245:     if (!is_loaded && 
>> placeholder_table()->contains(JfrTraceId::load_raw(existing_ik))) {
> 
> This must be a different placeholder than classfile/placeholders.hpp I hope.

Of course.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32218#discussion_r3845170317
PR Review Comment: https://git.openjdk.org/jdk/pull/32218#discussion_r3845173713

Reply via email to