On Thu, 9 Jan 2025 19:39:34 GMT, Archie Cobbs <aco...@openjdk.org> wrote:

>> Severin Gehwolf has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Review feedback
>
> (Getting into marginal returns on comments here, so my apologies for 
> nitpicking)
> 
> The loop could be simplified even further...
> 
> while (true) {
>     int bytesRead1 = is1.readNBytes(buf1, 0, buf1.length);
>     int bytesRead2 = is2.readNBytes(buf2, 0, buf2.length);
>     if (!Arrays.equals(buf1, 0, bytesRead1, buf2, 0, bytesRead2))
>         return false; 
>     if (bytesRead1 == 0)
>         return true;
> }

@archiecobbs @AlanBateman Any thoughts? Is this good to go? Thanks!

-------------

PR Comment: https://git.openjdk.org/jdk/pull/23014#issuecomment-2586767737

Reply via email to