>>> On 15.01.19 at 13:52, <pu...@hygon.cn> wrote:
> On 2019/1/15 1:17, Jan Beulich wrote:
>>>>> On 20.12.18 at 14:14, <pu...@hygon.cn> wrote:
>>>       if ( (boot_cpu_data.x86_vendor == X86_VENDOR_INTEL ) ||
>>> +         (boot_cpu_data.x86_vendor == X86_VENDOR_HYGON ) ||
>>>            (boot_cpu_data.x86_vendor == X86_VENDOR_AMD ) )
>>>           ret = cpufreq_add_cpu(cpuid);
>>>       else
>> 
>> At the very least here I think you want to change to switch().
>  
> I think there is no need to change if() to switch(), because if() looks
> concise enough here. Also the change will generate a bigger patch.

There may not be a strict need, but such recurring comparisons
generally read better when coded as switch().

Jan



_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

Reply via email to