On Sun, Jun 30, 2024 at 02:02:52PM +0000, Michael Kelley wrote: > 1) Rename is_swiotlb_buffer() to swiotlb_find_pool(), since it > now returns a pool. A NULL return value indicates that the > paddr is not an swiotlb buffer. > > 2) Similarly, rename is_xen_swiotlb_buffer() to > xen_swiotlb_find_pool() > > 3) The existing swiotlb_find_pool() has the same function signature, > but it is used only where the paddr is known to be an swiotlb buffer > and hence always succeeds. Rename it to __swiotlb_find_pool() as > the "internal" version of swiotlb_find_pool().
Sounds good. > 4) Do you still want is_swiotlb_buffer() as a trivial wrapper around > the new swiotlb_find_pool(), for use solely in dma_direct_need_sync() > where only a Boolean is needed and not the pool? If there is really just a single caller left we can skip the wrapper, otherwise it might be handy.