On Wed, Oct 08, 2014 at 10:48:36PM +0200, Przemyslaw Marczak wrote: > Hello, > This piece of code was a base for prepare my presentation talk > for the U-Boot Mini Summit, which taking place at ELCE2014 conference, > 13-th October 2014 Dusseldorf, Germany. > > The tittle of talk: "Power(full) framework based on Driver Model" > > The presentation will be shared after the Summit. > > This patchset introduces the new one PMIC framework for the U-Boot. > It is still under the construction, but the basic functionality was > achieved and tested. Please feel free to comment and share the opinion. > > I think that each patch is described full enough, but for some more design > details, please look into the documentation file. It includes some basic > examples for the PMIC drivers. > > Quick summary of: > Framework: > - The new approach - UCLASS_PMIC - simple and designed for device I/O only > - Add new uclass types: UCLASS_PMIC and UCLASS_PMIC_REGULATOR > - Two uclass drivers for above types > - A common regulator operations - will easy cover the real devices design > > Drivers: > - Introduce new PMIC API for drivers - now everything base on "struct udevice" > - Introduce Regulator Voltage descriptors and Operation Mode descriptors > which are usually taken from the device tree (board dependent data) > - Two uclass device drivers for MAX77686(PMIC+REGULATOR) > > User Interface: > - command pmic, unchanged functionality and ported to the driver model > - command regulator(NEW) for safe regulator setup from commandline, > - now can check output Voltage and operation mode of the regulators, > - also can check the board Voltage limits and driver available modes > > The future plans: > - Wait for the I2c Driver Model implementation > - Introduce a common way to bind pmic devices - now done by alias "pmic" > - Add additional uclass types: MUIC, CHARGER, BATTERY, MFD and maybe more. > - Introduce optimal operations for new uclasses > - Port all U-Boot drivers to the new Framework > - Remove the old drivers and the old PMIC Framework code > > The assumptions of this work is: > - Add new code to independent files > - Keep two Frameworks as independent and without conflicts > - Don't mix OLD/NEW Framework code - for the readability > - Port all drivers using new API > - Remove the old Framework and the old drivers > > A disadvantage: > - some parts of the present code is duplicated > > Need help: > - After merge this, it is welcome to help with driver porting. > - Everything should be tested > > The extra feature: > The first commit introduces errno_str() function. > It is a common function which I hope will be usefull for commands and not > only. > If any visible error says: -19 or some other magic number, then it means that > this function should be used. > > U-Boot Mini Summit members: > This code is maybe not as good as it could be, but the time was limited, > and the conference is comming soon. I don't expects a code review of this > now, but it would be nice if you take a look of this piece of code before > our U-Boot Mini Summit. Of course it depends on you.
Per the mini-summit, please add a patch adding yourself as pmic custodian (so something to doc/git-mailrc, shoot me your patchwork username and Detlev an ssh key so we can get a repo setup). For this series, I'm going to review/ack and I want Simon to pick it up for the DM tree since I think that makes the most sense, yes? Thanks! And for all the patches in the series I don't reply to, they seem fine but aren't for me to ack (being board specific stuff, that looked fine but I don't have the HW) or I just agree with Simon's comments. -- Tom
signature.asc
Description: Digital signature
_______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot