On Wed, 20 Nov 2024 14:53:54 GMT, Kevin Walls <kev...@openjdk.org> wrote:
>> Remove redundant SecurityManager, AccessController references >> (following on from JDK-8338411: Implement JEP 486: Permanently Disable the >> Security Manager). >> >> src/jdk.management/share/classes/com/sun/management/internal/GarbageCollectionNotifInfoCompositeData.java >> There is an existing theoretical path where GcInfoBuilder stays null, should >> never happen, "com.sun.management.GcInfo" exists... >> >> src/jdk.management/share/classes/com/sun/management/internal/GcInfoCompositeData.java >> Similarly there is an existing assumption that >> Class.forName("com.sun.management.GcInfo") succeeds. > > Kevin Walls has updated the pull request incrementally with one additional > commit since the last revision: > > Remove a Util.checkControlAccess src/jdk.management/share/classes/com/sun/management/internal/VirtualThreadSchedulerImpls.java line 62: > 60: @Override > 61: public final void setParallelism(int size) { > 62: Util.checkControlAccess(); Dropping this means that we don't need setParallelism in the base class no need for implSetParallelism. In its place we just rename implSetParallelism to setParallelism in the subclasses. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/22155#discussion_r1850469072