On Wed, 23 Oct 2024 05:42:34 GMT, David Holmes <dhol...@openjdk.org> wrote:

>> Patricio Chilano Mateo has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Address David's comments to ObjectMonitor.hpp
>
> src/hotspot/share/runtime/objectMonitor.hpp line 299:
> 
>> 297:   // Simply set _owner field to new_value; current value must match 
>> old_value.
>> 298:   void      set_owner_from_raw(int64_t old_value, int64_t new_value);
>> 299:   // Same as above but uses tid of current as new value.
> 
> By `tid` here (and elsewhere) you actually mean 
> `thread->threadObj()->thread_id()` - right?

It is `thread->vthread()->thread_id()` but it will match 
`thread->threadObj()->thread_id()` when there is no virtual thread mounted. But 
we cache it in thread->_lockd_id so we retrieve it from there. I think we 
should probably change the name of _lock_id.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21565#discussion_r1813525449

Reply via email to