On Thu, 10 Oct 2024 13:13:14 GMT, Roman Kennke <rken...@openjdk.org> wrote:
>> William Kemper has updated the pull request with a new target base due to a >> merge or a rebase. The pull request now contains 478 commits: >> >> - Fix merge error >> - Merge remote-tracking branch 'jdk/master' into great-genshen-pr-redux >> - Merge remote-tracking branch 'jdk/master' into great-genshen-pr-redux >> - Merge branch 'shenandoah/master' into great-genshen-pr-redux >> - Merge >> - 8341099: GenShen: assert(HAS_FWD == _heap->has_forwarded_objects()) >> failed: Forwarded object status is sane >> >> Reviewed-by: kdnilsen >> - 8341485: GenShen: Make evac tracker a non-product feature and confine it >> to generational mode >> >> Reviewed-by: kdnilsen, ysr >> - Merge >> - 8341042: GenShen: Reset mark bitmaps for unaffiliated regions when >> preparing for a cycle >> >> Reviewed-by: kdnilsen >> - 8339616: GenShen: Introduce new state to distinguish promote-in-place >> phase as distinct from concurrent evacuation >> >> Reviewed-by: kdnilsen, shade, ysr >> - ... and 468 more: https://git.openjdk.org/jdk/compare/b9db74a6...4db1e0e1 > > src/hotspot/share/gc/shenandoah/heuristics/shenandoahHeuristics.hpp line 79: > >> 77: >> 78: protected: >> 79: static const uint Moving_Average_Samples = 10; // Number of samples to >> store in moving averages > > I've never seen that style for constants in HotSpot before. I'd either make > it MOVING_AVERAGE_SAMPLES or MovingAverageSamples. I think the latter is more > prevalent, but I am not certain. Oh but I see that it's used in this source file. Hmm... So maybe stick with it for now and make a follow-up change? ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1795404177